Jump to content

amitxox

Members
  • Content count

    144
  • Joined

  • Last visited

Posts posted by amitxox


  1. Amit, 5.0.1 is not a fully functioning version. I posted a fuller and better script a few posts back and THEN I posted modifications to that script.

     

    I'm going to try to get a full package added to the contributions tomorrow. Hopefully, it'll work as well for others as it does for me.

    I guess I will wait for the full package then and just do a clean install. Until then I have domestic working.

     

    Will be checking.

     

    Amit


  2. Debbie or Jetta,

     

    If I send you my usps.php file can you tell me where to start. I feel i might have done manual updates everytime a chance came and might have an older version. I want to know if I should just go ahead and update to it 5.0.1 and start talking the same language that you guys are talking. I do have the domestic rates working at this time its just the international rates that are not working.

     

    Thanks

     

    Amit

     

    I am at a point with fulluvscent that domestic is working, no handing fee, no transit times, but now international is producing the: An error occured with the USPS shipping calculations

     

    Just did soe major comparing and testing, hopefully she (yes she!) can help me out here.. if it works on her server and mine we may have a winner..


  3. anyone know anything about this ? not being able to edit and change settings on any of the modules ? it just goes back to what the previous version without the change was.

     

    Don't know when this happened or what caused this but I am unable to update any of my installed modules using the edit button. For eg. if I want to start free shipping and go to the order total module and say enable free shipping to true and then click update it does not happen and it goes back to default. Some how I am not being able to update the modules ?

     

    Any one, any idea of what might be going on ? This is strange and might have happened after I installed the discount coupon code contribution.

     

    Your feedback is appreciated.

     

    Thanks

     

    Amit


  4. Don't know when this happened or what caused this but I am unable to update any of my installed modules using the edit button. For eg. if I want to start free shipping and go to the order total module and say enable free shipping to true and then click update it does not happen and it goes back to default. Some how I am not being able to update the modules ?

     

    Any one, any idea of what might be going on ? This is strange and might have happened after I installed the discount coupon code contribution.

     

    Your feedback is appreciated.

     

    Thanks

     

    Amit


  5. Toyicebear,

     

    1. What is the latest PayPal IPN Module and what might be the advantages over PayPal IPN v2.3.3 which is what we currently have installed ?

     

    2. Is there a contribution or does the latest PayPal Module Transfer the store Order Details to PayPal specifically,

     

    a) Items details and not just the total (i.e Itemized order)

    Transfer the shipping details to automatically fill the paypal shipping form ?

     

    Please do let me know if there is a module that might do this or if there are contributions we could install to make things easier.

     

    Thanks in advance for your help.

     

    Amit

     

     

    As Burt has already mentioned.....

     

    For RC2 and RC2a you dont't need to install PayPal IPN.

     

    Its already included in the shop....

     

    In Rc2/Rc2a the IPN module is named PayPal Standard

     

     

    So just go to modules >> payment in your shop admin install/enable PayPal standard and add in the required info and you are good to go....


  6. Hello All,

     

    I hope someone can update me on the status of the latest PayPal IPN Module. We have had a store for a while now using PayPal IPN as our primary mode of payment and I had a couple of questions:

     

    1. What is the latest PayPal IPN Module and what might be the advantages over PayPal IPN v2.3.3 which is what we currently have installed ?

     

    2. Is there a contribution or does the latest PayPal Module Transfer the store Order Details to PayPal specifically,

     

    a) Items details and not just the total (i.e Itemized order)

    Transfer the shipping details to automatically fill the paypal shipping form ?

     

    Please do let me know if there is a module that might do this or if there are contributions we could install to make things easier.

     

    Thanks in advance for your help.

     

    Amit


  7. Jack

     

    Any sites with header tags working. I wanted to show my programmer some examples. Let me know.

     

    Amit

     

    The sizes are controlled by the h1 and h2 classes as you mention. If the changes are installed as directed, I can't think of why the won't work.

     

    For the other problem, that is because you didn't copy, copied the code outside of or overwrote a php delimiter (<?php and ?>). You'll need to compare the changes in the instructions with those made to the file having the error.

     

    Jack


  8. Guys,

     

    Can you suggest some sites which might be running Header Tags SEO so I can see how it should look like and how the titles and tags change with the product or category information.

     

    Thanks

     

    Amit

     

     

     

    Jack.. I did add sort numbers and they had no effect.. not until I changed the code from this (in catalog/includes/header_tags.php) did it finally work as it should.. with still a slight hiccup in the admin section with respect to sort orders (below)

     

    // ALL OTHER PAGES NOT DEFINED ABOVE
     default:
    $header_tags_array['title'] = tep_db_prepare_input($defaultTags['default_title']);
    $header_tags_array['desc'] = tep_db_prepare_input($defaultTags['default_description']);
    $header_tags_array['keywords'] = tep_db_prepare_input($defaultTags['default_keywords']);
    break;
     }

     

    to this

     

    // ALL OTHER PAGES NOT DEFINED ABOVE
     default:
    $pageTags_query = tep_db_query("select * from " . TABLE_HEADERTAGS . " where page_name like '" . basename($PHP_SELF) . "' and language_id = '" . (int)$languages_id . "'");
    $pageTags = tep_db_fetch_array($pageTags_query);  
    
    $sortOrder['title'][0] = $pageTags['page_title'];
    $sortOrder['description'][0] = $pageTags['page_description']; 
    $sortOrder['keywords'][0] = $pageTags['page_keywords'];
    $sortOrder['logo'][0] = $pageTags['page_logo']; 
    
    if ($pageTags['append_default_title'] && tep_not_null($tmpTags['def_title'])) $sortOrder['title'][$pageTags['sortorder_title']] = $tmpTags['def_title'];
    if ($pageTags['append_default_description'] && tep_not_null($tmpTags['def_desc'])) $sortOrder['description'][$pageTags['sortorder_description']] = $tmpTags['def_desc'];
    if ($pageTags['append_default_keywords'] && tep_not_null($tmpTags['def_keywords'])) $sortOrder['keywords'][$pageTags['sortorder_keywords']] = $tmpTags['def_keywords'];
    if ($pageTags['append_default_logo'] && tep_not_null($tmpTags['def_logo_text']))  $sortOrder['logo'][$pageTags['sortorder_logo']] = $tmpTags['def_logo_text'];
    
    FillHeaderTagsArray($header_tags_array, $sortOrder);  
    break;
     }

     

     

    As for the sort orders.. I get these errors..

     

    Error Duplicate sort orders are not allowed -> buy.php

    Error Duplicate sort orders are not allowed -> buy.php

    Error Duplicate sort orders are not allowed -> buy.php

     

    I put in a sort order of 2 for the title and sort order of 2 for description.. I dont see why this is a problem..

     

    However, with the change in code above.. specific page titles are now being appended by the default page titles.. this wasnt happening before..


  9. pretty much everything fixed but i see a drop down menu appear on top for catalog. i don't know how and where to remove that. anyone have any ideas ?

     

    thx

     

    amit

     

     

     

    i deleted those and looks like i need to delete or comment out these too in all the header,footer, application_top and application_bottom files too ? is that correct.

     

    stuff like this. because if i dont its looking for these in all the panel files.

     

    //require(STS_STOP_CAPTURE);

     

    // Print everything out

    //require(STS_DISPLAY_OUTPUT);

     

    thanks for your help.


  10. Yes.

    What is happening is that your store is looking for the older STS files that you no longer have. If you still had the files, you would still get the errors because your store would be getting mixed signals on which STS files to use.

    i deleted those and looks like i need to delete or comment out these too in all the header,footer, application_top and application_bottom files too ? is that correct.

     

    stuff like this. because if i dont its looking for these in all the panel files.

     

    //require(STS_STOP_CAPTURE);

     

    // Print everything out

    //require(STS_DISPLAY_OUTPUT);

     

    thanks for your help.


  11. You still need to remove all of the STS define statements in the configure.php file. This was part of STS prior to STSv4.

    // STS: ADD: Define Simple Template System files
     define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php');
     define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php'); 
     define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php');
     define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/');
     define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html'); 
     define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php');
     define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php');
     define('STS_PRODUCT_INFO', DIR_WS_INCLUDES . 'sts_product_info.php');
      // STS: EOADD

     

    so i should remove all the above ?


  12. Hi Bill,

     

    I did upgrade to the STS 4.5 but this is what is happening. It is looking for my old files in the old location. What do I need to do ?

     

    Here is the message I am getting when I try to load my pages.

     

    Template file does not exist: [includes/sts_template.html]

    Warning: main(includes/sts_start_capture.php) [function.main]: failed to open stream: No such file or directory in /home/dzignzc/public_html/catalog/includes/application_top.php on line 524

     

    Fatal error: main() [function.require]: Failed opening required 'includes/sts_start_capture.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dzignzc/public_html/catalog/includes/application_top.php on line 524

     

    Any ideas ?

     

    Please do let me know.

     

    Thanks

     

    Amit

     

     

    Yes, remove all instances of the old STSv2 from your store. Save your sts_user_code.php (only if you added any custom tags to that file) and template files (html pages).

     

    Install the latest version of STS and then add any custom tags that you had in your previous setup. You can use your old STS template pages by creating a template folder called something like "mytemplates" in the catalog/includes/sts_templates/ folder.

     

    If you want to use any of the content template and infobox template features, you will need to create a folder called "content" and "boxes" within your newly created "mytemplates" folder as so: catalog/includes/sts_templates/mytemplates/content

    catalog/includes/sts_templates/mytemplates/boxes

     

    :thumbsup: If your templates use any of the "outdated" tags, you will need to replace them with thier new counterparts. Look in the STS User Manual for more details.

     

    Have fun,


  13. Yes, remove all instances of the old STSv2 from your store. Save your sts_user_code.php (only if you added any custom tags to that file) and template files (html pages).

     

    Install the latest version of STS and then add any custom tags that you had in your previous setup. You can use your old STS template pages by creating a template folder called something like "mytemplates" in the catalog/includes/sts_templates/ folder.

     

    If you want to use any of the content template and infobox template features, you will need to create a folder called "content" and "boxes" within your newly created "mytemplates" folder as so: catalog/includes/sts_templates/mytemplates/content

    catalog/includes/sts_templates/mytemplates/boxes

     

    :thumbsup: If your templates use any of the "outdated" tags, you will need to replace them with thier new counterparts. Look in the STS User Manual for more details.

     

    Have fun,

    thanks bill, this will be a good project for me because i am not that web savvy but i think i will take it up.

     

    ill try it somewhere else first. will my stylesheet still work ? or do i have to create a new one ?


  14. I don't use STSv2 since it is really outdated but I do remember that version already had Header Tag Controller support integrated in.

     

    With that said, both contributions have matured since that time and it really isn't worth it to try to work out any issues with them. The best solution if it is available to you would be to scrap the older STS/HTC and then install the latest of each onto your store.

     

    :thumbsup: You may even need to update your osCommerce files as well if you haven't been keeping up the the MS2 releases.

    is there a step by step procedure to that updrage from v2.01 to 4.5 and can i use my sts_template.html file still and not lose any changes with the new version ?"


  15. what is involved in upgrading from an old sts version of the template to the latest one ? i have sts version 2.01 and because of that i am not being able to add new stuff on the site because all the contributions are done for version 4.

     

    can any one help ?

     

    thanks

     

    amit


  16. I was having the same problem you where having except when I added that attribute to my HTML tag it did not fix the problem. I went into boxes/categories.php removed this line

    <!-- categories //-->
             <tr>
               <td>

     

    For some reason the categories box is no longer in a table of its own. I decided to test this out using a fresh install of OSC 2.2 RC1 with STS 4.5.7. Using the default "full" template from sts. It is causing the same problem.

     

    here it is.:

    http://dev.overlandgears.com/osc/index.php

     

    Of course this only happens when use infobox templates is turned on.

    what is involved in upgrading from an old sts version of the template to the latest one ? i have sts version 2.01 and because of that i am not being able to add new stuff on the site because all the contributions are done for version 4.

     

    can any one help ?

×