Jump to content

ozEworks

Partner
  • Content count

    1,440
  • Joined

  • Last visited

Everything posted by ozEworks

  1. ozEworks

    USPS Rate V4, Intl Rate V2 (official support thread)

    See this thread http://forums.oscommerce.com/topic/391303-notice-usps-is-updating-their-apis-jan-27th-2013-test-servers-available-now/
  2. USPS did an upgrade that went into effect 27.01.2013. THey renamed some otpions. Go to this thread so we can keep it altogether. http://forums.oscommerce.com/topic/391303-notice-usps-is-updating-their-apis-jan-27th-2013-test-servers-available-now/
  3. For the Parcel Post change you need to update the usps.com code to replace "Parcel Post" with "Standard Post". Once you update you need to uninstall and reinstall the module to get the correct names into the database configuration file. For International changes, maybe the file I am looking at is old but the lines I have are: 'First-Class Mail Int Lrg Env' => 'First-Class Mail regimark International Large Envelope**', 'First-Class Mail Int Package' => 'First-Class Mail regimark International Parcel**', 'First-Class Mail Int Letter' => 'First-Class Mail regimark International Letter**' so I am not sure what has to change. It is: 'First-Class Mail Int Package' => 'First-Class Mail regimark Package International Service**',
  4. We recently installed the latest version of http://www.oscommerce.com/community/contributions,487 and notice the same thing. First Class Parcel is not being offered even though the order weight is less than 13 oz.
  5. ozEworks

    FedEx - Web Services v9

    Just an update on the above issue. It relates to LIST rates and only the FedEx International Economy and Priority rates.
  6. ozEworks

    FedEx - Web Services v9

    A US based customer has advised that orders from Canada are coming thru as zero cost. The order is using FedEx (International Ecomony). Right now I am not sure when this issue started. It could be a V9.2 issue or could be earlier. We will test that on another site using 9.1 and see.
  7. ozEworks

    FedEx - Web Services v9

    The new version 9.2 has been loaded Allows you to choose List (published/public) prices or Account (your) prices. Allows you to use a Flat Rate or Percentage Handling Fee including negative values. Examples: 1. 10% off List Rates You can choose List rates and then give them 10% off them by entering -10% in handling fee 2. 20% on top of Account Rates You can choose Account Rates and then add 20% on top by entering 20% in the handling fee. If you are upgrading then all youshould need to do is uninstall, replace the main includes/modules file, then reinstall.
  8. ozEworks

    FedEx - Web Services v9

    The only plan that we have is to allow you to 1. choose List or Account Rates 2. Add a Handling Fee as a Percentage or Flat Rate. This change will be released next week some time. Any other changes is up to the rest of the community.
  9. ozEworks

    FedEx - Web Services v9

    No. It is a separate password and it is emailed to the your FedEx account email address.
  10. ozEworks

    FedEx - Web Services v9

    There is only one file for this module. fedexwebservices.php. Try uncommenting the debug lines such as //print_r($request['WebAuthenticationDetail']); //print_r($request['ClientDetail']); //exit; to see how far it gets.
  11. ozEworks

    FedEx - Web Services v9

    The module works on RC2a. We've implemented in numerous client sites. It is not possible that it is calling the wrong FedEx URL. Any issues have to be specific to your site. It is either how y ou installed it or some incompatibility with your specific site setup. If it was me I would uninstall the module in Admin, delete all files and folders. Delete all related configuration entries from my database. Then repeat the installation making sure I put all files in the correct location - specifically the additional/new folders, reconfigure and see what happens. You also need to look in your error log. If the site is not displaying an error then it may be that an error is being logged in error_log. If not then you are going to haev to debug your checkout_shipping process to see where it is stopping.
  12. ozEworks

    FedEx - Web Services v9

    Since it works in Admin it points to the specific functions in the module not working. That points to either it not being installed properly or not being configured properly. You claim that it is installed properly with all files in the right place and is configured properly. In which case it has to be some other issue relating to the checkout shipping page or your hosting environment. Since the only known hosting issue is SOAP and you say it is installed that leaves the actual checkout shipping page. The checkout shipping page invokes all active shipping modules. The FedEx module passes parameters to FedEx. You could try getting a new production key. See if that helps. Otherwise you will need to debug the checkout shipping page to see what is going on. How does it react if NO shipping modules are turned on?
  13. ozEworks

    FedEx - Web Services v9

    Forestshopkeeper, you don't need to turn off ftp to be PCI compliant. If McAfee scans insist you do then that is their jsut their own rules. There is nothing in the PCI Guidelines that say you cannot have ftp or for that matter SSH open on your server. As to your problem I am guessing that since you mention the Admin Order Editor you have customized your site code. Did you modify checkout?
  14. ozEworks

    FedEx - Web Services v9

    Dsolutions, actually the way it is set up, it is supposed to show the LIST rates but there is a bug in the code that means it actually uses the ACCOUNT rates. ozEworks are looking into it now and we'll be loading a new version maybe later this week.
  15. ozEworks

    FedEx - Web Services v9

    You don't have to turn off ftp to be PCI compliant. We have this module working on Rc2a. I don't know of other posts that talk about it. You did not say if you checked the sort order of your shipping modules. They need to be all unique. If you can see it in Admin and not on the site then it points to it not actually being installed properly. Perhaps when it goes to call something in the other folders. So you might want to check yout setup again. Also check your error log to see if there is an error message there.
  16. ozEworks

    FedEx - Web Services v9

    There is really no need to load each file one by one. If you just load the includes folder via ftp it will load everything in the right place. Apart from configuring it in Admin then is nothing more to add. Anyone looking for more documentation than that needs read the FedEx documentation there. http://www.fedex.com/us/developer/product/WebServices/MyWebHelp/ For detailed information see http://www.fedex.com/us/developer/product/WebServices/MyWebHelp/Utilities/c_RateCodingDetails.html#/us/developer/product/WebServices/MyWebHelp/Transactions/WS/r_RateRequestElements.html Forestshopkeeper, if you have more than one shipping module turned on then make sure they each have a unique sort order. Anyone else, if you come here looking for help and then resolve your problem it would be a good idea to then post how you fixed it in order to help others.
  17. ozEworks

    FedEx - Web Services v9

    It is configured in the module in Admin. Make sure you have PRODUCTION keys and not TEST keys. You cannot use the same valuesfor both.
  18. osCommerce is a core eCommerce solution that is meant to be taken and built upon. Any development by the team is from a technical perspective. Functional development is up to the individual and/or community.

  19. ozEworks

    FedEx - Web Services v9

    Roaddoctor, FedEx did not supply this Add On. Someone from over at ZenCart generously provided it. It is up to the osCommerce community to continue its development. Savierrnr, your path "/home/theholy4/public_htmlincludes/library/fedex-common.php5 is missing a / between the public_html and the includes.
  20. ozEworks

    FedEx - Web Services v9

    If you don't need FedEx long term then I suggest you do what the other person suggested and adjust the Canada Post handling fee to try and cover any additional costs to send via FedEx. Or install the old FedEx module.
  21. ozEworks

    FedEx - Web Services v9

    You need to ask your hosting. How well they respond in a crisis is an indicator of how good a hosting company they are. They don't sound too good to me.
  22. ozEworks

    FedEx - Web Services v9

    If you read this topic ou will see that there is a program called soap_test.php which you can run to test if soap is working on your server.
  23. ozEworks

    FedEx - Web Services v9

    Can't you set up the zone module to work with Canada Posts rates?
  24. ozEworks

    FedEx - Web Services v9

    Easiest thing to do is change hosting. Use of SOAP is becoming increasingly common in web services so a hosting company that refuses to install it is not eCommerce friendly.
  25. ozEworks

    FedEx - Web Services v9

    Yes I realise that is looks like a comment but I don't know why they included it when telling you what to do. I was wondering if it was implying something. You do really need to speak to them and escalate beyond first level support.
×