Jump to content

florence_dave

Members
  • Content count

    24
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Dave
  • Interests
    Biz
  1. Hi Everyone, I'm trying to integrate Individual Product Shipping Prices - v2.0 MS 2.2 with Ajeh's SECv2.2. I'm pretty new to all this stuff, but decided to give it a shot. There is a piece of code that is a duplicate of some changes made by SEC. It is tep_get_configuration_key_value. I took a flyer and tried to rename the IndvidShipping code to new_tep_get_configuration_key_value and changed it in all appropriate files (I think ) I get the following errors: Fatal error: Call to undefined function: new_tep_get_configuration_key_value() in /home/jewelryi/public_html/includes/classes/shipping.php on line 54 Here is the code from the \includes\classes\shipping.php OF: WebMakers.com Added: Downloads Controller - Free Shipping and Payments // Show either normal shipping modules or free shipping module when Free Shipping Module is On // Free Shipping Only if ( (tep_get_configuration_key_value('MODULE_SHIPPING_FREESHIPPER_STATUS')=='1' and $cart->show_weight()==0) ) { $include_modules[] = array('class'=> 'freeshipper', 'file' => 'freeshipper.php'); } else { // All Other Shipping Modules while (list(, $value) = each($this->modules)) { $class = substr($value, 0, strrpos($value, '.')); // Don't show Free Shipping Module if ($class !='freeshipper') { $include_modules[] = array('class' => $class, 'file' => $value); } } } // EOF: WebMakers.com Added: Downloads Controller - Free Shipping and Payments } // BOF: Individual Shipping Prices // Show either normal shipping modules or Individual shipping module when Individual Shipping Module is On // Show Individual Shipping Only if (new_tep_get_configuration_key_value('MODULE_SHIPPING_INDVSHIP_STATUS') and $shiptotal) { $include_modules[] = array('class'=> 'indvship', 'file' => 'indvship.php'); } else { // All Other Shipping Modules while (list(, $value) = each($this->modules)) { $class = substr($value, 0, strrpos($value, '.')); // Don't show Individual Shipping Module if ($class != 'indvship') { $include_modules[] = array('class' => $class, 'file' => $value); } } } // EOF: Individual Shipping Prices } for ($i=0, $n=sizeof($include_modules); $i<$n; $i++) { include(DIR_WS_LANGUAGES . $language . '/modules/shipping/' . $include_modules[$i]['file']); include(DIR_WS_MODULES . 'shipping/' . $include_modules[$i]['file']); $GLOBALS[$include_modules[$i]['class']] = new $include_modules[$i]['class']; } } } And to add insult to injury I get this error at the end of the file. There is so little information that I'm not sure what to do with it. Parse error: parse error in /home/jewelryi/public_html/includes/classes/shipping.php on line 155 Here is the code for this: $cheapest = $rates[$i]; } } return $cheapest; } } } ?> Hope someone can help. I think I'm close, but it may be more wishful thinking than anything else. Thanks! Cheers, Dave
  2. Hi Everyone, I'm trying to integrate Individual Product Shipping Prices - v2.0 MS 2.2 with Ajeh's SECv2.2. I'm pretty new to all this stuff, but decided to give it a shot. There is a piece of code that is a duplicate of some changes made by SEC. It is tep_get_configuration_key_value. I took a flyer and tried to rename the IndvidShipping code to new_tep_get_configuration_key_value and changed it in all appropriate files (I think :blink: ) I get the following errors: Fatal error: Call to undefined function: new_tep_get_configuration_key_value() in /home/jewelryi/public_html/includes/classes/shipping.php on line 54 Here is the code from the \includes\classes\shipping.php OF: WebMakers.com Added: Downloads Controller - Free Shipping and Payments // Show either normal shipping modules or free shipping module when Free Shipping Module is On // Free Shipping Only if ( (tep_get_configuration_key_value('MODULE_SHIPPING_FREESHIPPER_STATUS')=='1' and $cart->show_weight()==0) ) { $include_modules[] = array('class'=> 'freeshipper', 'file' => 'freeshipper.php'); } else { // All Other Shipping Modules while (list(, $value) = each($this->modules)) { $class = substr($value, 0, strrpos($value, '.')); // Don't show Free Shipping Module if ($class !='freeshipper') { $include_modules[] = array('class' => $class, 'file' => $value); } } } // EOF: WebMakers.com Added: Downloads Controller - Free Shipping and Payments } // BOF: Individual Shipping Prices // Show either normal shipping modules or Individual shipping module when Individual Shipping Module is On // Show Individual Shipping Only if (new_tep_get_configuration_key_value('MODULE_SHIPPING_INDVSHIP_STATUS') and $shiptotal) { $include_modules[] = array('class'=> 'indvship', 'file' => 'indvship.php'); } else { // All Other Shipping Modules while (list(, $value) = each($this->modules)) { $class = substr($value, 0, strrpos($value, '.')); // Don't show Individual Shipping Module if ($class != 'indvship') { $include_modules[] = array('class' => $class, 'file' => $value); } } } // EOF: Individual Shipping Prices } for ($i=0, $n=sizeof($include_modules); $i<$n; $i++) { include(DIR_WS_LANGUAGES . $language . '/modules/shipping/' . $include_modules[$i]['file']); include(DIR_WS_MODULES . 'shipping/' . $include_modules[$i]['file']); $GLOBALS[$include_modules[$i]['class']] = new $include_modules[$i]['class']; } } } And to add insult to injury I get this error at the end of the file. There is so little information that I'm not sure what to do with it. Parse error: parse error in /home/jewelryi/public_html/includes/classes/shipping.php on line 155 Here is the code for this: $cheapest = $rates[$i]; } } return $cheapest; } } } ?> Hope someone can help. I think I'm close, but it may be more wishful thinking than anything else. Thanks! Cheers, Dave
  3. Hi, Just wondering if anyone is using SECv2.2 with Authorize.net and AIM? I know its set up for SIM, but would prefer to utilize AIM... I guess its more secure, faster to use and overall a better method. Please correct me if I'm wrong, I'm not that familiar with this. I've looked at some of the files that would need to be changed to make one of the AIM contributions work, but the combining of the contribution files and the SEC files looks like it might be beyond my knowledge level. If anyone has set this up already, would you be willing to share how you made it work? Thanks, Dave
  4. Hi Everyone, I fixed the problem. Just started from scratch and rebuilt. It seems to be working now. Cheers, Dave
  5. Hi Everyone, Great Contribution.... Then I mucked it up somewhere. It was working fine and now it isn't. Please help me out if possible, I'm getting this error: 1064 - You have an error in your SQL syntax near '", "", "", "", "", "", "", " 'MAX-BLAST', '175', '1', ' at line 14 INSERT INTO products ( products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( 'bags/max-blast-s.gif',bags/max-blast-b.gif", "", "", "", "", "", "", " 'MAX-BLAST', '175', '1', CURRENT_TIMESTAMP, "0000-00-00 00:00:00", "0000-00-00 00:00:00", '', '0', '10', '11') Also, I was just going to live with this, but since I'm asking the above question, I'll ask this next one also. How can I set up my EZpopulate upload so that my images will show at the category level. That is when I click on a category all the images for the subcategories show up. For some reason, if I input manually it works, if I upload with EZpopulate, it doesn't. Thanks for all the effort everyone puts in on this board. I'm still a newbie, but hope to be able to contribute once I get this site launched and am up the learning curve a bit. Cheers, Dave
  6. florence_dave

    has anyone tried Articles Module v1.0?

    Hi Everyone, Hope you can help, because I've had no luck finding enough on the forum to help me fix my issues. I installed SEC 2.2 last week and had it working correctly. Now I'm working on adding the Article_module_v0222. So far I've had no luck getting the site to work properly after attempting this. When I go to my catalog page I get the following: Fatal error: Cannot redeclare tep_get_manufacturers_name() (previously declared in /home/jewelryi/public_html/includes/functions/webmakers_added_functions.php:172) in /home/jewelryi/public_html/includes/functions/articles_general.php on line 141 When I go to my admin page I get the following: Warning: main(includes/articles_filenames.php): failed to open stream: No such file or directory in /home/jewelryi/public_html/dante/includes/filenames.php on line 106 Fatal error: main(): Failed opening required 'includes/articles_filenames.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/jewelryi/public_html/dante/includes/filenames.php on line 106 I've looked at the install instructions and believe I have everything set up as it should be. Could it be a compatibility issue with Articles and SEC? I am fairly new to this stuff, so maybe I'm missing something obviouse. Please help if you can. Cheers, Dave
  7. florence_dave

    Simple Template System (STS)

    Thanks! I got it working. I had mistyped the path and left off a "/". Cheers, Dave
  8. florence_dave

    Simple Template System (STS)

    Hi, Hope you can help. I'm completely new to this stuff and have no idea if this is an easy fix or not. Hopefully it falls into the silly question/easy answer catagory. I'm trying to instal STS 1.2 and using osCommerce 2.2MS2 and linux. I had a clean install (after much work :) ) and I'm now trying to add some contributions. My first is STS. I've run forum searches for this error, but I haven't found a match. I'm getting the following error: Parse error: parse error in /home/miniatur/public_html/catalog/includes/configure.php on line 18 Warning: main(DIR_WS_INCLUDESfilenames.php): failed to open stream: No such file or directory in /home/miniatur/public_html/catalog/includes/application_top.php on line 53 Fatal error: main(): Failed opening required 'DIR_WS_INCLUDESfilenames.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/miniatur/public_html/catalog/includes/application_top.php on line 53 Here are line 18 & 53 from the catalog/index.php file. I hope this is helpful: Line 18 $categories_products_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS_TO_CATEGORIES . " where categories_id = '" . (int)$current_category_id . "'"); Line 53 <?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> On a side note, can anyone recommend some other good contributions to add into osCommerce after I get STS up and running? Thanks for your help, Dave
×