Latest News: (loading..)

kymation

Community Sponsor
  • Content count

    9,672
  • Joined

  • Last visited

  • Days Won

    118

kymation last won the day on April 21

kymation had the most liked content!

About kymation

  • Rank
    Code Monkey
  • Birthday 09/25/1950

Profile Information

  • Real Name
    Jim Keebaugh
  • Gender
    Male
  • Location
    Aberdeen WA USA
  • Interests
    Just about everything.
  • Website

Recent Profile Visitors

125,156 profile views
  1. The Modular Product Page Addon uses the products class to get the data. I retrieves all of the data from the products tables, so there is no need to modify the SQL query. I don't know about that last line in the replacement code. It should probably go in the template (catalog/includes/modules/content/product_info/templates/cm_pi_name.php) but I don't know where that $header_tags_array gets defined. You could try something like global $header_tags_array; $product_info->products_name = $header_tags_array['title_alt']; at the top of that file. Regards Jim
  2. You can post a question in the Commercial Support forum to get paid help. Regards Jim
  3. I forced a package update and install of Pale Moon, which updated me to Version 27.3.0. The bug is still present. The console is still showing the same bug on the same line, but now it points to Column 66 of the above line of JavaScript. I'm out of ideas. Regards Jim
  4. @Harald Ponce de Leon I can't get it to fail in Firefox anymore, but Pale Moon still consistently fails. I tried removing all Addons and deleted cookies, but there is no change. I see that you installed Pale Moon manually, so you have a different version than I do. You might try deleting your install and installing from the repository. That should give you the same version (27.1.0) which may make a difference. I'm accessing the site with HTTPS, and I've tried forcing a refresh and closing the browser and restarting. Nothing seems to help. Any suggestions ware welcome. Regards Jim
  5. The bug seems to always appear when using the Pale Moon browser [Version: 27.1.0 (64-bit)] .It sometimes works and sometimes doesn't in Firefox [53.0.2 (64-bit)]. It always works in Chromium [Version 58.0.3029.110]. All tests done on Linux Mint 18.1 64-bit fully patched. The developer's console shows the following error whenever I try to use the Reply editor: TypeError: instance is null https://forums.oscommerce.com/uploads/javascript_global/root_framework.js.d5a7afeef43d3baa452cb65e94f50556.js?v=4b4a088aba Line 314 Line 314 of the referenced file is: if(minimized){var _unminimize=function(){$(elem).find('.ipsComposeArea_dummy').hide().end().find('[data-role="mainEditorArea"]').show().end().closest('.ipsComposeArea').removeClass('ipsComposeArea_minimized').find('[data-ipsEditor-toolList]').show();if(instance.status=='ready'){minimized=false;callback();if(hiddenAtStart){resize(true);hiddenAtStart=false;}}else{instance.once('instanceReady',function(){minimized=false;callback();if(hiddenAtStart){resize(true);hiddenAtStart=false;}});} If you need more info for a bug report just ask. Regards Jim
  6. I checked in the developers console, and I get "TypeError: instance is null" every time I try to start the editor. I suspect there's some broken Javascript in this editor. Now I really do need to get back to work.... Regards Jim
  7. Hi Dan I should have mentioned that I'm running the Linux version. That often makes a difference. I can get it to work in Incognito mode, so I may just have an old cookie that's causing problems. I'll try to do more debugging later -- I need to do some work now. Regards Jim
  8. Email notification is now working, so whatever you did worked. I'll try adding an image of the reply box here. Also, I thought that we lost the @Harald Ponce de Leon mention thing, but it's still there, just different. Regards Jim
  9. I'm not receiving any email notices for updates in posts that I follow or have commented in. This comment box doesn't work at all in Firefox. I just get a paperclip icon and the greyed-out word "Loading...". That last one is really bad. I'm less likely to comment if I have to go open another browser and copy the URL over. Regards Jim
  10. It's impossible to say for certain without knowing which version of osCommerce you are using. Log into your Admin and navigate to Tools -> Version Checker. If that doesn't exist, navigate to Tools -> Server Info and look near the top for the osCommerce version. There's a database schema included with every version of osCommerce. Once you know your version, download the package and look in the Docs folder (for v2.3x) or the Extras folder (for 2.2x). That will give you all of the relations between tables. If you're having trouble reading it, post your version here and we'll help. Regards Jim
  11. To simplify that a bit: $cart_products = $cart->get_products( true ); $last_item = end( $cart_products ); Regards Jim
  12. That site doesn't look like osCommerce 2.3.x. It looks a lot like an old 2.2 version, with lots of tables for formatting. You can change the formatting of the New Products box, but you'll have to do some hacking on the core code. I think there is an Addon to change that format. Is this a new installation? If it is, I would advise you to dump it and replace it with the 2.3.4 Responsive version. If it is an old store, consider upgrading. That old 2.2 code will probably stop working soon, when your host upgrades to a modern version of PHP/MySQL. Regards Jim
  13. osCommerce 2.2 MS2 is vintage 2003. Very few of us remember much about that ancient code. We can try to help, but upgrading it to run on a modern server would be a huge task. Even if you were to accomplish this, you would then be stuck updating your custom codebase every time your host upgrades. As @@14steve14 said, you probably got hit by a PHP upgrade, or possibly a MySQL upgrade. I suggest that you first check your PHP error log and fix whatever is there. It would take far less time and effort to port over your products and customers tables and start over with the latest version of osCommerce. Your store will look and work better as well. Regards Jim
  14. Does the file includes/classes/hooks.php exist on your server? Install it if it's not there. Regards Jim
  15. Try this code in place of the second block you provided: if( $shipping_weight > 150 ) $this->enabled = false; You'll need the global in your first block of course. Regards Jim