Jump to content

Ralph2

Members
  • Content count

    29
  • Joined

  • Last visited

Everything posted by Ralph2

  1. Ralph2

    Payment Type Charge

    This is the topic to discuss Payment Type Charge contribution. Download link follows.
  2. This is the support thread for the RSS Feed contribution. The contribution can be found and downloaded here: RSS Feed.
  3. For those who use the osCommerce PayPal IPN Module v1.0 For 2.2MS2 module: This module suffers from a bug which doesn't place a customer's comment (entered during the order process) in the confirmation email. Thanks to an inspirational post on the Dutch osC forum, by user Job, the solution has been found: 1 - If you're using this particular module, then open ipn.php. 2 - Find: // lets start with the email confirmation // $order variables have been changed from checkout_process to work with the variables from the function query () instead of cart () in the order class $email_order = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $_POST['invoice'] . "\n" . EMAIL_TEXT_INVOICE_URL . ' ' . tep_href_link(FILENAME_ACCOUNT_HISTORY_INFO, 'order_id=' . $_POST['invoice'], 'SSL', false) . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . strftime(DATE_FORMAT_LONG) . "\n\n"; if ($order->info['comments']) { $email_order .= tep_db_output($order->info['comments']) . "\n\n"; } 3 - And replace this with: // lets start with the email confirmation // $order variables have been changed from checkout_process to work with the variables from the function query () instead of cart () in the order class $comment_query = tep_db_query("select comments from " . TABLE_ORDERS_STATUS_HISTORY . " where orders_id = '" . $_POST['invoice'] . "'"); $commentfetch = tep_db_fetch_array($comment_query); $comments = $commentfetch['comments']; $email_order = STORE_NAME . "\n" . EMAIL_SEPARATOR . "\n" . EMAIL_TEXT_ORDER_NUMBER . ' ' . $_POST['invoice'] . "\n" . EMAIL_TEXT_INVOICE_URL . ' ' . tep_href_link(FILENAME_ACCOUNT_HISTORY_INFO, 'order_id=' . $_POST['invoice'], 'SSL', false) . "\n" . EMAIL_TEXT_DATE_ORDERED . ' ' . strftime(DATE_FORMAT_LONG) . "\n\n"; if ($comments) { $email_order .= $comments . "\n\n"; } Done :)
  4. Sure, just open catalog/admin/includes/languages/english/categories.php and find: define('TEXT_PRODUCTS_WEIGHT', 'Products Weight:'); Add under it: define('TEXT_PRODUCTS_RSS', 'Add this product to the RSS feed:'); Regarding the unchecked products, verify whether an unchecked / checked checkbox stays unchecked / checked after you've updated / saved the settings of a product. If the checkbox "remembers" its last setting, then your DB and the catalog\admin\categories.php file are working correctly. In that case you might want to try to replace the following (in rss.php): $sql = 'SELECT p.products_id, products_model, products_image, products_date_added FROM products p, products_to_categories pc WHERE p.products_id = pc.products_id AND pc.categories_id = \'' . $category . '\' AND products_status=1 ORDER BY RAND() DESC LIMIT ' . MAX_RSS_ARTICLES; } else { $sql = 'SELECT products_id, products_model, products_image, products_date_added FROM products WHERE products_status=1 ORDER BY RAND() DESC LIMIT ' . MAX_RSS_ARTICLES; } With: $sql = 'SELECT p.products_id, products_model, products_image, products_date_added FROM products p, products_to_categories pc WHERE p.products_id = pc.products_id AND pc.categories_id = \'' . $category . '\' AND products_status=1 AND products_to_rss=1 ORDER BY RAND() DESC LIMIT ' . MAX_RSS_ARTICLES; } else { $sql = 'SELECT products_id, products_model, products_image, products_date_added FROM products WHERE products_status=1 AND products_to_rss=1 ORDER BY RAND() DESC LIMIT ' . MAX_RSS_ARTICLES; Success!
  5. Hey, I checked your feed output with a validator and it says the following: This feed is valid, but may cause problems for some users. We recommend fixing these problems. Don't worry, it works fine. I wouldn't bother to dive into the code for this. I've seen big websites with the same validator result. About the '&' symbol, if you don't like using 'and' then try to use: & Maybe the validator takes it.
  6. You're welcome. I'm glad it works :thumbsup:
  7. @ David: Via a .htaccess rewrite: didn't work. Via a SEO contribution (e.g. Ultimate SEO URLs): should be possible, but I don't have the time to figure out how. With some php: works, though it doesn't come up with a .html URL (like Ultimate SEO URLs does for example). But it does get rid of the "?language=en" part and it's very easy to implement. I don't have the time to work it out completely, but the following should get you started (and it looks like it's working fine): Open catalog/includes/filenames.php and add the following code to it (for each language): define('FILENAME_RSS_EN', 'rss-english.php'); Then rename / copy rss.php to rss-english.php (repeat this step for each language). Open for example catalog/index.php, go to the link rel code and replace: <?php if (!isset($lng) || (isset($lng) && !is_object($lng))) { include(DIR_WS_CLASSES . 'language.php'); $lng = new language; } reset($lng->catalog_languages); while (list($key, $value) = each($lng->catalog_languages)) { ?> <link rel="alternate" type="application/rss+xml" title="<?php echo STORE_NAME . ' - ' . BOX_INFORMATION_RSS; ?>" href="<?php echo FILENAME_RSS, '?language=' . $key; ?>"> <?php } ?> With: <?php if (!isset($lng) || (isset($lng) && !is_object($lng))) { include(DIR_WS_CLASSES . 'language.php'); $lng = new language; } reset($lng->catalog_languages); while (list($key, $value) = each($lng->catalog_languages)) { if ($key == 'en') { $rss_link = FILENAME_RSS_EN ?> <link rel="alternate" type="application/rss+xml" title="<?php echo STORE_NAME . ' - ' . BOX_INFORMATION_RSS; ?>" href="<?php echo $rss_link; ?>"> <?php } } ?> Now the browser RSS icon should be linking to an URL which looks like: http://www.kjhsdflskdflsjkdf.com/rss-english.php. The only thing you've to do is to get it working with multiple languages and the info box link. Good luck :) @ Michael: Good luck :)
  8. @ Michael (mkelly1) I'm glad that random products works correct :D Nope, if you've updated your DB and the files correctly, then it should work. I'm not using an English shop, so I'm not really sure about the names of the settings. But you'll get an idea of where to look: Just go to your admin section -> Catalog -> Articles -> and edit or add an article. On the edit/add article page there should be a checkbox (Add this product to the RSS feed:) under the 'weight' textfield. It's that bit of code above the </head> tag within your php files of the catalog directory. The code that makes browsers light up or show their RSS icon. You need to change all of the files which contain the old code. Look for the files with the following bit of code in them: <link rel="alternate" type="application/rss+xml" title=" Oh, I think you've made a copy/paste mistake. No problem, according to Roaddoctor the code wasn't working correctly anyway. Just read my answer to Roaddoctor for the correct code. @ David (Roaddoctor) At least the link rel is working correct now :thumbsup: The new info box problem is probably caused because its whole code is now within the code of the language code. And the lang. code makes as many links as there are languages, which is now happening to the whole info box. Anyway, I've some new code for the info box which automatically selects the current language as selected by the user. Start with a 'fresh' information.php file and follow the following steps: Find: ?> <!-- information //--> Replace with: // Recover the code (en, fr, etc) of the current language if ($HTTP_GET_VARS['language'] == '') { $lang_query = tep_db_query('select code from ' . TABLE_LANGUAGES . ' where directory = \'' . $language . '\''); } else { $cur_language = tep_db_output($HTTP_GET_VARS['language']); $lang_query = tep_db_query('select code from ' . TABLE_LANGUAGES . ' where code = \'' . $cur_language . '\''); } $lang_a = tep_db_fetch_array($lang_query); $lang_code = $lang_a['code']; ?> <!-- information //--> Find: '<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a>'); Replace with: '<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a><br>' . '<a href="' . FILENAME_RSS . '?language=' . $lang_code . '">' . BOX_INFORMATION_RSS . '</a>'); Despite the fact that I believe that this code works fine, could you please let me know whether that's also the case with a multi language shop? Thanks in advance :thumbsup: BTW, could you / someone please check whether the footer link works correctly with multiple languages? It should display 1 RSS icon (with a link based on the selected language) in the footer, but I've a feeling it'll display 1 RSS icon for each available language. If the code from the installation guide (@ step 7) indeed causes multiple icons to appear in the footer, you might try the following code: Open a 'fresh' catalog/includes/footer.php file and find: require(DIR_WS_INCLUDES . 'counter.php'); Replace with: require(DIR_WS_INCLUDES . 'counter.php'); if ($HTTP_GET_VARS['language'] == '') { $lang_query = tep_db_query('select code from ' . TABLE_LANGUAGES . ' where directory = \'' . $language . '\''); } else { $cur_language = tep_db_output($HTTP_GET_VARS['language']); $lang_query = tep_db_query('select code from ' . TABLE_LANGUAGES . ' where code = \'' . $cur_language . '\''); } $lang_a = tep_db_fetch_array($lang_query); $lang_code = $lang_a['code']; Find: <td class="footer"> <?php echo strftime(DATE_FORMAT_LONG); ?> </td> <td align="right" class="footer"> <?php echo $counter_now . ' ' . FOOTER_TEXT_REQUESTS_SINCE . ' ' . $counter_startdate_formatted; ?> </td> Replace with: <td class="footer"> <?php echo strftime(DATE_FORMAT_LONG); ?> </td> <td align="center" class="footer"><a href="<?php echo FILENAME_RSS, '?language=' . $lang_code; ?>" title="<?php echo BOX_INFORMATION_RSS; ?>"><?php echo tep_image(DIR_WS_IMAGES . "icons/rss_icon.jpg" , STORE_NAME . " - " . BOX_INFORMATION_RSS); ?></a></td> <td align="right" class="footer"> <?php echo $counter_now . ' ' . FOOTER_TEXT_REQUESTS_SINCE . ' ' . $counter_startdate_formatted; ?> </td> It would be really great if someone can verify whether this piece of code works correctly with a multi language shop! If the code works correct, then I can update the contribution knowing that it works correctly in combination with multi language shops. Thanks in advance!
  9. Solutions: Random products: Find (in rss.php): $sql = 'SELECT p.products_id, products_model, products_image, products_date_added FROM products p, products_to_categories pc WHERE p.products_id = pc.products_id AND pc.categories_id = \'' . $category . '\' AND products_status=1 ORDER BY products_id DESC LIMIT ' . MAX_RSS_ARTICLES; } else { $sql = 'SELECT products_id, products_model, products_image, products_date_added FROM products WHERE products_status=1 ORDER BY products_id DESC LIMIT ' . MAX_RSS_ARTICLES; } Replace with: $sql = 'SELECT p.products_id, products_model, products_image, products_date_added FROM products p, products_to_categories pc WHERE p.products_id = pc.products_id AND pc.categories_id = \'' . $category . '\' AND products_status=1 ORDER BY RAND() DESC LIMIT ' . MAX_RSS_ARTICLES; } else { $sql = 'SELECT products_id, products_model, products_image, products_date_added FROM products WHERE products_status=1 ORDER BY RAND() DESC LIMIT ' . MAX_RSS_ARTICLES; } Add or remove products from a feed: Please, check out v1.2. NOTE: In case you've already ran adminsetting.sql, your DB might not accept adminsettings.sql because of duplicate data. In that case you can run the following sql in your DB: ALTER TABLE products ADD products_to_rss TINYINT default '1' NOT NULL Problematic link rel: Replace the following: <link rel="alternate" type="application/rss+xml" title="<?php echo STORE_NAME . ' - ' . BOX_INFORMATION_RSS; ?>" href="<?php echo tep_href_link(FILENAME_RSS, 'language=' . $key, 'NONSSL', false); ?>"> With: <link rel="alternate" type="application/rss+xml" title="<?php echo STORE_NAME . ' - ' . BOX_INFORMATION_RSS; ?>" href="<?php echo FILENAME_RSS, '?language=' . $key; ?>"> The tep_href_link function might be the cause of the problematic link rel, I removed it and it seems to work fine. Please note that I can't test it on a shop with multiple languages, since my shop utilizes only 1 language. Could you / someone please let me know whether the link rel works correctly with multiple languages now? Thanks! Information box link: Open catalog/includes/boxes/information.php file: Find: ?> <!-- information //--> Replace with: if (!isset($lng) || (isset($lng) && !is_object($lng))) { include(DIR_WS_CLASSES . 'language.php'); $lng = new language; } reset($lng->catalog_languages); while (list($key, $value) = each($lng->catalog_languages)) { ?> <!-- information //--> Find: $info_box_contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_SHIPPING) . '">' . BOX_INFORMATION_SHIPPING . '</a><br>' . '<a href="' . tep_href_link(FILENAME_PRIVACY) . '">' . BOX_INFORMATION_PRIVACY . '</a><br>' . '<a href="' . tep_href_link(FILENAME_CONDITIONS) . '">' . BOX_INFORMATION_CONDITIONS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a>'); Replace with: $info_box_contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_SHIPPING) . '">' . BOX_INFORMATION_SHIPPING . '</a><br>' . '<a href="' . tep_href_link(FILENAME_PRIVACY) . '">' . BOX_INFORMATION_PRIVACY . '</a><br>' . '<a href="' . tep_href_link(FILENAME_CONDITIONS) . '">' . BOX_INFORMATION_CONDITIONS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a><br>' . '<a href="' . FILENAME_RSS . '?language=' . $key . '">' . BOX_INFORMATION_RSS . '</a>'); Find: new infoBox($info_box_contents); Replace with: new infoBox($info_box_contents); } The info box link appears to be working fine with a 1 language shop. Could you / someone please let me know whether the info box link works correctly with multiple languages now? Thanks! Many thanks to all of you for your patience :thumbsup:
  10. Ok, time for a new round of advice :) @ mkelly1: I'm sorry, but I didn't have the time to work out something regarding the randomization of the feed. But I'll check it out as promised. Nice looking shop by the way. Anyway, tomorrow I'll add a new feature to the contribution, which will give the admin the possibility to decicde whether or not a certain product should be added to the feed simply by checking or unchecking a checkbox. Tomorrow I'll look for a solution. Regarding the info box issue: that particular link is build in an array, which makes it impossible to add the code needed for the verification of the languages. There are 2 solutions for this problem: 1 - Each language gets its own link. 2 (this'll look better) - Take the link out of the array and build it in a similar way as the footer link.
  11. Ah, that should be possible. I'll try it this week. I'll keep you posted.
  12. Hello people, I see it's getting busy here :) Sorry for my late reply, but I didn't have the time to get back here sooner. My answers to your questions: Just follow effisk's advice (Post: #35), and you'll solve the problem. Another solution: Open the file adminsetting.sql and look for '80', just gradually increase this number (and run the SQL again after each increase) until your DB takes it. Each time you add new products to your shop, these will be automatically added to your feed. So, the feed updates automatically. It should be possible to hard code something like that in rss.php. But in the end it's the user's feed reader which sorts everything out based on the user's settings. Maybe there're feed readers out there which make it possible to randomize feeds. I know for sure that some feed readers can filter on categories, IE7's feed reader can do that for example. In order to make it possible for feed readers to filter products on categories, I just updated the contribution: contribution
  13. Since the timezone is correct in your feed's source, I think that the timezone of your database or server is incorrect. This causes the feed to display the incorrect time for each article, despite the fact that your feed is using the correct timezone. It's just a matter of a wrong input (e.g. database time) which results in a wrong output (e.g. feed time). Anyway, I've just tried something which might correct the incorrect dates of your feed. You can set the timezone for rss.php with a little bit of php. But first I would like to advice you to change: $added = $row['products_date_added']; Back to: $link = tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $id, 'NONSSL', false); So your feed is rss 2.0 valid again. After that you need to find the following in rss.php: $navigation->remove_current_page(); Replace it with: $navigation->remove_current_page(); putenv("TZ=US/Eastern"); Notice that in the above code the TZ (timezone) is US/Eastern. I've tried this piece of code myself with rss.php and it does indeed change the timezone. The only thing you've to do is to replace US/Eastern with a +8GMT timezone, e.g.: Asia/Hong_Kong. If the time is still incorrect, then try some other timezones until you've found one which sets the correct time in your feed. Oh, and make sure you're using the proper timzone formats, otherwise the code won't work properly.
  14. That there could be something wrong with the time setting, did cross my mind too. But I reasoned that such a problem woudn't effect the functioning of the links. But who knows, maybe it does in some way. So, you might want to focus on: $added = date(r,strtotime($row['products_date_added'])); And maybe on: <lastBuildDate><?php echo date(r); ?></lastBuildDate> The first line obviously formats and outputs the "product's added to the shop on" date. The second is pretty obvious too, as it outputs the build date of your feed. Before you're going to make any modifications to these lines of code, I would like to suggest that you first verify whether the dates within your feed are indeed incorrect. To do that, just go to your feed with (I guess) IE7 and check the source of your feed. I suspect you know how to check the source of a website which is displayed by IE. In case someone doesn't know: right click on the website / feed and click on "View source". Once the source of your feed is being displayed, check whether the dates are correct for your timezone. For example; I'm in the GMT +01:00 timezone, which makes the dates in the source look like: generated on Thu, 22 Mar 2007 10:03:53 +0100 (the date at which the feed was build for that last time) and: <pubDate>Sun, 28 Jan 2007 22:21:29 +0100</pubDate> (the date at which a product was added to the feed/shop) Notice the +0100 at the end of both dates, this shows that the dates within my feed are correct for the GMT +01:00 timezone. If your timezone and the +0100 part of your feed's dates do not match, then you can be quite sure that your feed is indeed experiencing timezone issues. This is quite possible since with some PHP versions the time code of rss.php (strtotime and possibly date( r)) functions incorrectly. Since I don't know whether your feed displays an incorrect build date, I'll focus on the "product added" date. Find: $added = date(r,strtotime($row['products_date_added'])); Replace with: $added = $row['products_date_added']; If your feed's dates are indeed incorrect because of strtotime, then the above suggestion might solve the problem. The only disadvantage is that your feed's dates will no longer validate as proper rss 2.0, but it should be working fine. In fact, the original script uses the same code, though it'll validate with the original script since it ouputs a feed based on an older rss version. I hope this helps.
  15. Ok, at least we now know for sure that the problem isn't version related. I still think it has something to do with the database / sql... maybe you can check whether the sql parts in rss.php are calling the correct tables. I'm very sorry, but at this point I don't know of any other possible solutions. Maybe you can give me a link to your site? Because I might get some new ideas when I see it for myself.
  16. That's indeed a bit strange. Well, I guess you've already tried the unsubscribe thing and that that didn't solve the problem either.' Did you try an older version of this contribution? Because if an older version works then at least we can be sure that your problem is version related. I'll keep an eye on this thread...
  17. It looks like the feed is pulling the time / data from a wrong or possibly deleted database record. I've a few questions for you: 1 - Are you using an updated version of your old rss.php? Is so, try the original rss.php as included with v1.0. 2 - Green arrow... I suppose you're using IE7. If you hold the mouse cursor over the green arrow, does the URL / link which shows up at the bottom of your browser look something like: http://yourwebshop.com/product_info.php?products_id=93 If not, could you please show me the URL / link which your browser comes up with when holding the cursor over the green arrow? 3 - Is the product still in your database or did you remove it? If the message you stated is displayed on the product_info.php, which pretty much means the green arrow link itself is working fine, you might want to verify this. I'm asking this because IE7 displays removed products as old articles in the feed, until they are pushed away by new products / articles. This means that when you click on such an old feed article, your shop's database can't find the product which leads to the message being displayed on product_info.php. In order to get an up to date feed in IE7, you have to unsubscribe from your shop's feed and reload the feed without being subscribed to it. That way you'll prevent deleted products from being displayed as old (and thus not working) articles in your feed. If the links work correctly after you did that, then your feed is working fine.
  18. I'm glad you solved the first problem. I'm just wondering; are you using the rss.php file as inluded with the v1.0 package or did you only update the rss.php which you were already using? You see, I noticed "products_price" within your error. While all references to the products_price, $price etc are actually removed since v1.0. Possible solution: try it with the original v1.0 rss.php. I hope that that'll solve your last problem.
  19. The code places a line like: <link rel="alternate" type="application/rss+xml" title="Myshop.com - Catalogus Feed" href="http://myshop.com/rss.php?language=en"> within the head of your webshop's pages containing the code. As soon as RSS supporting browsers like IE7 and Firefox read such a line in a page header, they notify a visitor of your website that there's a RSS feed available to them. The notification itself is usually done via an orange RSS icon which shows up (Firefox) or starts to glow (IE7). Since the notification is only activated if a page contains the code in its head, it's recommandable to place the php code in all the pages (with a head tag!) located within your catalog folder. Since the pages located in your catalog folder can be seen by visitors. So, if you want to maximize the change of visitors noticing your shop's RSS feed, it's recommandable to use the code. But you don't have to.
  20. Ralph2

    RSS contribution

    Duplicate items? Here's the solution: First the cause: Duplicate items within the RSS feed are caused due to the fact that the links within the feed contain a session ID (e.g. osCsid=some unique number). This means that each time the feed is reloaded by a feed reader, the links within the feed receive a new session ID. This causes a feed reader (like the feed reader function of IE 7) to "think": "Hey, those links are new. So, the items they are linking to must be new too. Let's add all the items as new / unread items. Oh, I'm so smart." Wrong! The links aren't new, only the session ID numbers at the end of the links are "new". Solution: Get rid of those session IDs at the end of the links of your feed. Just follow the following steps: Open rss.php and find: $link = tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $id); Replace with: $link = tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $id, 'NONSSL', false); 'NONSSL' tells the tep_href_link function to build a non SSL link, leave the NON out if you prefer a SSL link. And false tells the tep_href_link function to leave the session ID out of the link that has to be build. That's all folks!
  21. Ralph2

    NEW! Complete Order Editing Tool!

    Note: If you change an order's payment method to banktransfer using Order Editor, hit the update button first in order to store the new payment method to your database and then hit it a second time with the "Send new confirmation" box selected in order to email the updated confirmation.
  22. Ralph2

    NEW! Complete Order Editing Tool!

    I'm a bit late, but better late than never :) Thanks for the better explanation. Anyway, despite the fact that you say it's not a problem, I'll explain to you how to get the (pretty important) banktransfer info in the email. It's actually really simple: just open the language file (admin/includes/languages/yourlanguage/edit_orders.php) of the order editor and find: define('EMAIL_TEXT_PAYMENT_INFO', ''); Just type or copy your banktransfer info between the ''. So, it should look something like this: define('EMAIL_TEXT_PAYMENT_INFO', 'My bank, account number etc'); Then you'll have to verify the name which Order Editor is using for the banktransfer method. If I'm correct, this is a translated name if you're not using English language files with osC. I'm using Dutch language files for example, which means banktransfer is called "Overschrijving" within my shop. How to verify the correct name of the banktransfer method: 1- Go the your shop's admin section and open Order Editor. 2 - Look for the billing address information box and, more specifically, for the pull down menus at the bottom of this box. 3 - The left pull down menu should be filled with all of the payment methods your shop is using. So, within this box you'll have to look for the name of the payment method which stands for the banktransfer method. Maybe it's called "Banktransfer", but it probably isn't. 4 - Open edit_orders_email.php (admin/edit_orders_email.php) and find: if ($order->info['payment_method'] == 'NAMEOFPAYMENTMETHOD') { 5 - Replace 'NAMEOFPAYMENTMETHOD' with the exact name of the banktransfer method as verified at step 3. As mentioned before, within my shop banktransfer is called "Overschrijving", so in my case the line looks like: if ($order->info['payment_method'] == 'Overschrijving') { And that's it! Let me know if you're still having trouble with this.
  23. Ralph2

    NEW! Complete Order Editing Tool!

    Like djmonkey1 said; you've to hit the update button first to save the changes to the DB and then hit the update button again with the "New order confirmation" box selected. That way it should email a new confirmation mail to the customer (and a copy of it to the shop owner if the shop owner has configured osC to send copies of confirmations to an email address of the shop owner) containing the updated info. I'll upload a new version which will inform users about this through a (!)image next to the "New order confirmation" box.
  24. Ralph2

    NEW! Complete Order Editing Tool!

    I'm sorry, but I don't really understand your problem. Which information is sent? Do you mean the payment info text at the bottom of the email?
  25. Ralph2

    NEW! Complete Order Editing Tool!

    I've just uploaded version 2.9.0, which should make you're wish come true :)
×