Jump to content

all2coolnick

Members
  • Content count

    9
  • Joined

  • Last visited

Profile Information

  • Real Name
    Nick Gillard
  1. all2coolnick

    SecPay tips

    Just thought I would share our combined experience of implimenting SecPay with osCommerce for the first time as I'm sure everyone will have the same issues. 1. Ensure your store name (as specified within Admin:Configuration:My Store) has no spaces or special characters in it. The store name is used as part of the transaction reference and spaces cause it to fail. 2. When running SecPay in test mode (Account Status as specified within you account options on the SecPay web site), ensure that you have the options Mandatory CV2 and CV2 set to false. SecPay say that these options conflict with the test mode and cause transactions to fail, even if the account is set to simulate authorised transactions! You can turn these options on after the account has gone live. 3. When configuring the SecPay payment module within osCommerce Admin, you will need to add "-jredir" after the merchant ID. Log in to Admin > Modules > Payment > SECpay > click edit > Under Merchant ID type the text after your merchant id. For example if my merchant ID was: funboy01 The new ID would read: funboy01-jredir According to SECpay this makes the callback a java redirect. If you don't do this then the callback from SecPay will always fail even though the payment has gone through OK. This is because SecPay does not like the 302 code returned by checkout_process.php because it does a redirect to checkout_success.php. 4. If you have set your SecPay account to live, don't panic if it's not working. I'm not even sure why you have this option within your account setup since to get your account live, you have to contact Customer services at SecPay and request them to set the account to live and then it takes about 2 working days. In the mean time your transactions will fail with the error "cannot find tid". I Hope this saves some of you jumping through the hoops we had to to get this working.
  2. all2coolnick

    SECPAY - problems

    I had the same problem. I think you will find the solution here: http://forums.oscommerce.com/index.php?showtopic=204716 This worked for me and solved the problem in 5sec flat!
  3. all2coolnick

    SecPay module not functioning

    I had the same problem. I think you will find the solution here: http://forums.oscommerce.com/index.php?showtopic=204716 This worked for me and solved the problem in 5sec flat!
  4. all2coolnick

    Secpay Help!

    This worked for me too. I had spoken to SecPay and they had not offered a solution so thanks for sharing this.
×