Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Pixxi

Members
  • Content count

    138
  • Joined

  • Last visited

Everything posted by Pixxi

  1. Try adding this: / added to remove <td color=""> before $Title ... $content[1] = str_replace("<td color=\"\">", "", $content[1]); at the bottom of the section in the code where the rest of them are.
  2. Pixxi

    credit card number

    Have you ticked the box called 'split credit card number' and entered an email address in the credit card payment module? If you do that, the first 4 and last 4 digits will be stored in the database (and will appear in admin on the customer's order) and the middle 8 numbers will be emailed to the email address you entered. You might have to ring the customer to get the card details for your first order though. :)
  3. Pixxi

    Automatically send data feed to Froogle

    There's a listing of special characters and symbol codes Here.
  4. Pixxi

    Automatically send data feed to Froogle

    Has anyone been able to connect to hedwig.google.com via ftp in the last week or so? I'm finding all attempts are timing out but the server is responding to pings.
  5. Pixxi

    Recover Cart Sales

    Could you re-post your english.php with the formatting intact?
  6. Ooops - I meant to say you're logging in during the same browser session as different users but the previous oscID is being re-used.
  7. You need to run that section of code as an SQL 'Query' using a package such as phpmyadmin (your hosting provider may already have it installed on their servers - take a look in your CPanel/Plesk control panel)) to modify your osC database.
  8. The htmlspecialchars() error has been covered earlier in this thread. It occurs because you're logging in more than once as the same user during the same browser session and the same oscid is being re-used, which causes problems displaying addresses - you need to add a line to your logoff.php file to close the session. The line you need to add is: // added to fix ship in cart oscsid problem... tep_session_unregister('cart_address_id');
  9. Pixxi

    Recover Cart Sales

    'DB' is the MySQL database where your shop information and settings are stored. The database is created by the osCommerce installer when you install osC. The 'SQL' statement provided in the contribution adds extra information to the database that the contribution needs so it can keep track of customers and their carts. You would need to use a database admin program such as phpMyAdmin (free -and usually already installed on the server by your host) to run the SQL statement.
  10. Pixxi

    Recover Cart Sales

    :blink: Didn't you mean to post that in the Ship in Cart thread...? Here: Ship in Cart thread :rolleyes:
  11. hi all Thanks again for all the hard work to the developers and the great forum. I have come up with the same problem as was previously reported. I have followed all the suggestions, and I have even down loaded another copy of the contrib. and copied over my cc.php file with fresh one, but when I enter in a 4 digtit cvv number I get a java script error saying. I have a client how has a customer how is trying to use an American express card and it has 4 cvv digests on the front of the card but it will not let them make a payment. Help Thanks for any segestions So far as I know it's not intended for Amex, so only checks for 3 digits in the CVV in the validation code. You can do a search on your catalog folder for 'cvv' and change any occurrences of '3' for '4' in the validation code, but that may then allow people with visa, etc. to accidentally enter 4 digits ... so you may need to tie that into the validtion checking depending on the card issuer. :rolleyes:
  12. Where do you do this?? It's posted earlier in this thread .. Changing issue number max digits
  13. The link you give already shows photos on the allprods page - have you got it sorted now? :rolleyes:
  14. You're welcome. It's the simple things that sometimes confuse us the most ... :blink:
  15. Ok.. I am tring to install the above version of all products. Can someone explain to me what this means: Im a little lost. Add What line to these files? Can someone send me or post a set of clear instructions? Please. Thanks Tammy If you take a look in each of those files you will find the line of code that needs to be added to the existing file of that name inside your catalog folder. For example, in filenames.php (in the mod) you will find: <?php /* add the following line in your catalog/includes/filenames.php */ define('FILENAME_ALL_PRODUCTS', 'all_products.php'); // all products and used categories ?> So you find /catalog/includes/filenames.php on your PC or server and add the line in the mod to the line(s) already in that file on your PC/server. eg. in the above example you would add the line: define('FILENAME_ALL_PRODUCTS', 'all_products.php'); // all products and used categories :rolleyes:
  16. :rolleyes: Thanks for your kind words Justin, but we only identified the problem ... I think I might speak for Tim also when I say we wouldn't have had any idea how to fix it - so all the credit is yours. Excellent solution. :) I think that you should (if you want to) post the update to the mod too - for the above reason, and also because you will be able to describe the problem and the solution much better than we could. Thanks again - you saw what we didn't know what we were looking for ... :rolleyes:
  17. Thanks a million Justin, your code sorted the problem instantly! :D Sometimes the smallest things can take an age when you don't know what the problem is ... Interestingly, the cookie is still there after logout and seems to get reused by the next user/login, so I can't see how OSC keeps track of a customer unless it's based on IP, but ship in cart seems to work fine now. Thanks again :rolleyes:
  18. Htmlspecialchars() error - an update... Tim Elliott (tlelliott77) has discovered an interesting thing about this error: Ah-hah! - me too ... except in my case I have to quit/restart the browser rather than just use a new browser window. So, been doing some tests ... tried Mozilla, Netscape 7.0, IE6.0 and Mozilla Firebird so far and this happens in all of them: What seems to be happening is that the osCsid cookie is not being deleted at the end of the user's session (even though it says 'expires this session' on it), so it's being re-used for the next login/user/account creation and creates the error - presumably part of the shipincart code must be using the session ID to keep track of the customer and retrieve the customer's address array to display in the ship in cart mod ... (haven't looked at that bit yet). Try this (with a freshly started-up browser program): Login/create an account as user 1 - no error from shipincart - logout. Delete the osCSid cookie from the browser's prefs, save prefs Login/create account as user 2 using the same browser window - no error, and a new (different) oscsid cookie is created. Don't know yet who/what is responsible for deleting 'this session only' cookies - OSC or the browser. Don't quite understand either how the shop can welcome you back if the cookie has been deleted/expired at end of the session ... As Tim says, it's unlikely a customer would login/logout then immediately create a new user/account using the same browser/window, so it may not be a big problem in practice - it's just showing up for us because we're creating more than one user with the same browser/window/session as part of our testing. Would be nice to find the cause and fix it though... :rolleyes:
  19. Hi Bryanl, Thanks for your PM ... I'm not an 'expert' at all though :huh: just learning like you, but I try to help if I think I can add something... Don't know if this will help (don't know all of the things you've changed ...) but what do you have the value of GBP set to? If GBP is set as the default (which you would need to do even more if you only had GBP, of course), it needs to have a value of 1.00000000, then you might need to do an 'update' of the currencies. It might be that you haven't done anything majorly wrong ... you could try putting the other currencies back in and seeing if that restores things, then start deleting again. :rolleyes:
  20. Uh -oh ... I spoke too soon ... htmlspecialchars is back on my site too, same situation as other people are having ... 1. Create a new user, put something in cart and you get the error showing in shipincart. 2. BUT ... if you create a second address for that user, go back to the 'cart contents' screen, update the address drop-down in shipincart to the second address, then the error goes. From then on you can happily switch to either address in shipincart, log out/log-in with no error showing at all. 3. If you delete one of those two addresses (doesn't seem to matter which one) the error reappears. So it seems to need (at least in my case...) to have 2 addresses for each new user in order to work ... just spent 2 days looking over all files and putting fresh individual MS2 files in to test, no progress so far. Can't see why it works fine with 2 addresses in but not one. Interesting thing is ... this error only appeared for me when I installed shipincart, and I have one 'user' that I've been using for testing over several weeks (before I installed shipincart) and that 'user' still gives no errors with one address, so it looks like (in my case too) it's only new accounts that are being affected. Looks like it's a case of disabling it for the time being... :(
  21. Hi Read through this thread - someone has noted this problem (16 digits max) before and a code change has been posted. hth :rolleyes:
  22. What text editor are you using? If you use a word processor you may be getting invisibles in the php file when you save it. Can you post the parse error(s) here so we can see? Which orders.php do you mean? There are 2: one in catalog/admin/includes/languages/english/orders.php and one in catalog/admin/orders.php In the ... english/orders.php one, you have only to insert the defines like this in the middle somewhere and save the file (although, once again, your text editor may be causing you problems if it gives you an error once you've saved it): define('ENTRY_CUSTOMER', 'Customer:'); define('ENTRY_SOLD_TO', 'SOLD TO:'); define('ENTRY_DELIVERY_TO', 'Delivery To:'); define('ENTRY_SHIP_TO', 'DELIVER TO:'); define('ENTRY_SHIPPING_ADDRESS', 'Delivery Address:'); define('ENTRY_BILLING_ADDRESS', 'Invoice Address:'); define('ENTRY_PAYMENT_METHOD', 'Payment Method:'); define('ENTRY_CREDIT_CARD_TYPE', 'Credit Card Type:'); define('ENTRY_CREDIT_CARD_OWNER', 'Credit Card Owner:'); define('ENTRY_CREDIT_CARD_NUMBER', 'Credit Card Number:'); define('ENTRY_CREDIT_CARD_EXPIRES', 'Credit Card Expires:'); // BMC CC Mod Start define('ENTRY_CREDIT_CARD_START', 'Credit Card Start Date:'); define('ENTRY_CREDIT_CARD_ISSUE_NUMBER', 'Credit Card Issue Number:'); define('ENTRY_CREDIT_CARD_CVV_NUMBER', 'Credit Card CVV Number:'); // BMC CC Mod End define('ENTRY_SUB_TOTAL', 'Sub-Total:'); define('ENTRY_TAX', 'Tax:'); define('ENTRY_SHIPPING', 'Shipping:'); define('ENTRY_TOTAL', 'Total:'); define('ENTRY_DATE_PURCHASED', 'Date Purchased:'); define('ENTRY_STATUS', 'Status:'); define('ENTRY_DATE_LAST_UPDATED', 'Date Last Updated:'); define('ENTRY_NOTIFY_CUSTOMER', 'Notify Customer:'); define('ENTRY_NOTIFY_COMMENTS', 'Append Comments:'); define('ENTRY_PRINTABLE', 'Print Invoice'); In the catalog/admin/orders.php, the changes there are very simple again and shouldn't cause you any problems ... can you post the error you get, and the section(s) of code you've replaced with some of the surrounding code? Then again there are also two files named 'order.php' (note the 's' missing on the end) - one in catalog/includes/classes/order.php, and one in catalog/admin/includes/classes/order.php. Do you have the right mod in the right file? The email is constructed and sent in catalog/checkout_process.php, but that file also uses ('requires') catalog/includes/classes/order.php (where the customer's order is built up into an array) so you need to check how you've added the mod to both of those files. Can you post the section of code in checkout_process.php where the email is built up (from '// lets start with the email confirmation' down to the end of the file)? I've modded mine quite a bit, so that may confuse you more :blink: so maybe better if you check those files (and your text editor...?) and post the sections you've changed and the errors you're getting. Otherwise, maybe someone else can post their file for you (when they know which one you want) . :rolleyes:
  23. Well that's just a sneaky little trick to catch us newbies out ... because the defines aren't in application_top anymore, in MS2 they were split into two separate files: catalog/includes/database_tables.php, and catalog/includes/filenames.php... :blink:
  24. You upload the files contained in the mod it says to upload (that's assuming you have a stock MS2, if you've put other mods in any of those files on your install you'll need to find the differences this mod has added and add them manually) and then make the changes to the other files as the readme says. hth
  25. Searching through all the files in catalog, it would seem that tep_array_merge isn't defined anywhere and is only used in blacklist.php, although there are many instances where array_merge is used in other files. I may be wrong (I don't use the blacklist) but you could try removing the 'tep_' from the 4 instances of tep_array_merge in blacklist.php and see if that removes the error. :rolleyes:
×