Jump to content

mcdr

Members
  • Content count

    55
  • Joined

  • Last visited

Everything posted by mcdr

  1. mcdr

    [Contribution] STS v4

    Bill For reference firstly let me give you these links... Catalogue Opening Page - COP First Layer Down Sub Category - SUB Products in Sub Category - PRODLIST Products Page ...it will save on words. Contribution 2125 works as in COP but has issues in that colour changes to match background only partially work when hover on etc (STS clash?). I need to progress downward via SUB and PRODLIST to actual product page with image links as shown. You can, of course, access all the above directly via the URL shown on those page images. Clearly whilst osC Admin>Config>Images allows me to play with COP image sizes which is fine for purpose on that page, I do not want them anywhere else or image sizes in SUB dictated by that same control. Hence my original comments as to whether STS can give me a SUB page as illustrated? Grateful for any guidance or help you may be able to offer and response to my original query on $manufacturerbox and $reviewsbutton link - see http://forums.oscommerce.com/index.php?sho...381&st=2431 Michael
  2. Yes it does work exactly as stated in contribution - see my post immediately above yours. Tax is my issue and something I need to resolve. Installing was easy following instructions and with base price + attribute added, total price is shown - you have 2 choices of display - attribute changed prices only displayed or all attributes priced either as base price or total with attribute add-on. See accompanying notes in contribution. It really works well! As always backup before installing!
  3. mcdr

    [Contribution] STS v4

    I have been having a few problems since my last post (on older STS thread) - see http://forums.oscommerce.com/index.php?sho...541&st=3797 and hope you can put me on straight and narrow to get this site up in August. I have posted elsewhere for advice on getting osC main and therefore the opening STS template page with its $content placeholder to feature five main categories simply as images with title under (similar to New Products layout) which then link to page of images for products in that selected category - this time with layout just as New Products. Is there a route I can go down with STS templates or a simpler route with osC coding? Cart before the horse - I have achieved the main template layout to my specification and am content with the product page layout (as now is). There are two areas where placeholders are giving me problems - (1) $manufacturerbox (I have this under "Search by" in index left of page on link above but it does not show and (2) on same page how do I link $reviewsbutton to actual take customer to reviews? I am an amateur at this but getting there - with a little help....
  4. QTPro Visible Price Attributes Gather that "Trogette" was involved in at least part of this excellent osC Contribution. Can she (or anyone else) tell me whether BASE + ATTRIBUTE cost can be reflected in the pulldown inclusive of tax. Without that ability, if the basic price shows inclusive of tax, then having attribute added BUT WITHOUT TAX is confusing to customer! If base item price was GBP 33.00 and GBP4 added against size attribute and product was set as 'taxable' the base price on page would be GBP37.78 with tax. Adding the attribute size supplement would make at total cost of £43.48. The customer will see GBP37 in pulldown if this contribution cannot handle tax which makes for real customer confusion! Can this contribution only be used where tax is NOT included? Any ideas?
  5. I have installed QT Pro and QVAP and it works brilliantly bar one small problem. Where an item has variable size/prices using Admin>Attributes and adding say GBP 5 and the where the item is taxable, the pulldown shows the size/price variant as a total cost calculated on basic price + tax + attribute GBP 5 + NO tax which is NOT what customer will be charged and wrong. Moving to checkout the overall total cost is completely correct including tax calculation on GBP 5. Does any one know how the pulldown attribute can accurately show the total item price as at checkout? This is surely the purpose of this contribution! Ignoring tax on the extra size supplement within attributes is of little use.
  6. QT Pro and STS - Ongoing saga...... Following my earlier post on this thread, I managed to get QT Pro working absolutely find on standard osC platform. I then added the Simple Template System (STS) contribution without apparent problems. Only as I moved to create a products template did I find issues - please link to http://forums.oscommerce.com/index.php?sho...cdr&st=3797 Also see Bill Kellum's reply immediately following that post. He thinks it maybe bad QT Pro coding? Are there any other users of STS and QT Pro out there who have experienced and resolved the issues of this type? I cannot be the only person wanting osC design customised and capable of handling multi-attributes to a product. HELP! PLEASE.
  7. Earlier I had problems with QTPro & STS 4.5 which after advice from Bill Kellum and a QTPro forum contributor worked in their own right and apparently together following re-installation. I thought all was well but having created a content template, I find that three areas which work in the default osC (ie with STS off) do not do so when STS is active. These are: 1) Currency symbol (£ in this case) appears only as ? 2) The options - size, colour, etc work but fail to show "Out of stock" (part of QTPro) within pull downs and as separate text warning message. 3) Image shown with click to enlarge will not do so. The paths for the STS 'on' and 'off' screens are; ON - product_info.php?cPath=2_19&products_id=28 OFF - product_info.php?products_id=28 It seems likely that STS is the problem since the default osC page works flawlessly? Screen grabs under: Does anyone have any ideas how to rectify problem?
  8. Tracy - sorry about late reply, been away. Yes, have gone down that route and without STS, QTPro is working on clean install. Going to add STS and see what result is as my problem originally was adding QTPro with STS installed. Maybe vice versa problem will not happen! Thanks, Michael
  9. Below is posting from STS thread... STS v4.5.2 AND QT Pro v4.3 Already made posting on this subject but outside the STS v4 contribution pages so though some people have looked at that none has replied. I need to move on and need help asap! I have had STS working well using single new design html template and very happy with results. Added QT Pro contribution carefully checking that no php file clashed in either contribution. QT Pro allows for multi-attribute stock tracking. On returning to the catalogue(I have named it cart), I get the following error message: Fatal error: Call to a member function on a non-object in /home/shapely/public_html/cart/includes/header.php on line 14 Lines 12-14 of header.php shows: // START STS 4.1 $sts->restart_capture ('applicationtop2header'); // Capture header from the actual script, needed to take out javascript // END STS 4.1 Can someone help me with this. Do you think this an STS problem or QT Pro? Many thanks in advance. -------------------- Michael, have you posted this in the QT Pro thread? This appears to be a QT Pro installation issue. I just quickly browsed that thread and noticed others with the same issue even without having STS installed. Try reinstalling the QT Pro contribution as that seems to have corrected this problem for the others. Bill Kellum -------------------- Have carried out complete re-install and problem remains. Can't see if QT Pro is working ok or not. Any QTPro experts out there with any ideas?
  10. mcdr

    [Contribution] STS v4

    STS v4.5.2 AND QT Pro Already made posting on this subject but outside the STS v4 contribution pages so though some people have looked at that none has replied. I need to move on and need help asap! I have had STS working well using single new design html template and very happy with results. Added QT Pro contribution carefully checking that no php file clashed in either contribution. QT Pro allows for multi-attribute stock tracking. On returning to the catalogue(I have named it cart), I get the following error message: Fatal error: Call to a member function on a non-object in /home/shapely/public_html/cart/includes/header.php on line 14 Lines 12-14 of header.php shows: // START STS 4.1 $sts->restart_capture ('applicationtop2header'); // Capture header from the actual script, needed to take out javascript // END STS 4.1 Can someone help me with this. Do you think this an STS problem or QT Pro? Many thanks in advance.
  11. I have installed QT Pro v4.2 to track product attributes following instructions to the letter but when going to catalogue get this Fatal Error message: Fatal error: Call to a member function on a non-object in /home/shapely/public_html/cart/includes/header.php on line 14 Going to that line 13/14/15 it reads: // START STS 4.1 $sts->restart_capture ('applicationtop2header'); // Capture header from the actual script, needed to take out javascript // END STS 4.1 Can anyone help here and get catalogue/shop active again?
  12. I would like a simple column to left of my STS template created in html listing 5 categories of apparell which when clicked opens images within $contents area similar in layout to NEW PRODUCTS, ie just pictures and captions which when clicked go to product page STS template (yet to do) from whence add to cart decision or not is made. Have handled STS v4.5.2 so far with pleasing results. To progress, I need to know whether I can link html category names to catalogue so that all products in clicked category show in $content area of basic STS template, or must I rely on unattractive listing and its actions generated from $categorybox?
  13. I have installed STSv4.5 in to osC 2.2ms2 and all seemed fine until I got the message under when trying to open admin panel to complete configuration: Fatal error: Call to a member function on a non-object in /home/shapely/public_html/cart/admin/includes/functions/html_output.php on line 78 Cannot access admin panel! Not sure how this arises as html_output.php came with STS. Have tried replacing that file from STS program download several times, but still get same fatal error message. Have been back thro' pages here but see no similar error dealt with. Any ideas please someone?
  14. Posted this yesterday after installing STS v4.5 but in "Templates & Images" forum pages rather than STS specific thread.... http://forums.oscommerce.com/index.php?showtopic=260179 Can anyone with good STS knowledge help??? I am baffled!
×