Jump to content

gwynwyffar

Members
  • Content count

    58
  • Joined

  • Last visited

Profile Information

  1. gwynwyffar

    Multi_Vendor_Shipping new thread

    Can no one clarify how to properly configure this for me? The module text itself doesn't indicate how to enter states, just countries (by their ISO2 code) My Locations > Zones are set up as the default, like this: Country Zones Code United States Alabama AL United States Alaska AK United States Arizona AZ United States Arkansas AR Do I need to create zones differently?
  2. gwynwyffar

    Multi_Vendor_Shipping new thread

    I know the module can do it, what I asked was how do I fill it out so it will work for states instead of countries. I understand if I want to create Zone 1 for US and Zone 2 for the UK, I would just put US in the first zone box, and UK in the 2nd zone box. But what if I want to have Zone 1 be California, Oregon and Washington states, and Zone 2 be New York, Connecticut and Pennsylvania? Do I need to enter some sort of array? Just entering CA,OR,WA or using the full state name (California,Oregon,Washington) gives me the result "No shipping available to the selected country" I apologize if I'm missing something simple, but under Taxes>Zones I've got United States listed with all of the states, so I do not understand what isn't working.
  3. gwynwyffar

    Multi_Vendor_Shipping new thread

    Help with Zones setup. I'm looking to use the Zones module for MVS 1.2.3 which appears to have been modified to allow states as shipping zones as well as countries, however I'm having difficulty in figuring out exactly how to set up my zones in the admin side. There's no documentation as to how exactly I need to format my entries so it will allow states. If I just put in a state abbreviation (NY for example) I get the result that there's no shipping to that zone. Do I need to set up Tax Zones differently and how exactly should I format the names when entering them in the shipping module settings. I spent a fair amount of time searching this thread for the answers, but couldn't find any complete answer.
  4. gwynwyffar

    Modules missing online

    I'm having the same exact problem, but only on my local server. I recently made a copy of my live site/database so I could test some changes locally and for the life of me I cannot sort out why none of the modules are showing up. I have other virtually identical local installations of OSC running on the same wamp server environment with no issues. It just seems to be this one site Local Server: HTTP Server: Apache/2.2.11 (Win32) PHP/5.2.1 PHP Version: 5.2.1 (Zend: 2.2.0) Database: MySQL 5.0.51b
  5. gwynwyffar

    Multi_Vendor_Shipping new thread

    Adding the Vendor_id and Vendor_name to the Get1Free array seemed to do the trick. Thanks for pointing me in the right direction!
  6. gwynwyffar

    Multi_Vendor_Shipping new thread

    I'm having issues with MVS and the Get 1 Free contribution. Everything seems to work fine from the customer side of things, but where I run into a problem is on the Admin side. The "Free" item that the customer ordered does not show up on the Order, Invoice or Packing slip. The only things that show up are the items the customer would have been required to purchase to get the free item. The free item is in the database as part of that order, but I notice there is no Vendor ID attached to the free item, so I'm assuming that may be part of the issue. I'm assuming that I either need to add something to the shopping cart part of MVS to add the Get1Free item, and/or I need to add something to the admin side of MVS to show the Get1Free item. If anyone could give me some insight into what I should do, I'd appreciate it.
  7. gwynwyffar

    Get 1 Free

    I'm having a strange issue with this contribution and I expect it has something to do with the MVS shipping mod I also have installed. Everything works on the customer's end, it adds the free item, the item shows up properly all through the checkout process and even on the customer's order confirmation email, however when I view the order on the admin side it does not show the free item as part of the order at all, not on the order, the invoice or the packing slip. The only thing that it shows the customer ordered is the item they would have paid full price for. Has anyone else encountered this issue? Any insight as to where I might look to fix this? When I look at the database the free item is there as part of the order, but the admin is not reflecting it.
  8. That did the trick! Thank you very much!
  9. I did download a Complete csv file and I do not see any products without a vendor assigned. I also looked at the actual product table in the database and all products have a vendor id assigned. Is there something else I should be looking for?
  10. I've installed EP and it works for the most part, but I'm running into an error when trying to download anything other than a Complete file. For example I tried downloading a Model/Price/Qty csv file so I can updated product quantities and receive the following error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 SELECT vendors_name FROM vendors WHERE vendors_id = [TEP STOP] I have not modified the easypopulate.php file at all, other than to set the configuration. I do have MVS installed. My settings are as follows: EP vers: 2.76i-MS2 osCommerce Online Merchant v2.2 RC2a OS: FreeBSD 7.2-STABLE HTTP: Apache/2.2.15 DB: MySQL 5.0.67-log PHP: 5.2.12 (Zend: 2.2.0) Temp Directory: (removed for security) Temp Dir is Writable Magic Quotes is: off register_globals is: on Split files on: 300 records Model Num Size: 24 Price with tax: false Calc Precision: 2 Replace quotes: true Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 3 Enable attributes: false SEF Froogle URLS: false Other Support: MVS Support: true Additional Images: false More Pics: true UltraPics Pics: false HTC: false SPPC: false Extra Fields: false PDF Upload: false I'm assuming the relevant code is here: if (EP_MVS_SUPPORT == true) { $vend_result = tep_db_query("select vendors_name from ".TABLE_VENDORS." where vendors_id = " . $row['v_vendor_id'] . ""); if ($vend_row = tep_db_fetch_array($vend_result)) { $row['v_vendor'] = $vend_row['vendors_name']; } } But I just don't see an error with it.
  11. gwynwyffar

    FEDEX METER ID ISSUES Where is it

    That looks more like you missed running something with the fedex.sql or you missed a modification on your categories.php page where you would indicate whether products ship together or separately. It has nothing to do with your Meter ID. You do not have to enter a meter ID with the FedEx module, just your account number and make sure the address you have in the shipping module matches the address for your store that you entered for your main configuration. You will generate a Meter ID the first time you successfully get a quote.
  12. gwynwyffar

    Multi_Vendor_Shipping new thread

    The "no file uploaded" warning only occurs if you do not upload an image to go with the Product information. It's not really an error, it's just letting you know you didn't attach an image to that Product's listing (which isn't required). The fact that nothing changes means that you probably missed something in making the modifications to your catalog/admin/categories.php file. I recommend using a tool like WinMerge to compare the MVS categories.php file to your own (make sure to back up your current copy before making any changes) Also make sure you've added all your Vendors to the MVS Vendor listing before creating new products for that Vendor.
  13. gwynwyffar

    FedEx Direct 2.06 Support thread

    You could try this contribution http://addons.oscommerce.com/info/490 You have to generate rate tables from the FedEx website and can probably just use their default rates to accomplish what you are trying to do.
  14. gwynwyffar

    FedEx Freight & MVS

    Apparently the problem lies in FedEx changing their API - see this thread http://forums.oscommerce.com/topic/351152-fedex-freight-shipping-module/page__view__findpost__p__1469830 If anyone finds a solution, I'd be very interested. MVS is working great with the exception of FedEx Freight.
  15. gwynwyffar

    Obtaining FEDEX METER ID #

    Assuming you are using the FedEx direct contribution and you've entered your FedEx acct number and address information correctly, the Meter ID will be generated automatically the first time someone gets a shipping quote. You don't have to enter it to start.
×