Latest News: (loading..)

grantli2002

Members
  • Content count

    67
  • Joined

  • Last visited

About grantli2002

Profile Information

  • Real Name
    grant rex
  1. Hi, Nick, Was out of town for a few days. Just tried out. Worked like a charm. Thank you very much for your help. Again, thank you for creating this nice contribution and supporting it. Grant
  2. Hi, Nick, Thank you for providing and supporting this simple but nice contribution. I got two questions: 1. I use 1280x800 display and I can see 4 products per column comfortably. When I reduce the browser into smaller size, 800x600, I have to scoll to the right to view the whole page. I noticed some other sites change the product per column display automatically when browser size is changed. Can Basic Design Pack do this? 2. Is it possible to add a link at the bottom of product display page, we see Page 1, Page 2, etc. Is there a way to add a link like Display All? Thank you. Grant
  3. Hello, this nice contribution works great. How can I remove the "or more with a maximum package weight of 100 lbs" from displaying? Free shipping only for an order of $50.00 or more with a maximum package weight of 100 lbs My store sells dvd's, the weight is not a issue with shipping. It looks more professional without the weight displaying.
  4. Just one basic question. I installed SEO-G in a fresh store and everything seems to be working. Under SEO-G Reports, I saw the contribution can generate google.xml sitemap. So does it mean I don't need to install another google site map contribution anymore?
  5. I had the same error message after installation. I deleted the "order by" before "pd.products_name" and "p.products_recent_sales desc" and it worked. But I had a problem running the Cron job. The confirmation email I receive says: Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory. But my register_globals are set on in php.ini file. I have other contribution which requires register_global to be on working as well. So can someone help me with this dilemma? Otherwise, the contribution can't really tell buyers which items are best sellers.
  6. Again, thank you for your help. It seems the most updated one supporting Master Products is 2.76C, which is what I am using right now. I will try newer version one by one. I am sure the 2.76G didn't work at all.
  7. This was from post of 1608. It seems no one has answered it yet. Now I am having the same problem as well. Does anyone know? ********************************************* HELPPPPPP!! Master Products And Easy Populate. I have setup the EP 2.76c module that has Master Products support. My question is, do I need to setup the master products through my admin first and only use EP to setup the slaves? I ask because in the v_products_master column for slaves you must specify the master products id. And the only way to get this is to setup the master in the admin and use a test slave product to view the drop down selection menu of available master products so it spits out that master products id in the box next to it. Then you take this number and copy it into EP v_products_maste field to make the slave match up with the master. Is that the only way to do it? Isn't there a way I can just put in Master and Slaves in easy populate and have it work? **help**
  8. Hello, I installed Easy Populate 2.76C with Master Products. This is the most current version I can find to support Master Products. I have two questions: 1. How can I enable the search result when searching slave product's model number (v_products_model)? Currently, I can only search and find out (display) by master product's model number and the model number of regular products (v_products_model)? 2. v_products_master, where can I assign the number for this column. It seems that I have to select a master product from admin area, then I can find that products_master ID and use it in easy populate. Is there a easy way to do so? Please, help me.
  9. Hi, George, Thank you note. I "hide" products in admin, slave products only show under master product page. Can you tell me the exact "hide products contribution"? I am still new to oscommerce and tried searching in contributions but found none. Grant
  10. Hello everyone, It took me quite a while to install Master Products contribution, but it seems to work now. I have two questions and look for help: 1. For products without master or slave feature, in product description page, under the "select quantity" box, default number is 0. Can this be changed into 1? 2. I set Master product with price of 0. I also Hide Slave products. It seems if I search Slave product's model number, I can't find it. How can I enable the shopping cart to Find it by searching slave product's model number? Thank you for your time. Any help is appreciated. Best Regards, Grant
  11. Regarding the easy populate, after I open a downloaded file with excel, the first few columns are for product picture, product name, etc, and the last few columns are for manufacturer, category and EOREOR. The columns in the middle are for product attributes, such as color, size, etc. For my products, each color/size has one model number. For example, let's say I have three products: AA149504 Pink color AA149505 Purple color AA149506 Flesh color Instead of creating three products, I use the product attributes feature to group them together into ONE product. To differentiate them, I put AA1495 as the model number, and then list Pink-04, Purple-05, Flesh-06 in attributes fields. As you know, Easy Populate pulls "all the attributes" of all products and put them cell by cell in each product in the txt file. Attached is a sample file with only one product (AA1495) plus the header. If you open it by txt editor, you will see how big it is with all those attributes. The real three attribute "Pink-04, Purple-05, Flesh-06" for this product were hidden in the middle. http://my.t-bird.edu/files/Discuss/191785/example.txt This not only cause the easy populate file so big, but also make it impossible for people to search by model name. If people search AA149504, they get nothing. They have to search AA1495 to find the product. So question is: 1. Is there a way to tell Easy Populate only download the attributes with individual product, do not download the attributes from other products? 2. Whether there is a way to allow buyer to search the whole model number and find the product by looking the model number + attribute number? Thank you for reading my long post. Any help is appreciated. Maybe you know some contributions or sth to fix, can you please forward the link to me? If you have dealt with this problem before and know the solution, I am willing to pay you. Please pm me your quote. Thank you. Grant
  12. Thank you for your help. Yeah, I did put EOREOR in the upload file. I downloaded the Easy Populate 2.76d-MS2 (with attributes) by surfalot. There are only these two files under catalog/admin. Did I miss the "language file" you mentioned? easypopulate.php easypopulate_functions.php I also tried this link. The link says "1. Many people had problems with the temp directory which often on a shared server got assiged wrong - this was my first issue which I solved with adding $_SERVER["DOCUMENT_ROOT"] before each $tempdir. this will give the correct root path on a shared server i.e. /usr/local/apache/www/catalog/temp/" http://forums.oscommerce.com/index.php?sho...l=easy+populate I am not good at php, I just replace 14 $tempdir and then get error message saying: Parse error: syntax error, unexpected T_VARIABLE in /home/onead3/public_html/admin/easypopulate.php on line 22 I guess what I did was wrong, so I changed it back.
  13. I need help. I have no clue what the following error means. I can download the EP files without problems. I keep one line of the download EP file, add another line of new product, there is EORDER at the end of the line. temp file is set up under catalog with 777 permission. So what shall I do for now? Warning: move_uploaded_file(DIR_FS_DOCUMENT_ROOT/catalog/temp/EP2007Jun08-1705.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/onead3/public_html/admin/easypopulate_functions.php on line 32 Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpWgndAz' to 'DIR_FS_DOCUMENT_ROOT/catalog/temp/EP2007Jun08-1705.txt' in /home/onead3/public_html/admin/easypopulate_functions.php on line 32 File uploaded. Temporary filename: /tmp/phpWgndAz User filename: EP2007Jun08-1705.txt Size: 4723 Warning: file(DIR_FS_DOCUMENT_ROOT/catalog/temp/EP2007Jun08-1705.txt) [function.file]: failed to open stream: No such file or directory in /home/onead3/public_html/admin/easypopulate.php on line 667 Warning: Invalid argument supplied for foreach() in /home/onead3/public_html/admin/easypopulate.php on line 690
  14. OK. I got a friend helping me run the sql. That part is solved. But then when I try to configure the payment module, I entered all the information such as: API Username API Password API Signature Then I got the following two messages. What am I supposed to do now? Warning: Variable passed to each() is not an array or object in /home/onead3/public_html/admin/modules.php on line 46 Warning: Cannot modify header information - headers already sent by (output started at /home/onead3/public_html/admin/modules.php:46) in /home/onead3/public_html/admin/includes/functions/general.php on line 22
  15. I'm trying to use paypal pro as the merchant account for this site. I have uploaded the files, but I couldn't run the sql scripts. the following are the instructions: Once you have copied the files, you need to run two small SQL scripts, paypal_wpp.sql and pwa.sql, both in this directory. The command to run them may vary depending on your database name and user, but will look something like: mysql -u oscommerce -p oscommerce < paypal_wpp.sql mysql -u oscommerce -p oscommerce < pwa.sql This is beyond my knowledge. Here is what I did to run the sql: I log into my web hosting lunarpages Then I click the "Control Panel" click "Go to cPanel" In the pop up window, I click MySQL Databases Then I click the phpMyAdmin at the most bottom of the page. In the new window, I click the "Show MySQL runtime information" Then I click the "SQL" tab on top Then under the Run SQL..., I entered the clause mysql -u twoad3_osc1 -p twoad3_osc1 < paypal_wpp.sql my database name is twoad3_osc1 and the user name is twoad3_os1 as well (from the cPanel) And it didn't work, giving me error message. #1064 - You have an error in your SQL syntax I know very little about php or sql, so please tell me what did I do wrong.