Jump to content

sbetto

Members
  • Content count

    34
  • Joined

  • Last visited

  • Days Won

    1

Reputation Activity

  1. Like
    sbetto reacted to kymation in [Addon} Modular SEO Header Tags   
    osCommerce now comes with a Canonical module. I suggest that you use that one instead of the one in this addon.
     
    Regards
    Jim
  2. Like
    sbetto reacted to Jack_mcs in View Counter   
    That error is being generated when ViewCounter tries to check the session and the data you show doesn't look like a valid session string so my guess is that your sessions table is corrupted. Please go into the database and run a repair on the sessions table or, if this is a test shop, just clear it, and try again. If that doesn't work, it may be something in the code that can't handle the session but I can't duplicate the problem so I can't check that.
  3. Like
    sbetto got a reaction from Peper in Recover Cart Sales   
    Hi midijay, I experienced this issue too and think I have resolved the issue (at least all appears to be working for me now :-)
    I have V2.23a dated 1DEC2008 installed but am using the file recover_cart_sales.php (catalog/admin) from the 2.0a version dated 11JAN2011 with a change to where the email is sent. I have replaced the code at around line 308 in catalog/admin/recover_cart_sales.php
     
    Replaced this code below:
    //tep_mail($custname, $outEmailAddr, EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, EMAIL_FROM);
    //Let's build a message object using the email class
    $mimemessage = new email(array('X-Mailer: osCommerce'));
    // add the message to the object
    $mimemessage->add_text($email);
    $mimemessage->build_message();
     
    $mimemessage->send($custname, $outEmailAddr, '', EMAIL_FROM, EMAIL_TEXT_SUBJECT);
    With this code:
    tep_mail('', $outEmailAddr, EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, EMAIL_FROM);
     
    *** please note I am no expert in this code but this did work for me to at least get the emails sending. (I found info on this forum helpful - http://www.oscmax.com/forums/oscmax-v2-customization-mods/19425-cant-send-email-recover-cart-sales-2-22-a-2.html) I have not experienced any other fallout as a result of this change as yet but there could well be as its early days of this install for me.
    Cheers, Sarah
  4. Like
    sbetto got a reaction from Peper in Recover Cart Sales   
    Hi midijay, I experienced this issue too and think I have resolved the issue (at least all appears to be working for me now :-)
    I have V2.23a dated 1DEC2008 installed but am using the file recover_cart_sales.php (catalog/admin) from the 2.0a version dated 11JAN2011 with a change to where the email is sent. I have replaced the code at around line 308 in catalog/admin/recover_cart_sales.php
     
    Replaced this code below:
    //tep_mail($custname, $outEmailAddr, EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, EMAIL_FROM);
    //Let's build a message object using the email class
    $mimemessage = new email(array('X-Mailer: osCommerce'));
    // add the message to the object
    $mimemessage->add_text($email);
    $mimemessage->build_message();
     
    $mimemessage->send($custname, $outEmailAddr, '', EMAIL_FROM, EMAIL_TEXT_SUBJECT);
    With this code:
    tep_mail('', $outEmailAddr, EMAIL_TEXT_SUBJECT, $email, STORE_OWNER, EMAIL_FROM);
     
    *** please note I am no expert in this code but this did work for me to at least get the emails sending. (I found info on this forum helpful - http://www.oscmax.com/forums/oscmax-v2-customization-mods/19425-cant-send-email-recover-cart-sales-2-22-a-2.html) I have not experienced any other fallout as a result of this change as yet but there could well be as its early days of this install for me.
    Cheers, Sarah
×