Jump to content
Latest News: (loading..)

cururu

Members
  • Content count

    9
  • Joined

  • Last visited

  1. I believed that i solved my 301 X Google problem: I installed the following contrib that generate sitemap using the ultimate SEO links: Google Sitemap Generator for MS2 http://addons.oscommerce.com/info/3226 version: 27 May 2008 Is in french :/ . Google Translator helped a lot. I will wait to see the google behavior.
  2. Hi There, I am getting the 301 - too many redirects from Google Webmasters Sitemaps. Using: - // Ultimate SEO URLs v2.1 if (SEO_ENABLED == 'true' or (SEO_ENABLED != 'true' and SEO_ENABLED != 'false')) { include_once(DIR_WS_CLASSES . 'seo.class.php'); - Google XML Sitemap Feed Cron Script - Independent SEO URL Validation (for ULTIMATE SEO URLs) The contribs are working fine, but Google doesnt like it. The sitemap links are all like the original oscommerce without the Ultimate SEO contrib. I disabled the option on Admin/Configuration/SEO URLs: Enable automatic redirects But this is not the ideal solution because Google will index the pages using the original urls. Any suggestion? Thansk in advance.
  3. Hi There, I am still getting the 301 - too many redirects from Google Webmasters Sitemaps. Using: - // Ultimate SEO URLs v2.1 if (SEO_ENABLED == 'true' or (SEO_ENABLED != 'true' and SEO_ENABLED != 'false')) { include_once(DIR_WS_CLASSES . 'seo.class.php'); - Google XML Sitemap Feed Cron Script - Independent SEO URL Validation (for ULTIMATE SEO URLs) The contribs are working fine, but Google doesnt like it. The sitemap links are all like the original oscommerce without the Ultimate SEO contrib. I disabled the option on Admin/Configuration/SEO URLs: Enable automatic redirects But this is not the ideal solution because Google will index the pages using the original urls. Any suggestion? Thansk in advance.
  4. Hi Robert! Thank you very much for this contribution! My website was removed from Google results because of "301 - too many redirects" problem, I am sure that it will return to normal after your contribution. I installed it and the contrib is working as it should. Now I will wait and see. Thanks! Best Regards
  5. I had to add this simple code after this line on product_info.php also: if (!tep_session_is_registered('recently_viewed')) The correct modification is the code below to be added at product_info.php: ///////////// begin recently_viewed if (!tep_session_is_registered('recently_viewed')) { $acount=substr_count($HTTP_GET_VARS['products_id'],"{"); if ( $acount == 0 ) { tep_session_register('recently_viewed'); $recently_viewed = $HTTP_GET_VARS['products_id'] . ';'; } } $acount=substr_count($HTTP_GET_VARS['products_id'],"{"); if ( $acount == 0 ) { $dup_recent_viewed = 'n'; $recent_products = split(';',$recently_viewed); foreach ($recent_products as $recent) { if ($recent == $HTTP_GET_VARS['products_id']) $dup_recent_viewed = 'y'; }//foreach ($recent_products as $recent) { if ($dup_recent_viewed == 'n') $recently_viewed = $HTTP_GET_VARS['products_id'] . ';' . $recently_viewed; } ///////////// end recently_viewed Regards
  6. To solve this I made a small modification on product_info.php recently_viewed code: ///////////// begin recently_viewed if (!tep_session_is_registered('recently_viewed')) { tep_session_register('recently_viewed'); $recently_viewed = $HTTP_GET_VARS['products_id'] . ';'; } $acount=substr_count($HTTP_GET_VARS['products_id'],"{"); if ( $acount == 0 ) { $dup_recent_viewed = 'n'; $recent_products = split(';',$recently_viewed); foreach ($recent_products as $recent) { if ($recent == $HTTP_GET_VARS['products_id']) $dup_recent_viewed = 'y'; }//foreach ($recent_products as $recent) { if ($dup_recent_viewed == 'n') $recently_viewed = $HTTP_GET_VARS['products_id'] . ';' . $recently_viewed; } ///////////// end recently_viewed This line counts if there is any character: { which is on the link from de Shopping cart with attributes: $acount=substr_count($HTTP_GET_VARS['products_id'],"{"); If the return value is equal 0 than continue with the recently viewed code. If its different from 0 means that its a link from shopping cart and does not include the product on the recently viewed list. (The correct link for the product already is included on the recently viewed list anyway.) if ( $acount == 0 ) { Solved my problem, hope it helps. Regards
  7. cururu

    Enable/Disable categories contribution

    Hi there! I have installed many contributions, and this one is the most problematic that I found. I tried really hard to fix and use this contribution but without success. None of the suggestions for index.php works. None of the suggestions for products_new.php works. /advanced_search_results.php os working. /allprods.php is working. /includes/boxes/categories.php is working. /includes/boxes/manufacturers.php is working. /includes/boxes/best_sellers.php is working. The admin part is working. I still see products from disabled categories in the main page and products_new.php. Is it possible that some good samaritan post a complete and working full package for this VERY useful contributtion? Everybody from this community wil be very gratefull. Thank you very much.
  8. cururu

    Margin Report v2.10

    Hi, i use products attributes too and Margin Report does not calculate the atributes prices. Is it possible to work with products attributes? Thanks for this great contrib!
  9. cururu

    Contribution Issue

    Thanks for your message! I also use SPAW. But i noticed that the editor of original text was empty. To solve this I changed: admin/extra_info_pages.php: tep_draw_fckeditor('pages_html_text_'.$languages[$i]['id'],'600','300', $pages_html_text[$languages[$i]['id']]); to tep_draw_textarea_field('pages_html_text_'.$languages[$i]['id'],'soft','70','15', $pages_html_text[$languages[$i]['id']]); also removed this line to stop putting error messages on my apache log: <script language=javascript src="editor/inhtml.js"></SCRIPT> The popup to show the page on admin is not working. I modified this to open the page on a new windows: from: <a href="java script:popupImageWindow(\'' . FILENAME_POPUP_IMAGE . '?page=' . $pages['pages_id'] . '\')">' . tep_image to: <a target=new href="../' . FILENAME_PAGE_MANAGER . '?pages_id=' . $pages['pages_id'] . '">' . tep_image Now, apparently, the contribution is working as it should.
×