Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

shelby72

Members
  • Content count

    170
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by shelby72

  1. shelby72

    Links Manager II

    Thanks Jack, I managed to get version 1.16 working before I saw your most recent update version, and have upgraded it to 1.20. Everything seems to be working fine now. What does the reciprocal override option do? Also is there anyway to make the contact information and the reciprocal link as not required in the admin?
  2. shelby72

    Links Manager II

    Jack, I do not understand what it is you were trying to tell me to do. You sent me to a page where I could download version 1.20 which I've already done and I still get the following error. Is there not any other way to correct this? Is this a links.php problem or a database issue? 1054 - Unknown column 'lf.links_all_pages' in 'where clause' select l.links_id, l.links_url, l.links_image_url, ld.links_title, ld.links_description, lf.expires_date from links l, links_description ld, links_featured lf where l.links_id = ld.links_id AND ld.links_id = lf.links_id AND lf.links_all_pages = '1' and (ld.language_id = '1' or ld.language_id = 99) AND lf.expires_date >= now() order by RAND() [TEP STOP]
  3. shelby72

    Links Manager II

    Exactly what do I need to change to correct the problem? Is it the links.php file that's causing it or is it a database issue? I'm new at all this php stuff.
  4. shelby72

    Links Manager II

    I just installed all of the Links Manager II versions 1.16 to 1.20 and I'm still getting the following error: 1054 - Unknown column 'lf.links_all_pages' in 'where clause' select l.links_id, l.links_url, l.links_image_url, ld.links_title, ld.links_description, lf.expires_date from links l, links_description ld, links_featured lf where l.links_id = ld.links_id AND ld.links_id = lf.links_id AND lf.links_all_pages = '1' and (ld.language_id = '1' or ld.language_id = 99) AND lf.expires_date >= now() order by RAND() [TEP STOP] How do I fix this?
  5. shelby72

    Links Manager II

    I already have the latest version 1.20 installed but I still keep getting the following error with it: 1054 - Unknown column 'lf.links_all_pages' in 'where clause' select l.links_id, l.links_url, l.links_image_url, ld.links_title, ld.links_description, lf.expires_date from links l left join links_description ld on l.links_id = ld.links_id left join links_featured lf on ld.links_id = lf.links_id where l.links_status = '2' and lf.links_all_pages = '1' and (ld.language_id = '1' or ld.language_id = 99) AND lf.expires_date >= now() order by RAND() [TEP STOP]
  6. shelby72

    Links Manager II

    I don't see any corrections for this error. I've searched all through the posts.
  7. shelby72

    Links Manager II

    I fixed the following error: 1136 - Column count doesn't match value count at row 1 by adding a 1 in the following: array("INSERT INTO links_exchange VALUES ( 'Link Name', 'My home page sells the best products you can imagine.', 'http://www.myhomepage.com', '1')")); now my database says it's uploaded successfully, but now I get the following error: 1054 - Unknown column 'lf.links_all_pages' in 'where clause' select l.links_id, l.links_url, l.links_image_url, ld.links_title, ld.links_description, lf.expires_date from links l left join links_description ld on l.links_id = ld.links_id left join links_featured lf on ld.links_id = lf.links_id where l.links_status = '2' and lf.links_all_pages = '1' and (ld.language_id = '1' or ld.language_id = 99) AND lf.expires_date >= now() order by RAND() [TEP STOP] How do I correct that?
  8. shelby72

    Links Manager II

    I never installed version 1.19 so I didn't think I had to apply the update file. Version 1.20 is the first one I've installed. I'll try it and see if it works though.
  9. shelby72

    Links Manager II

    I just installed Links Manager II V 1.20 and when I try to install the links_setup.php I get the following error: 1136 - Column count doesn't match value count at row 1 INSERT INTO links_exchange VALUES ( 'Link Name', 'My home page sells the best products you can imagine.', 'http://www.myhomepage.com') [TEP STOP] How do I correct this?
  10. shelby72

    Event Calender

    How do you get this to work with Oscommerce Rc2? I really need this contribution.
  11. shelby72

    EasyMap

    I can't get this contribution to work. All it shows is a box with nothing in it. I've tried all of the updates. How do I uninstall it?
  12. shelby72

    Specials & Products_new

    I can't get this to work on my site either. I have the newest version of Oscommerce. Has anyone been able to get this to work properly?
  13. shelby72

    Add to cart not working

    I solved my problem. It was in the application_top.php. I had installed the add quantity to product_listing.php contribution which messed everything up.
  14. I cannot get the add to cart to work in new_products.php, products_new.php, or whats_new.php. It works fine in product_listing.php and product_info.php. I've searched google and all through the forums and still can't figure this out. I installed the Sharp-Grey-Osc template on my site and I've also installed the short description in products contribution. Here is what the code in my new_products.php looks like: <a href="' . tep_href_link(FILENAME_DEFAULT, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $new_products['products_id']) . '">' . tep_image_button('cart_buy.gif', IMAGE_BUTTON_IN_CART) . '</a> I installed the add quantity to product listing contribution and this is the changes I had to make in my application_top.php code in order to get my product_listing.php and product_info.php add to cart to work: case 'add_product' : if (isset($HTTP_POST_VARS['products_id']) && is_numeric($HTTP_POST_VARS['products_id'])) { $cart->add_cart($HTTP_POST_VARS['products_id'], $cart->get_quantity(tep_get_uprid($HTTP_POST_VARS['products_id'], $HTTP_POST_VARS['id']))+ (int)$HTTP_POST_VARS['quantity'], $HTTP_POST_VARS['id']); Here is my configure.php file info: <?php define('HTTP_SERVER', 'http://sparklespot.com'); define('HTTPS_SERVER', 'https://sparklespot.com'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'sparklespot.com'); define('HTTPS_COOKIE_DOMAIN', 'sparklespot.com'); define('HTTP_COOKIE_PATH', '/catalog/'); define('HTTPS_COOKIE_PATH', '/catalog/'); define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', '/catalog/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/var/www/vhosts/sparklespot.com/httpdocs/catalog/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', ''); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); ?> I also tried turning register globals on and that doesn't help either. What else could be the problem?
  15. shelby72

    "Dynamenu" for osCommerce

    I'm trying to use the vertical fly-out menu. When I set $show_dmcats_as_box = false; the menu doesn't work. I've seen in this forum where there is a solution for this if you have STS installed and you can correct it in sts_column_left.php, but I do not have the STS contribution. Is there not another way to fix this?
  16. shelby72

    "Dynamenu" for osCommerce

    Can you use this contribution in the place of your oscommerce categories box? In column_left.php when I try to change: if ((USE_CACHE == 'true') && empty($SID)) { echo tep_cache_categories_box(); } else { include(DIR_WS_BOXES . 'categories.php'); } to: if ((USE_CACHE == 'true') && empty($SID)) { echo tep_cache_categories_box(); } else { include(DIR_WS_BOXES . 'dm_categories.php'); } nothing happens. If I change it to just: include(DIR_WS_BOXES . 'dm_categories.php'); It messes my navigation bar up at the top of my site. It scrunches my navigation bar down and over into the far left corner above the categories box. What do I have to do to get it to replace the categories box that's already on my oscommerce site?
  17. Thank you very! It works now. I changed it to header("Content-type: text/x-csv") and now Easy Populate works just fine even when I open it up in Excel.
  18. I'm using Windows Vista and I have Excel 2000. What could be causing that file to have those extra quotes around it? They aren't there on the files that I save to the temp folder from Easy Populate nor the ones that I save to my computer. That may not be the problem but that's the only difference I can see between the files.
  19. That file is opened in excel then saved to the computer. I'm using windows and I'm in the US.
  20. I have the latest version of Easy Populate installed 2.76g-MS2. All of my headers are being crammed in my first column. It does this every time I try to open it with Excel. It seems to be working fine now if I download it in the temp directory first or if I download it on my hard drive and then open it with excel. After looking at the file in a text editor it seems to be adding quotes around everything. That might be the problem but I have no idea how to fix it. I just started this site so everything is a real mess right now and I haven't uploaded any products yet but anyway here is a link to the file. http://sparklespot.com/catalog/temp/EP2008Oct20-0014.csv My Easy Populate settings are: EP vers: 2.76g-MS2 osCommerce Online Merchant v2.2 RC2a OS: Linux 2.6.9-023stab044.4-smp HTTP: Apache/2.0.52 (CentOS) DB: MySQL 4.1.20 PHP: 4.3.9 (Zend: 1.3.0) Temp Directory: /var/www/vhosts/sparklespot.com/httpdocs/catalog/temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: off Split files on: 300 records Model Num Size: 12 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 7 Enable attributes: true SEF Froogle URLS: false More Pics: false Unknown Pics: false HTC: false SPPC: false Extra Fields: false
  21. I'm having this same problem. I just installed Easy Populate 080926EP_v2_76g_MS2_fixed. When I Import into Excel it reads all the columns in each of my columns. It doesn't separate them. Anybody know how to fix this?
  22. Can someone please help me add this contribution to PayPal Express checkout? When someone clicks on the PayPal Express Checkout button it skips the checkout_payment.php and goes straight to the checkout_confirmation.php so they never see the discount coupon box. What do I need to do to get this working with PayPal Express Checkout?
  23. I have PayPal Express also and I'm having the same problem. How do you get it to work with the discount code contribution?
  24. I solved my problem. The files I was using to install the discount coupon codes contribution in didn't have the PWA contribution in them.
  25. I solved my problem. The files I was using to install the discount coupon codes contribution in didn't have the PWA contribution in them.
×