Jump to content

alexschmidt

Members
  • Content count

    17
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Alex Schmidt
  1. alexschmidt

    [Contribution] Dynamic MoPics v2.2

    Problem solved... I've no idea what was wrong with the popup_image but I simply replaced it with the one from the old server.... Anyway...
  2. alexschmidt

    [Contribution] Dynamic MoPics v2.2

    In the meantime I've replaced all instances of $_GET['pic'] with $HTTP_GET_VARS['pic'] Now the popups are searched in the catalog/images/thumbs dir itself as "2.jpg" instead of "picname2.jpg" What the hell can be screwed up?
  3. alexschmidt

    [Contribution] Dynamic MoPics v2.2

    Dreamscape, please do not beat me, but I#ve got a problem which I can't solve... :blink: I've installed dynamic mopics 2.2 successfully in the past (earlier in this thread) at http://www.fetishteam.com/catalog/product_.../products_id/29 Now on a new server I've done the same thing but the pop ups won't show... I don't know what to to else.... http://web1.cserver11.erfurt14.de/catalog/.../products_id/29 All seem to be the same thing, but those big images won't show... The link shows to catalog/images/ instead of catalog/images/big-images... These are the entries in the admin area: Name Big Images Directory big_images/ Thumbnail Images Directory thumbs/ Main Thumbnail In Thumb Directory false Number of Pics per Row 4 Mo Pics Extension Main Big Pic Extension Mo Pics Thumbnail Image Type jpg Mo Pics Big Image Type jpg And this is my popup_image <?php $thumb_len = ((MAIN_THUMB_IN_SUBDIR == 'true') ? strlen(IN_IMAGE_THUMBS) : 0); $thumbs = ((MAIN_THUMB_IN_SUBDIR == 'true') ? IN_IMAGE_THUMBS : ''); $image_base = substr($products_values['products_image'], $thumb_len, -4); $image_ext = '.' . BIG_IMAGE_TYPE; $image_path = DIR_WS_IMAGES . IN_IMAGE_BIGIMAGES; $image_addon = (($_GET['pic']) ? MORE_PICS_EXT . $_GET['pic'] : BIG_PIC_EXT); /* if the big image isn't shown unkomment the next line, and check the path: maybe you have to remove '/'. or adjust the path, depends on your configuration */ // echo DIR_FS_CATALOG . $image_path . $image_base . $image_addon . $image_ext . '<br>'; if (is_file(DIR_FS_CATALOG . $image_path . $image_base . $image_addon . $image_ext)) { $image = $image_path . $image_base . $image_addon . $image_ext; } else { $image = (($_GET['pic']) ? DIR_WS_IMAGES . IN_IMAGE_THUMBS . $image_base . $image_addon . $image_ext : DIR_WS_IMAGES . $thumbs . $image_base . $image_ext); } echo tep_image($image, $products_values['products_name'], '', '', 'lowsrc="images/pixel_trans.gif"'); ?> </a> </div> </body> </html> <?php require('includes/application_bottom.php'); ?> Please helP!!!
  4. alexschmidt

    [Contribution] Dynamic MoPics v2.2

    Hi fiscus, please excuse the late reply! Zhx a lot for your help! :wink:
  5. alexschmidt

    [Contribution] Dynamic MoPics v2.2

    That did it!! :D :D :D Thx a lot for your help and for this great contribution! May I ask another dumb question, which has nothing to do with this contribution? :blush: Per default the image (if the product is made via admin) always is put to www.mysite.com/catalog/images/pic.jpg How can I create a product with an image in (for example) www.mysite.com/catalog/images/gt_interaktive/pic.jpg? This is a thing I still don't understand... :oops: :oops: :oops: Would be great if you could answer this to a newbie... Thx for all, Alex
  6. alexschmidt

    [Contribution] Dynamic MoPics v2.2

    Hi dreamscape, thx for the quick response... :) I've got this to work!!! ->http://www.fetishteam.com/catalog/product_.../products_id/29 But why the pop-up shows the pic & the PATH? Thx in advance... :D
  7. alexschmidt

    [Contribution] Dynamic MoPics v2.2

    Hi, I'm new to this forum and to osc... I've installed this contribution without any problem (after replace thos $_get with the proper $) but now there're 2 things I don't understand.... 1. The big image of the default thumb open in a pop-up and shows the pic and the url!?! 2. The additional pics won't show... I've named them with a _pic1, _pic2, ... extension and put those thumbnails in a thumb subfolder in the folder of the big ones. What went wrong??? http://www.fetishteam.com/catalog/product_.../23/language/en
×