Jump to content

MountainMan

Members
  • Content count

    103
  • Joined

  • Last visited

Everything posted by MountainMan

  1. Was hoping to get some advice on using Braintree payment module? A payment module comes with CE_Phoenix, but I also find an App, similar to the PayPal App. Wondering which I should use? https://apps.oscommerce.com/0oEmU&braintree-app Thanks...
  2. I got on the hunt for a bootstrap modal login for my OSC shop, thought it might be a good and thoroughly modern idea, and came across this discussion. The discussions here highlight important issues with modal logins, primarily the SSL and the redirects, if I am not mistaken? Considering that most of the posts here go back a couple of years, I was wondering if any progress has been made to resolve these issues? And/or, what is the current best practices regarding modal logins? Has/will it become SOP, or has it been abandoned and just not a good thing to do for whatever reasons? One thought I had about the SSL issue was to have a two part login...start by getting the email address, then when they continue, redirect to an HTTPS page for the password. Have not tried to implement this yet. Not sure if I (or my customers) would like the look and feel. But any comments about the idea would be appreciated. Thanks...
  3. MountainMan

    ULTIMATE Seo Urls 5 - by FWR Media

    Well, thanks for the info. Hopefully someone can give me clue as how the module works and in what file the changes to the URL occur.
  4. MountainMan

    ULTIMATE Seo Urls 5 - by FWR Media

    Thanks for the info. Can you tell me where to look, in order to fix? I have looked at product_listing.php itself, including past SEO versions, and dont see anything about UltSEO there.
  5. MountainMan

    ULTIMATE Seo Urls 5 - by FWR Media

    Am wondering if I have this installed/working correctly, maybe I am missing something, or maybe its working properly. Within a list of products generated by product_listing.php (for a category), the links visible in the lower left corner of the browser by hovering the cursor over the Product Name seems to be the regular OSC type, like this: /catalog/product_info.php?cPath=5_11&products_id=121 . Whereas when I click on the link and go to the product, I see a URL up top that says something like: /catalog/great-product-p-121.html ... ....which I presume is generated by the Ultimate SEO module...and I also presume this is what I would rather see (when hovering) generated by product_listing.php instead of the cPath version. Yes, no, maybe. Totally not necessary. Hey, a good idea and I will whip that up in a sec. ???
  6. MountainMan

    Google XML Sitemap SEO

    How does one doublecheck and/or view the sitemap(s) created for accuracy and errors?
  7. Am using BS version. Have Colorbox installed. Objective is to have a large image popup when the visitor clicks on any image in the category product_listings. This would be the same functionality found when viewing an individual item in product_info. Hoping someone wiser and more experienced can point me down the right road. Maybe there is some easy way to do this? I have been know to have the habit of taking the hard road. Trying to learn not to reinvent the wheel. P.S. I am not sure how the large popup is created in product_info. I presume it is colorbox, but dont quite get it, yet.
  8. Working now. A key is to add the three <scripts> that colorbox requires to the footer.
  9. I have reviewed the archived discussions of similar questions, but have not found my solution. Am trying to implement the code below found in some of those other discussions, but it does not appear to have any effect whatsoever on the popup. Seems like it should be the solution I need...any suggestions why it wont work? Am using modified and somewhat upgraded BS Gold. <script type="text/javascript"> $(function() { $('#piGal').css({ 'visibility': 'hidden' }); $('#piGal').photosetGrid({ layout: '<?php echo $photoset_layout; ?>', width: '250px', highresLinks: true, rel: 'pigallery', onComplete: function() { $('#piGal').css({ 'visibility': 'visible'}); $('#piGal a').colorbox({ maxHeight: '90%', maxWidth: '90%', title: '<?php echo $product_info['products_name']; ?>', rel: 'pigallery' }); $('#piGal img').each(function() { var imgid = $(this).attr('id').substring(9); if ( $('#piGalDiv_' + imgid).length ) { $(this).parent().colorbox({ inline: true, href: "#piGalDiv_" + imgid }); } }); } }); }); </script>
  10. Thanks for the advice, but I am experimenting with a more "visual" approach to look and feel (navigation).
  11. I notice content module classes such as "cm-header-breadcrumb", but cant find them in the code anywhere other than the templates where they are used. Was hoping I could be schooled a bit on these? Where are the defined, and/or is there something unique about this usage of class names. What am I missing? Thanks...
  12. Thanks for the schooling, guys. Was exactly whut I was looking fer.
  13. MountainMan

    BS\GOLD with PayPal App 5.018

    Hi there from the USA. Have been porting an OSC 2.3? site over to BS\GOLD. (Started a while back, and now coming to finish it, I see "frozen". Drat, more more more work.) FYI, I harvested the PP App 5.018 (which did not come with Gold) from github, and copied it over to my new work. The App would not do an update from 5.10, so I tried the manual approach. So far, so good. Except for the PayPal app. Previously was using PayPal Standard, which is still setup in the configuration table. Firstly, its confusing about retrieving the credentials - Live vs API. Do I need both? If yes, which first? Secondly, my credentials are not being retrieved. When I press any of the buttons, the page just reloads. In desperate need of insight...
  14. MountainMan

    BS\GOLD with PayPal App 5.018

    That's always an option.
  15. MountainMan

    BS\GOLD with PayPal App 5.018

    Live vs sandbox is obvious, I was confused by the API credentials, partly because I was used to the older PP Standard setup in Admin (which was simple), and also because "API" is often used for different/direct/programming access on other platforms. I initially thought I should only be concerned with Live or Sandbox setup. Also adding to the confusion was nothing was working as advertised, because, of course, its a bastardized port over. The three "buttons" - I was seeing the PP App Start page with three "panels" for retrieving the Live, Sandbox and API credentials. I did not find it clear, should I setup the API first? In any case, I slugged threw the code, and also had to make some manual entries in the configuration table because they werent saving, but am now finally seeing PayPal as a payment option and can click thru to PayPal to make payment, and am just about to see if a test payment will work. Thanks for your response. The community is much appreciated.
  16. MountainMan

    PayPal App for osCommerce Online Merchant

    Using BS\Gold, lightly modified. Am getting the " Could not start the procedure to download v5.011" error message. Have changed all the $HTTP_ vars to new $_ vars. Still have problem.
  17. MountainMan

    EZier New Fields

    Can anyone tell me where/how the variable $customer_discount is initialized?
  18. MountainMan

    ULTIMATE Seo Urls 5 - by FWR Media

    Adding more info to my post above: It appears the error occurs in part because some items do not actually have a "products_model" number - the entry in the table is empty. Can someone more experienced than I suggest a work-around or mod to the code? I have done the following and it seems to work: if (!isset($details['products_model'])) { $text_types = array( 'p' => $details['products_name'], 'c' => $details['categories_name'] ); } else { $text_types = array( 'p' => $details['products_name'], 'c' => $details['categories_name'], 'm' => $details['products_model'] ); }
  19. MountainMan

    ULTIMATE Seo Urls 5 - by FWR Media

    Looking for more info/guidance on the error: Undefined index: products_model File: includes/modules/ultimate_seo_urls5/page_modules/product_info.php Line: 189 This error kind of comes and goes, as I refresh a page multiple times. Have read in this forum where it is probably a corrupted database, and a possible fix is changing " INNER JOIN to LEFT JOIN in the query". Assuming the query in question begins on approx. Line 35 in the above module with "protected $dependencies =" ....Unfortunately, this has not worked for me. Help much appreciated...and have a Happy New year!
  20. MountainMan

    Quickpay payment module for 2.3

    What is Quickpay? I found this online: https://quickpay.net But they dont list USA, which I need.
  21. Back to the issue of the jquery mobile CSS...I need to modify the look of the select-option-select dropdowns. Any clues how to do this without changing the existing ones would be appreciated.
  22. A little confused on the payment modules. On the osc contribution page for iOSC, it says for ver 6.0 that: - Support for all payment modules of standard OsC (catalog/ext/modules/payment/) And was news to me...because I thought the ones OsC uses are in catalog/modules/includes/payment/ And in fact I have modified those and know that they are the ones being used. I also notice that the same modules in catalog/ext/modules/payment/ are also in catalog/mobile/ext/modules/payment/ Kind of lost here on what's what...
  23. Thanks for the info on CSS. I had found the new (to me) jquery stuff based on this in the iOSC code: <body class="ui-mobile-viewport ui-overlay-c"> I also found other folks confused by the same issue of the CSS being forced on them and needing to over-ride it.
  24. I obviously need to give myself a little schoolin'. There are some css technologies going on that I am unfamiliar with. I was hoping someone could point me to what I need to study. I notice there are div's with classes not in my source code that turn up on the page in the browser. Generated on the fly somehow. Kind of forcing styles on the page, and working against me! They seem to be of the "ui-xxxxx" genre. What in the world is this? Where do I look to learn? Thanks
  25. All my paths are off when calling for modules internally with "include" or "require" ...this is based on me starting the mobile site from within the mobile directory, with a link to say /mobile/index.php Am I missing something about how the mobile site is started and/or linked to...? This is blowing my mind. It hurts. Really hurts. Ouch.
×