Jump to content

dvharrison

Members
  • Content count

    370
  • Joined

  • Last visited

Posts posted by dvharrison


  1. Ok the problem is sorted. And I shall share the problem and the solution here for any other poor soul who falls into the same trap.

     

    Going back a few pages to http://forums.oscommerce.com/index.php?s=&...t&p=1364763 wontonesaju said rename the old file to something with a prefix eg index-bk.php

     

    When everything seems to be working Ok, remove the old files as this is what was messing up the shipping pages.


  2. I should explain my last post a bit better:

     

    Basically we need to amend delivery to the table rate so delivery is free to orders over £15 (its currently £10) and basically table rate is nowhere to be found and we now cannot edit anything.

     

     

     

    I get:

     

    kcssprob2202.gif

     

    Please could anyone help or can I at least get in somewhere and adjust the PHP code manually so we can make this change?


  3. Thanks Saju you were right. I had another go this evening and I have had to adjust the catalog.php to:

     

     

     

    As I also have optional related products listed at the bottom of the catalog box.

     

    This leaves the link in the catalog box displayed as BOX_CATALOG_DISCOUNT_COUPONS

     

    Then I changed the reports.php and again nothing could be viewed on the admin screen except for the boxes on the left (this time all of them)

     

    With the amendments, my reports.php looks like:

     

     

     

    What am I doing wrong? Please help. :(

     

    Sorry but bumping this. I would dearly love some help.


  4. Thanks Saju you were right. I had another go this evening and I have had to adjust the catalog.php to:

     

    <?php

    /*

    $Id: catalog.php 1739 2007-12-20 00:52:16Z hpdl $

     

    osCommerce, Open Source E-Commerce Solutions

    http://www.oscommerce.com

     

    Copyright © 2002 osCommerce

     

    Released under the GNU General Public License

    */

    ?>

    <!-- catalog //-->

    <tr>

    <td>

    <?php

    $heading = array();

    $contents = array();

     

    $heading[] = array('text' => BOX_HEADING_CATALOG,

    'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog'));

     

    if ($selected_box == 'catalog') {

    $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

    //kgt - discount coupons

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a><br>' .

    /***************

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a><br>' );

    ***************/

    //end kgt - discount coupons

    /* Optional Related Products (ORP) */

    '<a href="' . tep_href_link(FILENAME_RELATED_PRODUCTS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_RELATED_PRODUCTS . '</a>');

    //ORP:end

    }

     

    $box = new box;

    echo $box->menuBox($heading, $contents);

    ?>

    </td>

    </tr>

    <!-- catalog_eof //-->

     

    As I also have optional related products listed at the bottom of the catalog box.

     

    This leaves the link in the catalog box displayed as BOX_CATALOG_DISCOUNT_COUPONS

     

    Then I changed the reports.php and again nothing could be viewed on the admin screen except for the boxes on the left (this time all of them)

     

    With the amendments, my reports.php looks like:

     

    <?php

    /*

    $Id: reports.php 1739 2007-12-20 00:52:16Z hpdl $

     

    osCommerce, Open Source E-Commerce Solutions

    http://www.oscommerce.com

     

    Copyright © 2002 osCommerce

     

    Released under the GNU General Public License

    */

    ?>

    <!-- reports //-->

    <tr>

    <td>

    <?php

    $heading = array();

    $contents = array();

     

    $heading[] = array('text' => BOX_HEADING_REPORTS,

    'link' => tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, 'selected_box=reports'));

     

    if ($selected_box == 'reports') {

    $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_VIEWED . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' .

    //kgt - discount coupons report

    '<a href="' . tep_href_link(FILENAME_STATS_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_ORDERS_TOTAL . '</a><br>'

    '<a href="' . tep_href_link(FILENAME_STATS_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_DISCOUNT_COUPONS . '</a>');

    /*************

    '<a href="' . tep_href_link(FILENAME_STATS_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_ORDERS_TOTAL . '</a>');

    *************/

    //end kgt - discount coupons report

    }

     

    $box = new box;

    echo $box->menuBox($heading, $contents);

    ?>

    </td>

    </tr>

    <!-- reports_eof //-->

     

    What am I doing wrong? Please help. :(


  5. I used the last update from 31 January from wontonesaju I never did the bug fix that has since come in from the same person, could that have been why?

     

    I have other add-ons on the site so I have had to edit some of the pages before.

     

    I have the latest version of PHP on my server so PHP5.

     

    Basically the whole admin panel disabled and all you could see was the configuration menu.

     

    Hope this helps.


  6. Both.

     

    Although when I check out the image in a newsletter, it does point to just /images/xyz.gif rather than kelscrafts.co.uk/images/xyz.gif

     

    Remember I posted because it was adding index.php by default to the URL path and you showed me how to eliminate it? How can I add the domain name as a prefix (and is this a good idea?)

     

    Please help. You are very nice and supportive Todd (not many are, you know) ;)


  7. Help

     

    I hope there is someone on this forum that can help. I am using the multiple categories at http://addons.oscommerce.com/info/1537 and have finished tying my products up in it.

     

    However, now when I add products to the catalog panel, I cannot find them again. Despite me using the drop down tree, they display under Home > product number rather than the sub-category I choose.

     

    Example can be found at: http://rocket.unitedhosting.co.uk/~admin34...products_id=850

     

    As further insight I did cancel several products off a couple of weeks ago. as these were duplicates. Would this have affected them? Or is this written in PHP 4 or 5?

     

    I hope you can help me as I am truly stumped. i am meant to be training someone to use this next week and may have to cancel it as nothing can be found once added.

     

    Please help. i can provide further info if you PM me.

     

    Best regards


  8. I have get the following error message adding the module to the Newsletter manager.

     

    1146 - Table 'kelscrafts_co_uk_products.TABLE_CUSTOMERS_TEMP' doesn't exist

     

    select * from TABLE_CUSTOMERS_TEMP

     

    [TEP STOP]

     

    I followed the example in the WYSIWYG_editor_addition.txt, added the code between the <head></head> tags and added

     

    tep_draw_textarea_field('content', 'soft', '100%', '20', $nInfo->content, 'class="TinyMCE"');

     

    onto the appropriate line as laid out. I can create the newsletter and preview and lock it, but once I try to send, I get that.

     

    I had just configured Tiny_mce to

    relative_urls : false,
    in the init.js files, but reverting this back to true makes no difference.

     

    Please help.

×