Jump to content

dvharrison

Members
  • Content count

    370
  • Joined

  • Last visited

Posts posted by dvharrison


  1. Hi All

     

    I have installed SEO header tags on my website operating on Oscommerce 2.3.4.  We did have Ultimate SEO 5 installed, but uninstalled it.

     

    However after installing and configuring Header Tags, everything works fine, except that on the admin panel under Configuration > Header Tags SEO, I keep getting the following warning appear :

     

     

    Warning: call_user_func() expects parameter 1 to be a valid callback, function 'tep_reset_cache_data_usu5' not found or invalid function name in http://ourwebname\admin\includes\functions\general.php on line 1328

     

    Line 1328 is:

     

     

       return call_user_func($function, $parameter);

     

    I have uninstalled, reinstalled, gone through all my changes, run searches on usu5, tep_reset_cache_data and call_user_func and even gone through the database.  There is an usu_cache table in our database.  I did drop it but its made no difference (I have since imported it again).

     

    I would appreciate any help or advice.

     

    Thanks in advance :)


  2. Hi

     

    I have just upgraded to 2.3.3.4 and am getting the following listing in my error log.

     

    It doesn't occur all the time, but there must be some pages which are producing this error.

     

    PHP Warning: Invalid argument supplied for foreach() in /pathtoroot/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 102

     

    and

     

    PHP Catchable fatal error: Argument 1 passed to aPage_Modules::linkText() must be an array, null given, called in /pathtoroot/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 170 and defined in /pathtoroot/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 338

     

    Does anyone have any suggestions/advice to offer? Please, any help will be gratefully received.


  3. I believe that this addon will not work with 2334 until it is recoded to proper parameters.

     

    Good one @@burt you answered my question :) But is there any news on when this particular add-on will be updated to be compatible with 2.3.3.4?

     

    It would be good to know.

     

    Best regards


  4. Ok so one assumes that I need to add the settings under admn/includes/sitemonitor_functions.php? This is defnitely not mentioned in the readme file.

     

    Also it makes no odds doing this. I still get the same message. So it can't be that. :sweating:


  5. Hi I am trying to set up SiteMonitor on a fresh 2.3.3.4 website. I get to step 6 and run the third option and I get the following message:

     

    Warning: opendir(/home/username/public_html,/home/username/public_html): The system cannot find the path specified. (code: 3) in C:\xampp\htdocs\kc14\KCAPaneL\includes\functions\sitemonitor_functions.php on line 364

     

    Warning: opendir(/home/username/public_html): failed to open dir: No such file or directory in C:\xampp\admin\includes\functions\sitemonitor_functions.php on line 364

    No new files found...

    Found a deleted file named

    No size differences found...

    No time mismatches found...

    No permissions mismatches found...

     

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Sitemonitor (0) ran on December 11, 2013, 11:48 am

    Total mismatches found were 1

    Total files being monitored is 0

    Email sent to shop owner.

    Reference file deleted due to reset setting.

     

    Warning: opendir(/home/username/public_html,/home/username/public_html): The system cannot find the path specified. (code: 3) in C:\xampp\admin\includes\functions\sitemonitor_functions.php on line 364

     

    Warning: opendir(/home/username/public_html): failed to open dir: No such file or directory in C:\xampp\admin\includes\functions\sitemonitor_functions.php on line 364

    Reference file creation failed!

     

    I also found that step 4 is unnecessary as the code has changed to include everything under admin/includes/boxes/

     

    Please could anyone shed some light?

     

    Many thanks in advance.

×