Jump to content

starcad

Members
  • Content count

    198
  • Joined

  • Last visited

1 Follower

Profile Information

  1. starcad

    Finally an easy Photogallery to install!

    Forgot to add that this works very well in STS.
  2. starcad

    Finally an easy Photogallery to install!

    HEY NIGEL, I have it up and running on my site here. I was also able to use the same technique to add a Blog to the site. Love the idea of using the iframe as it really makes thing easy to add to OSC. Thanks for pointing me in the right direction. Guy
  3. By far the easiest way to add templates, change the appearence of your site is to add STS to your catalog. It will allow you to set up your site with just about any template you desire by just inserting tage into the source code at the locations you desire. If you decide to try this option be sure to download the latest version STS4.2 . There is a support thread for this contribution and Bill is more than happy to help others with any problems they have.
  4. Can you post the URL and maybe your template code?
  5. starcad

    Finally an easy Photogallery to install!

    Damn, I love it Nigelman. What version did you download as there are several different files to download. Maybe you should consider making this a contribution.
  6. starcad

    [contribution] Simple Template System (sts)

    Just by chance you may want to check your image folder and make sure it is chmod 777 as properties show that the image is there just not being written to the file.
  7. starcad

    [Contribution] STS v4

    Bill and everyone that has followed my attempts to solve the problem of the popup image. Well, after reading through several hundred posts and trying many different avenues i finally read one of Bill's post about placing the <!--$headcontent--> in my sts_template. IT WORKS! Problem solved. I had looked at that post countless times and it never occured to me. This morning I thought I would check to see it I had that in my template and sure enough it wasn't there. Added and again IT WORKS! Thanks to all of you that have tried to help me through this and a Big Thanks to Bill who finally helpped me solve my problem. Guy
  8. starcad

    [Contribution] STS v4

    Hi Geert_K hope your still around and can shad some light on this subject. I'm having about the same problem you are in that I can not get the pop image to Pop. Did you finally solve the problem or are you still experinecing it? Any help would be appreaciated. Thanks
  9. starcad

    [contribution] Simple Template System (sts)

    Well looks like I was wrong on this one guys so don't use the above code it is not correct - Guy
  10. starcad

    [contribution] Simple Template System (sts)

    Bill, Great News! I think I solved the problem :D . I looked all over the net and found a function that would eleminate the javascript popup that good old XHTML refused to prase. Anyway here is the code for anyone that has this problem with XHTML in there product_info.php pages. First you have to delete the javascript code at the top of the file. Look for these lines of code <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le ft=150') } //--></script> and replace it with this function var newWindow = null; function closeWin(){ if (newWindow != null){ if(!newWindow.closed) newWindow.close(); } } function popUpWin(url, type, strWidth, strHeight){ closeWin(); if (type == "fullScreen"){ strWidth = screen.availWidth - 10; strHeight = screen.availHeight - 160; } var tools=""; if (type == "standard" || type == "fullScreen") tools = "resizable,toolbar=no,location=no,scrollbars=yes,menubar=yes,width="+strWidth+",height="+strHeight+",top=0,left=0"; if (type == "console") tools = "resizable,toolbar=no,location=no,scrollbars=no,width="+strWidth+",height="+strHeight+",left=0,top=0"; newWindow = window.open(url, 'newWin', tools); newWindow.focus(); } Next, look for this line of code <script language="javascript"><!-- document.write('<?php echo '<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id']) . '\\\')">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>'); //--></script> <noscript> Replace it with this line <a href="http://www.yoursite.com/catalog/popup_image.php? $product_info " target="popUpWin" onclick="popUpWin(this.href,'standard',400,600);return false;"></a> This eleminates the problem javascript call that XHTML will not allow by replaceing it with a function call and html thus allowing the popup to ah! POP! Hope this makes since. As I'm not a php, js, or XHTML programmer. Note I haven't yet ported this to my regular page but it can be seen at http://www.rcxjets.com/catalogold/product_...?products_id=28 Hope this may help someone else that is having this problem. Guy
  11. starcad

    [contribution] Simple Template System (sts)

    Getting back to you. If I turn on debug I can see where sts loads the script but for reasons beyond me it just won't pop. Looks like this in debug <script language="javascript"><!-- document.write('<a href="java script:popupWindow(\'http://www.rcxjets.com/catalog/popup_image.php?pID=28\')"><img src="images/f106catalog.gif" border="0" alt="Foamie F-106" title=" Foamie F-106 " width="100" height="80" hspace="5" vspace="5"><br>Click to enlarge</a>'); //--></script> <noscript> <a href="http://www.rcxjets.com/catalog/images/f106catalog.gif" target="_blank"><img src="images/f106catalog.gif" border="0" alt="Foamie F-106" title=" Foamie F-106 " width="100" height="80" hspace="5" vspace="5"><br>Click to enlarge</a> </noscript> I just can't seem to find the offending area of the code that will not let this pop. If I turn off sts then it works just fine. The anchor in the bottom line has the information to write the popup however this is where I get lost. Feeling helpless here!
  12. starcad

    [contribution] Simple Template System (sts)

    Thanks Bill for those hints I'll be looking at your references and get back to you in a day or so. I have looked at all the required code and still can't seem to figure out why it won't pop the image. But, I'll go back and read the manual again and sts_blank_template.html and compaire it to what is going on with my template. Oh, yes if I go back to and turn off sts it will pop. I really think that it has something to do with the XHTML not serving up the javascript correctly.
  13. starcad

    [contribution] Simple Template System (sts)

    Well, found a brain f**t in my code and have one problem fixed where I was adding the information box twice. Still looking on how to solve the popup image problem as I haven't quite solved this yet. If I take out the section of code above I can get a window.open but not the popup. Really getting a feel for ocs and sts 4.2 in the way it works.
  14. starcad

    [contribution] Simple Template System (sts)

    Well, after two weeks playing with Nifty Corners I've just about given up as there are still several problems associated wtih using the scripts. I've switched my page back to using the normal STS 4.2 scritps and templates. I do intend to use my project catalog to futher test the concept of using the Nifty scripts to see if I can work out the rest of the associated problems.
  15. starcad

    [contribution] Simple Template System (sts)

    Hey Bill, hope you see this as something in this forum won't allow me to post in here unless I reply to a question. Anyway, as you probably know I've been trying to track down the popup image problem I've been have with my site. Unsuccessfully, unfortunately. Here is the offending code. <script language="javascript"><!-- document.write('<?php echo '<a href="java script:popupWindow('\\\ . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id']) . \\\')">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>'); //--></script> <noscript> If I remove this code it will pop however there is no format to the popup, size, width, height and or position. I looded at the responce in an eirlier post and added the script and the tag however it still did not work. Tried messing with several different paths etc. and still nothing. All I can see in the the properties is the link to java script:popupWindow(http://www.rcxjets.com/catalog/popup_image.php? Seems as there is a ")" missing somewhere and I just can't seem to find it. Any clues to pointing me in the right direction would be extermly greatful. - Guy
×