Jump to content

sulelew

Members
  • Content count

    2
  • Joined

  • Last visited

Posts posted by sulelew


  1. I think i have the same problem as you... i think it's the php coding, but i?m not a php wizzard..

     

    Do you know where i can find the modified code to add to general.php ?

    Thnxz your help.

     

    This is from his intructions from the readme file in the zip.

     

    Step #5 - In:

    catalog/admin/includes/functions/general.php

    Just before the ?> at the very end of this file add the following:

     

      function tep_cfg_readonly($value){
      $single[]= array('id' => $value,
    					'text' => $value);
      return tep_draw_pull_down_menu('configuration_value', $single, $value);
     }
    
     function tep_cfg_pull_down_installed_fonts($font_name) {
      if ($root=@opendir(DIR_FS_DOCUMENT_ROOT.'includes/imagemagic/fonts')){
    		while ($file=readdir($root)){
    			  if($file=="." || $file==".." || is_dir($dir."/".$file)) continue;
    			  $files[]= array('id' => $file,
    							 'text' => $file);
    		}
      }
      return tep_draw_pull_down_menu('configuration_value', $files, $font_name);
    }
    
     function tep_cfg_pull_down_installed_watermarks($watermark_name) {
      if ($root=@opendir(DIR_FS_DOCUMENT_ROOT.'includes/imagemagic/watermarks')){
    		while ($file=readdir($root)){
    			  if($file=="." || $file==".." || is_dir($dir."/".$file)) continue;
    			  $files[]= array('id' => $file,
    							 'text' => $file);
    		}
      }
      return tep_draw_pull_down_menu('configuration_value', $files, $watermark_name);
    }
    
     function tep_cfg_pull_down_watermark_alignment($watermark_alignment) {
      $align[]= array('id' => 'Tiled',
    					'text' => 'Tiled');
      $align[]= array('id' => 'Top',
    					'text' => 'Top');
      $align[]= array('id' => 'Top Left',
    					'text' => 'Top Left');
      $align[]= array('id' => 'Top Right',
    					'text' => 'Top Right');
      $align[]= array('id' => 'Center',
    					'text' => 'Center');
      $align[]= array('id' => 'Bottom',
    					'text' => 'Bottom');
      $align[]= array('id' => 'Bottom Left',
    					'text' => 'Bottom Left');	 
      $align[]= array('id' => 'Bottom Right',
    					'text' => 'Bottom Right');																																									 
      return tep_draw_pull_down_menu('configuration_value', $align, $watermark_alignment);
    }

     

    I hope I did that right an it doesnt screw up the page.


  2. Hi, i can't get image working properly, the server info matches the requirements, only no watermark is showing up

     

    but there's something strange.

    if i go to the admin -> watermark image file -> and i click on the collum change, the collum change dissapears, so i can't select any watermark....

     

    The samething happens with text watermark font.

     

    All the file are on the server..

     

    any thoughts?

     

    This sounds like the same problem I had in admin whenever I selected one of options that had to have a dropdown menu to select from ( watermark image, watermark position, text font and text position) when I would hit edit, the column would disappear. I also checked an checked the database for something that was off, but nada.

     

    So it ended up being the code added (from readme/installation v1.14/1.15 step#5) for catalog/admin/includes/functions/general.php - thats what worked for me (because I am using a modified version for cre and everything worked except those functions and I was missing that bit of code added to general.php)

     

    May not be the same problem as yours but it sounds similar so I thought I would throw in what worked for me. Hope it helps in some way!

     

    And thanks Tom and everyone who has contributed to this contrib, its excellent!

×