Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

sgostelow

Members
  • Content count

    16
  • Joined

  • Last visited

Everything posted by sgostelow

  1. Social Bookmarks v1.0 - del.icio.us, digg, etc Date: 29th June 2007 Author: Shaun Gostelow Support Thread: This thread! If you find this contribution useful please DONATE WITH PAYPAL (see the INSTALL.html) to encourage future development. What is the Social Bookmarks OSCommerce contribution? This small contribution to OScommerce adds links at the bottom of product pages so that users on your site can bookmark the page with a social bookmarking service such as del.icio.us or digg. This is a great way to help with SEO efforts as your product pages should get lots of inbound links. If you have additional services (Google Bookmarks, etc) you would like to add to this contribution please feel free to add more, or donate to encourage further development. Have fun...
  2. sgostelow

    Product Sales and Stats v2.0 Contribution

    I've just discovered that the cron job was not adding new products that were added after installation of the contribution. I fixed this by adding the following lines to cron_update_bestsellers.php: tep_db_query("delete from products_yearly_sales"); tep_db_query("INSERT INTO products_yearly_sales ( products_id ) SELECT products_id FROM products"); below the following line: require('includes/application_top.php'); I hope it helps someone! Shaun
  3. Social Bookmarks v1.2 contribution for OSCommerce released. Changes: Added support for Google Bookmarks and Yahoo myWeb. Bookmark sites now launch as separate browser window/tab. Link to contribution: Social Bookmarks for OSCommerce v1.2
  4. Please ignore this thread. This is a duplicate. Use this thread instead: http://forums.oscommerce.com/index.php?showtopic=267891
  5. Social Bookmarks v1.0 - del.icio.us, digg, etc Date: 29th June 2007 Author: Shaun Gostelow Support Thread: This thread! If you find this contribution useful please DONATE WITH PAYPAL (see the INSTALL.html) to encourage future development. What Is Social Bookmarks? This small addition to OScommerce adds links at the bottom of product pages so that users on your site can bookmark the page with a social bookmarking service such as del.icio.us or digg. This is a great way to help with SEO efforts as your product pages should get lots of inbound links. If you have additional services (Google Bookmarks, etc) you would like to add to this contribution please feel free to add more. Have fun...
  6. Doh! Thanks for spotting that jamez. Glad to hear it worked for you. I've uploaded a new version (v1.1) with the del.icio.us and digg icon images. I've also added a missing space before the del.icio.us text. You can download this from: http://www.oscommerce.com/community/contributions,5261 Note: There is a duplicate of the contribution in the credit modules section. Please ignore this. I've let the mods know and asked for it to be removed. Cheers Shaun
  7. Contribution download link: http://www.oscommerce.com/community/contributions,5261
  8. sgostelow

    Protx Direct v2.22

    zarren: That's a bit cheeky asking Tom to "sort it out"!!! Since when did open source authors who work on code in their spare time ever have to do anything for anyone else? Maybe you should be a little more polite if you really do want it fixed! :angry: Tom: I'd just like to say thanks for putting in so much hard work to make the Protx Direct contribution such a valuable additition to OScommerce. I for one very much appreciate it. :thumbsup: Cheers Shaun
  9. sgostelow

    Automatically send data feed to Froogle

    I've added some echo comments into the feeder and it seems it's hanging on the line: $upload = ftp_put( $conn_id, $ftpdestinationfile, $ftpsourcefile, FTP_ASCII ); It gives the connection reset error in the middle of this. Does this mean there is some kind of FTP connectivity issue from my host? Even it there was I would have expected the script to fail gracefully. Any ideas? Thanks Shaun
  10. sgostelow

    Automatically send data feed to Froogle

    I have a very strange problem with the Google Base Feeder. I get the following output: File completed: myfeedfile.txt Connected to uploads.google.com, for user myusername And then after about 10 seconds I get a "The connection was reset" screen. It seems the script has just died. On my Google Base account I get a zero length file and it obviously gets rejected. Is there any way I can turn on debug messages to see how far the FTP gets? Thanks Shaun
  11. sgostelow

    Protx Direct v2.22

    Hi Tom, Thanks for the hints about session IDs. Watching the address bar as I navigated through checkout I could see the session ID get re-issued. It was also happening when clicking Buy Now buttons on the product listings. So did a bit of digging around and found that my /includes/configure.php had some incorrect settings. Found this really useful thread on how it should be conifigured for an SSL environment: http://www.unitedforums.co.uk/vb/showthread.php?t=4217 Changed HTTPS_COOKIE_DOMAIN to be blank and hey presto sessions started working correctly. Thanks for your assistance. Shaun
  12. sgostelow

    Protx Direct v2.22

    Hi Tom, Thanks for the hints, it's very much appreciated. Below are the session settings for the website: Title Value Action Session Directory /home/myhomedir/tmp Force Cookie Use False Info Check SSL Session ID False Info Check User Agent False Info Check IP Address False Info Prevent Spider Sessions True Info Recreate Session False Info Note: The directory myhomedir has been swapped with my hosting account name for security. When I've got time tomorrow I'll try switching the sessions variable in configure.php. To enable database stored sessions should it be set to 'mysql' as suggested in the file? I have Ultimate SEO installed that has modified html_output.php. I'll re-check the code changes are correct for that. Thanks Shaun
  13. sgostelow

    Protx Direct v2.22

    Hello. I've got Protx Direct v3.0a integrated with my OSCommerce site and can process credit card transactions OK. However, if I put through incorrect details I get redirected to the signin page (login.php) If I enter all invalid details (card number, end date, cvv) then I get redirected to login.php when I click Continue on from checkout_payment.php If I enter a correct card number, but end date and cvv then get redirected to login.php when I click Confirm Order on from checkout_confirmation.php Does this make any sense? Shouldn't I be getting some kind of error message? I'd really appreciate help with this. Thanks Shaun PS If you want to try breaking it for yourself the website is www.xtendedplay.co.uk :blink:
  14. Interestingly, despite the fact that my links within categories do not display I've just added a featured link and that displays with no problem...
  15. I forgot to mention that I've installed Links Manager v1.14 on CRE Loaded 6.2. Also it's probably better if you look at this link instead myBoomBox web links page as you can see the category counters and then when you click on the category (e.g. iPod Forums & Discussion) it comes back with an empty list. Shaun
  16. We're running CRE Loaded 6.2 Standard and are seeing the problem where the links do not show up when you click on the link category. The category listings gives a link count that is correct, and the links appear correctly in the Admin->Links Manager->Links page. The links page displays the default text "There are no links to list in this category." I've ensured that the link is approved and the language settings are correctly set to English in all relevant admin screens. Below is an SQL dump from the shop demonstrating this problem as requested on post #422 (quoted above): select l.links_image_url, ld.links_title, ld.links_description, l.links_url, l.links_clicked, l.links_id, ld.language_id from links_description ld, links l, links_to_link_categories l2lc where l.links_status = '2' and l.links_id = l2lc.links_id and ld.links_id = l2lc.links_id and l2lc.link_categories_id = '1' and ( ld.language_id = '1' xor ld.language_id = '99') order by ld.links_title You can see it for yourself on our website (due to go live in the next month or so) - see myBoomBox iPod accessories It seems the issue is with the language SQL WHERE clause as the other clauses look OK... any help with this appreciated. Thanks
×