Jump to content

Ethan1701

Members
  • Content count

    172
  • Joined

  • Last visited

Everything posted by Ethan1701

  1. Ethan1701

    [Contribution]Paypal IPN - Devosc

    I'm having the same problem. I don't at the moment have the option of testing, but I suspect this might only occur when a customer logs in and goes directly to the checkout. No way of confirming this - this is what happened now. I'm getting a confirmation email about the order, and I am getting the money. However, the order doesn't appear in the database. Please help! -Ethan
  2. Ethan1701

    dob dropdown

    I've been having the same problems. My server doesn't print the error messages to the screen, so I never know what the problem was until now. After reading your error message, I found a solution to the problem: replace <?php for ($i=1; $i<32; $i++) { line378: $dob_day[] = array('id' => sprintf('%02d', $i), 'text' => sprintf('%02d', $i)); } for ($i=1; $i<13; $i++) { $dob_month[] = array('id' => sprintf('%02d', $i), 'text' => strftime('%B',mktime(0,0,0,$i,1,2000))); } $today = getdate(); $first_year = $today['year'] - 77; $last_year = $today['year'] - 10; for ($i=$first_year; $i < $last_year; $i++) { $dob_year[] = array('id' => sprintf('%02d', $i), 'text' => sprintf('%02d', $i)); } echo tep_draw_pull_down_menu('dob_day', $dob_day); echo tep_draw_pull_down_menu('dob_month', $dob_month); echo tep_draw_pull_down_menu('dob_year', $dob_year); echo tep_not_null(ENTRY_DATE_OF_BIRTH_TEXT) ? '<span class="inputRequirement">' . ENTRY_DATE_OF_BIRTH_TEXT . '</span>': ''; ?> with <?php for ($i=1; $i<32; $i++) { $dob_day_arr[] = array('id' => sprintf('%02d', $i), 'text' => sprintf('%02d', $i)); } for ($i=1; $i<13; $i++) { $dob_month_arr[] = array('id' => sprintf('%02d', $i), 'text' => strftime('%B',mktime(0,0,0,$i,1,2000))); } $today = getdate(); $first_year = $today['year'] - 77; $last_year = $today['year'] - 10; for ($i=$first_year; $i < $last_year; $i++) { $dob_year_arr[] = array('id' => sprintf('%02d', $i), 'text' => sprintf('%02d', $i)); } echo tep_draw_pull_down_menu('dob_day', $dob_day_arr); echo tep_draw_pull_down_menu('dob_month', $dob_month_arr); echo tep_draw_pull_down_menu('dob_year', $dob_year_arr); echo tep_not_null(ENTRY_DATE_OF_BIRTH_TEXT) ? '<span class="inputRequirement">' . ENTRY_DATE_OF_BIRTH_TEXT . '</span>': ''; ?> What I did was replace the arrays dob_day[], dob_month[] and dob_year[] with arrays by the same name with the suffix _arr. The reason for this, is that when the page calls for itself (as it does if the email address exists), it receives variables from your browser by the same names as the arrays. The error you got tells us that it can't turn a string variable into an array. It was trying to, because they have the same name. So giving the arrays a new, distinguishing name, solved the problem. You can replace your code with the one I put here. I'll ad a new version to the contribution for the next generations. -Ethan, doing my share.
  3. Ethan1701

    Register Globals Support

    Hi, I just installed this contribution, and it went perfectly! I'm releived, grateful, and rather surprised that the default for osCommerce is globals = on. It's so simple to deactivate them. Thanks a million to all those who worked on this! -Ethan
  4. Hi, In the past couple of weeks, my SE raing has been dropping, till now it's all gone. I traced the problem to the autologin contribution: if there's no cookie (which SE won't have), they get forwarded to the logoff page The hearders here suck, and that's besides there not being any products on this page. Can someone please briefly explain to me why the user is directed to the logoff page in the first place? Is there a nkown fix for this issue? for the meantime, I'm disabling the autologon, but I'd like to get it to work properly, so I could reactivate it. Please help, -Ethan
  5. Ethan1701

    Autologin makes Search engines leave

    maniac101, it's good to know I'm not the only one with this problem. I think I'm using MS2 (how could I check?). Let me know if you make any progress, or if you'd like me to do anything to help. -Ethan
  6. I've installed a 'who's online' enhancement, and it has given me a few ideas for additional enhancements I'd like to see, but I'm not sure how to do on my own. Here are the ideas I've had: compair user ID to robots.txt. If the user is a bot, color the line is color A detect my IP. color my sessions in color B Control these colors via stylesheet. onder the list, summerise with: ........................distinct..............total customers.............5......................7 search engines......2......................3 Administrator........1......................2 total.....................8......................12 If a customer has something in his shopping cart, color session in color C Can this be done? I'd be happy to help, but I have no idea where to start. -Ethan
  7. Ethan1701

    Autologin makes Search engines leave

    I don't have the sID killer installed. Might this have to do with one of the settings in admin-> configuration-> Sessions? I have everything set to false, except for 'Prevent Spider Sessions', which is true. -Ethan
  8. Ethan1701

    Autologin makes Search engines leave

    could you link to your thread? maybe one of the folks who had not had this problem could share their file sources, and we could find the problem... -Ethan
  9. Ethan1701

    Autologin makes Search engines leave

    Jeese, I didn't expect so many replies... ;-) I'm sure other folks here use this contrib, and have encountered this problem. Can anyone please lend a hand? -Ethan
  10. Ethan1701

    Help me!

    I find this site useful for IP whois's: http://www.arin.net/whois/ works better then Ripe... -Ethan
  11. Ethan1701

    Recover Cart Sales

    A quick question: In the current version, clicking on a customer's name will open the customer list page, searching for his last name. How can this be altered so instead it goes into the specific customer's info page, based on the customer ID? -Ethan
  12. Ethan1701

    Browse by Categories

    oakhill, I installed the enable/disable contribution a few weeks ago, over a very moded osC. I had to edit the code of all the contributions i had previously installed, but it's not too dificult. This will take some basic SQL understanding, and a lot of patience: The enable/diasable contribution (from here on to be known as E/D), adds a column to the categories table, called categories_status. In all the queries you run, you have to make a condition on this column, as the E/D SQL statements would show. any query you wish to edit, which already refers to TABLE_CATEGORIES is easy to fix. In it's WHERE clause, add the following condition: c.categories_status = '1' Most queries do in fact read from this table, among others, but if you encounter one that doesn't you will have to add the table to the FROM clause (from " . TABLE_CATEGORIES . " c, " ), and in the WHERE clause, use the code I gave you above, and link the table to any other tables by the common fields, usually being the categories_id (WHERE c.categories_id=cd.categories_id, for example) This ought to fix all the problems you have in this matter. -Ethan
  13. Hi, I installed the enable/ disable category contribution. It has you alter the Queries to the database, to reflect the change it made. It verifies that the cetegory status is '1'. This works great, but not perfect. I've installed some other contributions, and I need to incorporate this change into them. I'm haveing a hard time especialy with the all_prods contribution. the query in it is $listing_sql = "select p.products_id, pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where p.products_status = '1' order by p.products_price, pd.products_name"; I need to somehow add to this a line basically saying where c.categories_status = '1' and... , where as usual, C is TABLE_CATEGORIES. I will also need help finding how to add this change to the categories dropdown list in the advanced search. Thanks! -Ethan
  14. Ethan1701

    [Contribution] Newsletter Unsubscribe v1.1

    THat's the beauty of open source (or Free software, as you like). leave the code lieing around, and someone else is bound to use it and make something even better out of it! Glad to have helped. -Ethan (who the fog is Ed?)
  15. Ethan1701

    [Contribution] Newsletter Unsubscribe v1.1

    Ed, I could never get the search engine safe URLs to work. it would do what you described to every parameter it would pass... I don't know how it's meant to work, but it shouldn't be to hard to fix this.. -Ethan
  16. Ethan1701

    [Contribution] Newsletter Unsubscribe v1.1

    Jim, Your contibution worked, thank you! I did, however, have to make a few changes, which I beleive should be made public as the next version: 1. in order for the link in the email to work, you must add the following lines to admin/includes/filenames.php: //// Begin Unsubscribe hack ? define('FILENAME_UNSUBSCRIBE', 'unsubscribe.php'); //// End Unsubscribe hack 2. sdtep 2 of the readme creates a link which is missing the /catalog/ part of the URL. to fix this, replace $mimemessage->add_text($this->content . TEXT_UNSUBSCRIBE . HTTP_CATALOG_SERVER . FILENAME_UNSUBSCRIBE . "?email=" . $mail['customers_email_address']); with $mimemessage->add_text($this->content . TEXT_UNSUBSCRIBE . HTTP_CATALOG_SERVER . DIR_WS_CATALOG . FILENAME_UNSUBSCRIBE . "?email=" . $mail['customers_email_address']); Also, if you're sending out HTML base emails, as I am, you may want to change the function call from add_text to add_html. In order to make the link clickable in an HTML email, as well as in non-HTML email clients, replace $mimemessage->add_text($this->content . TEXT_UNSUBSCRIBE . HTTP_CATALOG_SERVER . DIR_WS_CATALOG . FILENAME_UNSUBSCRIBE . "?email=" . $mail['customers_email_address']); with $mimemessage->add_html($this->content . TEXT_UNSUBSCRIBE . '<a href="' . HTTP_CATALOG_SERVER . DIR_WS_CATALOG . FILENAME_UNSUBSCRIBE . "?email=" . $mail['customers_email_address'] . '">' . HTTP_CATALOG_SERVER . DIR_WS_CATALOG . FILENAME_UNSUBSCRIBE . "?email=" . $mail['customers_email_address'] . '</a>'); 3. again in the readme, you left the line that advises on how to check if it works with the mistake it had in it. that is, it says ? ? UPDATE customers SET customer_newsletter = '2' where customer_newsletter = '1' instead of ? ? UPDATE customers SET customers_newsletter = '2' where customers_newsletter = '1' other then that (and those are really minor fixes), It works like a charm! I think a new version ought to be made with the fixes I proposed. If you prefer, I'll make it. -Ethan
  17. Ethan1701

    [Contribution] Newsletter Unsubscribe v1.1

    kymation, before I go into the trouble of trying out your release, I think it would benefit everyone if you were to please list all the changes you've made. many of the directories in your release are empty, and I don't know If that's deliberate or not. Have you found a fix for the problem I had - the contribution passed the sID as part of the email address, and returned an error with every unsubscribe atempt. -Ethan
  18. Ethan1701

    Browse by Categories

    That worked! Thanks for that code!! BTW, if I may suggest another idea for version 2.6: Include a readme file, which will tell people exaclty what lines of code have to be removed, and what has to come instead of them. Telling them the line numbers on the stock file is also needed. This will make it easier for users to remove the contribution if they so choose, and it might also help track back problems people have while installing it. -Ethan, he who broke the code of this forum, and opened a new table row. :)
  19. Ethan1701

    Browse by Categories

    straider, I took your advise, and replacved my index.php with the one in the contribution, and still, no good. Not only that, but the lines of code you say appear twice - only appear once. I'm attaching the code in the contribution I downloaded. Maybe you could figure out what's going on... BTW, do you have a site for example where branch categories appear properly? IE, showing sub-categories and products? for compairison, here's my index.php, with the BBC and other modifications:
  20. Ethan1701

    Browse by Categories

    straider, You could take a look at my site at http://www.madab-il.com. though the site is in Hebrew, I think you could manage, with the layout and the images. Click on the Star Trek category (second row, on the right). you will the nsee the products I have in that category, but not the subcategories. You could only get to them by clicking on them from the categories box on the right. I'm sure I'm loosing a lot of customers because of the fact they can't find things they're looking for... Like I said earlier, my index.php is identicle to the one in the contribution, and even tehr I can't seem to understand how it's meant to show the categories in non-leaf categories: around line 160 of the index.php file is all the code that displays products. I can't find any referance to the BBC in this segment of the code! I'd expect there to be the sub-categories box, and under that, the products listing...
  21. Ethan1701

    [Contribution] Newsletter Unsubscribe v1.1

    Hi, I just installed this contribution, but I have one problem I can't figure out (had others that I fixed): After copy-pasting the URL from the email to my browser, I get to http://www.madab-il.com/catalog/unsubscrib...il=ethan@<no spam!>.com, which shows me the unsubscribe page. When I click on the button, however, I'm directed to http://www.madab-il.com/catalog/unsubscrib...il=ethan@<no spam!>.com?osCsid=6442bff62650d641f69e88d9a99fe751, or some othe sID. the unsubscribe_done does't seperate the two parameters being passed, and tells me that the email address below is not on the database: ethan@<no spam!>.com?osCsid=6442bff62650d641f69e88d9a99fe751 I tested a little, and found that if I replace the '?' with a '&', it will in fact work. The question is, where would I put this fix, and why is this problem occuring? Other then that, there are several fixes that have to be made for MS2.2, such as putting all the defines in the filenames.php file, and calling to the file within DIR_WS_CATALOG (would have fixed problems other people mentioned earlier.) Alother modification worth making is in unsubscribe_done, telling customers that they can always re-subscribe by going into their (link) account manager. The problem I mentioned is one cookie I could use some help cracking... -Ethan
  22. Ethan1701

    Browse by Categories

    Regarding the problem I mentioned before; (quick reminder: If I'm in a cetegory, say, Hardware, The subcategories don't appear, only the products within the top level category) I compaired my index.php to the one in the contributions' ZIP file, and there's no diference. My guess, is that the problem might be caused if a category has sub-categories, and products in the same level. In my case, for example, I may have: Star Trek +Shirts +Action figures +Posters -Klingon snow globe -Some other product -And so on... Where the Bold represents a sub-category, and the italic, a product. I haven't seen any other stores where products and categories are listed in the same level, and this is whjy I suspect that this is the cause. I can't think of any other reason why the subcategories wouldn't be listed. I'd love some help here! Could you direct me to the lines of code that call the subcategory display, within the contributions index.php? -Ethan
  23. Ethan1701

    Browse by Categories

    Hey there, I have this contribution installed, but I have a problem, which I had originally thought was a feature: Brouse by categories (henceforth: BBC) doesn't show when I'm in a sub-category. The only reason I could find for that, or at least - this is what drew my attention, is this segment of code I have commented out. It came that way- I don't recall editing it out myself: ~ line #90 of index.php Might his have anything to do with it? is there some other known cause for this? Another issueu that has to be attended to is correcting the comments in the code, to reflect the current vertion of BBC, instead of the older ones, currently mentioned. -Ethan
  24. Ethan1701

    Dynami Title for index.php

    is the file you quoted some contribution? what is it, and where might I find it? -Ethan
  25. Ethan1701

    Dynami Title for index.php

    chances are, the variable isn't defined. go to includes/languages/english.php. and look for if you find it, name it as you wish. my bet is that you may have accidentally deleted it, and will need to recreate it. no biggy.
×