Jump to content

hopefuloperator

Members
  • Content count

    13
  • Joined

  • Last visited

Profile Information

  • Real Name
    Steven Gordon
  1. hopefuloperator

    Multi_Vendor_Shipping new thread

    Hello, For some reason, I(the store owner) and the the vendor do not recieve emails when a product is purchased on my online store. However, when I type in an email address under send order to extra email address in admin-> config that email address a copy of the order. Also, my customers still recieve a confirmation from the store. MVS is turned on in my store, and send to vendor is also turned on. I have osCommerce 2.2 Milestone 2 Update 051112 installed at my shop with CCGV and other mods but not the fancier invoice with HTML. I did try to install that mod, but after reading that this module interferes I uninstalled it. Anyone have any suggestions? Thanks, Steve
  2. hopefuloperator

    [CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

    When I installed SEO URL's everything was working fine. Than I moved my catalog folder to my root folder and I started getting error 404 when I tried to access the products on my webiste. To fix this, I deleted the word catalog in the .htaccess file in my root directory. This is what my new line looks like. RewriteBase / Hope this helps some people.
  3. hopefuloperator

    ### POINTS AND REWARDS MODULE V1.00 ###

    When I just tried to install Points and Rewards Verion 2 d I may have found an error in the install.txt file. It says for step 3 for users of CCGV replace if ( (is_array($payment_modules->modules)) && (sizeof($payment_modules->modules) > 1) && (!is_object($$payment)) && (!$credit_covers) ) { with ##### Points/Rewards Module V2.00 check for error BOF ####### if (isset($HTTP_POST_VARS['customer_shopping_points_spending']) && USE_REDEEM_SYSTEM == 'true') { if (isset($HTTP_POST_VARS['customer_shopping_points_spending'])&&tep_calc_shopping_pvalue($customer_shopping_points_spending) < $order->info['total'] && !is_object($$payment)) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(REDEEM_SYSTEM_ERROR_POINTS_NOT), 'SSL')); } else { if (!tep_session_is_registered('customer_shopping_points_spending')) tep_session_register('customer_shopping_points_spending'); } } if (isset($HTTP_POST_VARS['customer_referred']) && tep_not_null($HTTP_POST_VARS['customer_referred'])) { $valid_referral_query = tep_db_query("SELECT customers_id FROM " . TABLE_CUSTOMERS . " WHERE customers_email_address = '" . $HTTP_POST_VARS['customer_referred'] . "'"); $valid_referral = tep_db_fetch_array($valid_referral_query); if (!tep_db_num_rows($valid_referral_query)) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(REFERRAL_ERROR_NOT_FOUND), 'SSL')); } if ($HTTP_POST_VARS['customer_referred'] == $order->customer['email_address']) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(REFERRAL_ERROR_SELF), 'SSL')); } else { $customer_referral = $valid_referral['customers_id']; if (!tep_session_is_registered('customer_referral')) tep_session_register('customer_referral'); } } // if ( (is_array($payment_modules->modules)) && (sizeof($payment_modules->modules) > 1) && (!is_object($$payment)) && (!$credit_covers) ) { if ( (is_array($payment_modules->modules)) && (sizeof($payment_modules->modules) > 1) && (!is_object($$payment)) && (!$credit_covers) && (!$customer_shopping_points_spending) ) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL')); } ######## Points/Rewards Module V2.00 EOF #################*/ When doing this I had to copies of tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL')); } which gave me an error on my line 97 because I had an extra " } ". Just delete the copy of tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL')); } that isn't in the Points/Rewards Module slashes to fix the problem.
  4. hopefuloperator

    Credit Class/Gift Vouchers/Discount Coupons 5.10

    It seems like my site is fixed. I re-uploaded most of the files and rechecked the instructions. This seemed to fix things.
  5. hopefuloperator

    Credit Class/Gift Vouchers/Discount Coupons 5.10

    Hello, I just installed Credit Class and Gift Vouchers today version 5.16. I installed in using the latest instructions from June 30th. I am getting this error after I installed it. Fatal error: Call to undefined function: clear_posts() in /homepages/18/d169071379/htdocs/catalog/checkout_payment.php on line 91 I searched the forums and found this error once before, but it was supposed to be corrected with the new instructions. Here is line 91. $order_total_modules->clear_posts(); // ADDED FOR CREDIT CLASS SYSTEM by Rigadin in v5.13 Any help would be appreciated. Thanks, Steve
  6. hopefuloperator

    Multi_Vendor_Shipping new thread

    Thank you for the quick reply. I haven't been able to find $db_query in any other admin files(although I didn't search everyone). I found tep_db_query in my admin section, but I don't think this should be an issue. The weird thing about this is when I try to edit another user(not the 1st one) I have no problems. It is just when I try to access this file admin/admin_members.php?page=1&mID=1&action=edit_member I recieve the error message. Is this making my site any less secure? Any other suggestions? Best, Steve
  7. hopefuloperator

    MVS 1.1 - Access Denied Error

    Did you store all of the files available in the vendors section? That should do the trick.
  8. hopefuloperator

    Multi_Vendor_Shipping new thread

    Hello, Just installed MVS 1.1 today. I also have installed order editor and Admin Access version 2.2. Order Editor and MVS appear to work, but when I double click in my administrative system with admin access on my admin name, I recieve this error Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in */includes/functions/database.php on line 107. I did not see this error before I installed MVS today. Does anyone know of any reason why this could be happening. Line 107 in my databse.php file is Line 106 function tep_db_num_rows($db_query) { Line 107 return mysql_num_rows($db_query); Line 108 } I read the previous post on how the installation instructions need to be modified and didn't know what these two lines were about or if I needed to modify them at this point. I am not sure if this would help me though. Thank you. Checkout shipping in catalog has an extra <? around line 63 also around the first entry for MVS the first part is messed up. comapre to original file included with the package, you should be able to figure it out pretty easy using the search command Any insight provided would be greatly appreciated. Thank you.
  9. Hello, Just installed MVS 1.1 today. I also have installed order editor and Admin Access version 2.2. Order Editor and MVS appear to work, but when I double click in my administrative system with admin access on my admin name, I recieve this error Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in */includes/functions/database.php on line 107. I did not see this error before I installed MVS today. Does anyone know of any reason why this could be happening. Line 107 in my databse.php file is Line 106 function tep_db_num_rows($db_query) { Line 107 return mysql_num_rows($db_query); Line 108 } I read the previous post on how the installation instructions need to be modified and didn't know what these two lines were about or if I needed to modify them at this point. I am not sure if this would help me though. Thank you. Checkout shipping in catalog has an extra <? around line 63 also around the first entry for MVS the first part is messed up. comapre to original file included with the package, you should be able to figure it out pretty easy using the search command Any insight provided would be greatly appreciated. Thank you.
×