Latest News: (loading..)

edukes

Members
  • Content count

    149
  • Joined

  • Last visited

2 Followers

About edukes

Profile Information

  • Real Name
    Eddie
  1. Hello, Running a rc2.2 shop. Today a customer called and said she can't check out. So I tried myself. Products are added to the shopping cart but when clicking 'Checkout', it states the shopping cart is empty. Clicking 'Continue Shopping', the cart shows items. The site was working fine until apparently today. I have not made any changes in probably a couple years. There are no errors, just the message, 'Your shopping cart is empty'. This is very odd. I wish I could provide more info but that's all I have. The next step in the checkout procedure is shipping. I use UPS. Could it be something there? TIA
  2. Thanks, Jim! I'm just trying to stay of the game this time. A few year back when my hosting company changed the version php, it took weeks to straighten out all those deprecated functions on a heavily modified shop. This time, I want to keep it simple. When they change to php 5.4x, it will break my shop again. I have a Centos 7 VM with php 5.4 running here at the house on my server and testing opencart, but I don't really like it. Thanks, again!!
  3. Not sure if this is a reply to my post, but I am using the most current version of osCommerce (2.3.4) and the Theme Switcher released in July 2016. What is the Responsive build? Been running rc2a for years. Time for a fresh look.
  4. Trying to install Theme Switcher on a fresh install of OSC 2.3.4. Been working on this since this past Sunday. I'm just not getting it. I have the error, The theme CSS file is the wrong version or missing! Checking the users manual in the troubleshooting section, 4.3 Theme Doesn't Show in Theme Switcher, I copied the themes to catalog/ext/jquery/ui Went back to section 3.2, The selected version of the theme was found. This tells you that the version of your theme matches the version of your jQuery UI file. If you see The theme CSS file is the wrong version or missing! instead, you probably updated the jQuery UI file without updating the theme. Go check that again. In the Theme Switcher package, there are two directories, Boostrap and OsCommerce 2.3.x. I used the files from the 2.3.x directory. The files in Boostrap, break things. Not sure what I'm doing wrong. TIA
  5. I didn't find any diffs in the MVS sections. The hardest is the admin/category file. MVS, Header Tags, SEO URLS and Add More Fields like being in the same places. If you look at the checkout_ files and compare them from the files in 2.3.3 you can see some changes, but I doubt that's what's causing the problem since I have tried using the files from the mvs package and still get the same errors. Pretty sure its on the admin side.
  6. Going to start over from scratch. Did the catalog side today using compare and merge. Saw no diffs except for possible differencies in 2.3x and 2.33. Must be on the admin side. What version is the alpha version based? thanks!!
  7. I checked the products table in the database. Then vendor id is set to 1, My Store. I guessing that the 1 in "Warning: strpos() expects parameter 1 to be string" is the vendor id of My Store.
  8. I may need to do an easy populate download, add the vendor then re-upload?
  9. I have only one, My Store. When I go into a products description, it shows no vendor. I tried changing it to My Store but it won't save. I can do an easy populate download and it shows all products with the vendor name as My Store. Also, I found to tables that were not added by the mvs.sql products_sort_order products_qty_blocks I added them to the products table as VARCHAR. That may not be right.
  10. I must have gotten the memo, but the new easy populate uses the vendor name, not the vendor id. :blush:
  11. Hey Jim, I have flat rate and USPS. I installed the updated USPS package. (Using it on my live, rc2a) site with no problems.) Thanks, Eddie
  12. Thanks, I found the error in the includes/languages/english/checkout_payment.php file. I had an extra ?> at the end of the file I didn't see the first time. I'm getting there. Going through the check out, I get to checkout_confirmation and get Warning: strpos() expects parameter 1 to be string, array given in /......includes/classes/vendor_shipping.php on line 46 Warning: substr() expects parameter 1 to be string, array given in /....../includes/classes/vendor_shipping.php on line 46 Warning: strpos() expects parameter 1 to be string, array given in /....../includes/modules/order_total/ot_shipping.php on line 48 Warning: substr() expects parameter 1 to be string, array given in /....../includes/modules/order_total/ot_shipping.php on line 48 We're getting close!! :) Thanks!!
  13. Have a new problem. Going through the checkout process and I get to checkout_confirmation, then ?> Warning: Cannot modify header information - headers already sent by (output started at /....../includes/languages/english/checkout_payment.php:36) in /....../includes/functions/general.php on line 50 Not sure what's causing the ?> I am using the checkout_confirmation file from the 1.3 package. The only addition to the general.php is the Ultimate SEO URLs 5 Pro TIA
  14. Ooops, I thought I would run into this again. Deprecated: Function ereg() is deprecated in /....../admin/vendor_modules.php on line 229 In my live store I made this change: // if (ereg('->', $use_function)) { if (preg_match('/->/', $use_function)) { Not sure its right but I don't get any errors
  15. Moving xmldocument,php to the admin side worked. I have two errors on the catlog side during checkout but I think that has to do with not having a shipping method specified/setup. Thanks!!