Latest News: (loading..)

little.pm

Members
  • Content count

    116
  • Joined

  • Last visited

1 Follower

About little.pm

  • Birthday 02/20/1971

Profile Information

  • Real Name
    Ralf Buescher
  • Gender
    Male
  • Location
    Germany, Bavaria, Feldafing
  • Interests
    Perl, PHP, Q3A, beer, pizza (did I mention programing?)
  • Website
  1. Hello Johannes, I am glad you like it. Yes, I do know the effect, but it does not only occur in german but also in all languages that use non standard ascii character sets but rather extended character sets. Think about accent acute in french for example. I like your solution to the problem. However, a single solution for just one language can not fix the problem in general. So I would prefer to go along the way with the languages themselves. Every language that we know of has an alphabet wich defines the sort order for each character. So in the end we need to define a sort function, that sorts any list we give to it according to the predefined alpahbet for that language. The alphabet could be defined in the language file, eg. includes/languages/english.php or includes/languages/german.php. The sort function gets the list we want to sort. It also gets the language ID for the language in wich (or according to that languages alphabet) we want to sort and a third argument stating a sort option, eg. ascending or descending. Such function itself could be reused all over the place for other parts of the shop where a language dependend sort function could be of use, eg. to display and sort products options names. The reason why I take the short time to write this down, is simply because I do currently not have the time to code such sort_function. May be you would have time and would want to code it : I would say to you as to everyone else: You're welcome, because its an open source project based on collabortaion :-) regards Ralf
  2. Just posted an update so the contribution now contains also the spanish countries names (wich where provided by Pablo Ferrer). regards ralf
  3. the above syntax is wrong as ORDER BY requires an argument wich has been omitted and hence the following LIMIT causes the error regards ralf
  4. Patrick, first off the question "why would you want to do this?" DO you use HTTPS? Do you have your own SSL-Cert? Do you have your own dedicated server? Can you assure taht no one ever hacks into your server? Can you assure that no third person reads your email while being send (you do use encryption for the order emails from your shop to your account?)? In Short can you assure the users data are protected? If any of the above had the answer NO then please consider using PayPal or Worldpay or Moneybookers or whatever ThirdParty Payment Processor seems able to provide the above required security. (If they fail and someone discloses user data from their machines its their fault, you can blaim them and users can charge them. If you fail you probably will have to retire from your current way of living, and spend your life paying back the damaged users charges etc.) On the other Hand if you never said NO above you might easily use the credit card acceptance that comes preinstalled with the shop, but remember to protect the users credit card data as needed. The module itself works fine and without any knwon bugs. The only problem that you face and have to be aware of is the security of the data against unwanted dirsclosure (wich covers all cases where it is not you who sees that data). regards Ralf (btw. I am on the german forum too *grin*)
  5. see here http://www.oscommerce.com/community/contributions,403 have a nice day regards ralf
  6. Just posted an update with a minor bug fix. regards ralf
  7. Hi everyone, I just posted a contribution that allows to have separate countries_names per language. countries_names Does anyone who is good at spanish does have the time and will to translate the countries names into spanish as I unfortunately don't speak nor even understand spanish :-) Comments regarding if such contribution is usefull or not and what I might have missed out or how to improve it are highly appreciated as well. regards ralf
  8. go to your admin area and under cache control delete the cached version of the categories :-) on the other hand it seems that you include the classic categories parallel to cool_menu. (feel free to post SOME code to be examinded) regards ralf
  9. right Chris, you already posted a solution. Please allow me to offer another on (which by the way forces no extra database queries) ;-) regards ralf Have a nice day! All decision is left to your taste
  10. <title><?php echo STORE_NAME . ' - ' . $breadcrumb->currentTitle(); ?></title> and do not forget to insert these lines function currentTitle() { $tmp = end($this->_trail); return $tmp['title']; } before the closing curly brace of the class breadcrumb in includes/classes/breadcrumb.php under you catalog directory. I am sorry but I can only attempt to guess where the solution for you is as you are not specific enough to let me know what goes wrong or in another way. regards ralf
  11. what does your shop send to the client browser as <title> in the documents head section? Do you get an error emssage and if what kind of? what does it say? Wich version of osCommerce are you using?
  12. you are getting the erro because you did not "require" nor "include" DIR_WS_FUNCTIONS . 'html_output.php' as this is the file in wich the function tep_href_link() is defined. compare the contents of your file 'redirect_login_to.php' with for example to 'application_top.php'. As you'll see you need to include or require the file that contains a function (so it gets to life so to say) before you could use that function. regards ralf btw. working with snapshots is not recommended for live servers :-)
  13. not really to say it would not matter what to use, the protocol for Http says that if a parameter list is passed to a document it has to start the list with a '?' Alle name value pairs in this parameter list have to be assigned with the the symbol '=' and the symbol '&' has to be used to separate all entries from each other. So that gives http://server.domain.tld/uri.php?param=value and http://server.domain.tld/uri.php?param=val...e&param1=value1 etc. If the parameter list is not started with a '?' then the webserver looks for a document named alike uri.php&param which he won't be able to find, so the server should return a "302 document not found" or a prepared error document (set by rules in httpd.conf or .htacces) or produced by a errorhandler (also set by rules in httpd.conf or .htacces). I don't know and can not imagine what causes your loop. I will think about it. Maybe you'll find a hint on what s really going on if it loop. Do you have a shell access to your server? try tail -f /var/log/httpd/access.log or use the path where you know that your logs are stored to see wich document is being requested actually. (you can exit that command and the output and return to the shell wit CTRL+C.) If that doesn't work insert a die() before the output for the javascript redirection as <?php } else { ?> <script language="JavaScript"> <!-- window.location.href = document.URL + ((document.URL.match(/[?]/))? '&' : '?') + 'javascript=on'; //--> </script> <?php } ?> to see if its really the javascript test that fails. If it dies then so please start debugging. Let php echo the values for javascript and even the ones for 'blah'. A full list you get (not always needed but helpfull with this) /* // debugging help foreach (array_keys($HTTP_POST_VARS) as $tmp_str) { echo "keys: " . $tmp_str . ' : value ->' . $HTTP_POST_VARS[$tmp_str] . '<br />' . "n"; if (is_array($HTTP_POST_VARS[$tmp_str])) { foreach ($HTTP_POST_VARS[$tmp_str] as $tmp_tmp_str) { echo ' : value ->' . $tmp_tmp_str . '<br />' . "n"; } } } */ Do the same accordingly for HTTP_GET_VARS and you can see what the server gets and how it modified what it got or if it didn't at all. I am sorry to have no solution by now for this. I will look into it in the evening. regards Ralf (GMT +01 ;-))
  14. another change :-) That should do it :-) //////////////////////////////////////////////// // rb 20030803 13:00 JAVASCRIPT DETECTION if (!tep_session_is_registered('javascript')) { tep_session_register('javascript'); } if (isset($HTTP_GET_VARS['javascript']) || isset($HTTP_POST_VARS['javascript'])) { $javascript = ((isset($HTTP_GET_VARS['javascript']) == 'on') || ( isset($HTTP_POST_VARS['javascript']) == 'on'))? 'on' : 'off'; unset($HTTP_GET_VARS['javascript']); unset($HTTP_POST_VARS['javascript']); $parameters = array('javascript', 'pid', 'ref'); tep_redirect(tep_href_link(substr($PHP_SELF,1), tep_get_all_get_params($parameters))); } // END JAVASCRIPT DETECTION //////////////////////////////////////////////// The reason is that $PHP_SELF always returns the DOCUMENT_URI, so the document and path relative to the WEBSERVER_ROOT_DIR, and not important here but to be complete the tep_get_all_get_params() returns also the get parameters given to the document except those namely listed in the array $parameters. With the substr() we get rid of the always present preceeding slash from $PHP_SELF and with tep_get_all_get_params() we rebuilt the full REQUEST_PATH except for 'javascript' and 'ref' or whatever you don't want to show up. (sometimes I change code before reading the comments, sometimes code doesn't even have comments, sometimes I rechange code after I read the code others wrote :-) Enjoy :-) regards ralf
  15. Ok, I admit, I am no JavaScript Guru (but hey still willing to learn, dunno why Netscape croaks on that but who cares, here s another way to do it). I moved my little code modification a bit down in application_top in order of being able to use 'general.php' and 'html_output.php' // include the language translations require(DIR_WS_LANGUAGES . $language . '.php'); // define our general functions used application-wide require(DIR_WS_FUNCTIONS . 'general.php'); require(DIR_WS_FUNCTIONS . 'html_output.php'); //////////////////////////////////////////////// // rb 20030803 13:00 JAVASCRIPT DETECTION if (!tep_session_is_registered('javascript')) { tep_session_register('javascript'); } if (isset($HTTP_GET_VARS['javascript']) || isset($HTTP_POST_VARS['javascript'])) { $javascript = ((isset($HTTP_GET_VARS['javascript']) == 'on') || ( isset($HTTP_POST_VARS['javascript']) == 'on'))? 'on' : 'off'; unset($HTTP_GET_VARS['javascript']); unset($HTTP_POST_VARS['javascript']); $parameters = array('action', 'cPath', 'products_id', 'pid'); tep_redirect(tep_href_link($PHP_SELF, tep_get_all_get_params($parameters))); } // END JAVASCRIPT DETECTION //////////////////////////////////////////////// // currency and the javascript will still use the get method and not post a form. <link rel="stylesheet" type="text/css" href="/styles/common.css" /> <?php if ($javascript == 'on') { ?> <?php } else { ?> <script language="JavaScript"> <!-- window.location.href = document.URL + ((document.URL.match(/[?]/))? '&' : '?') + 'javascript=on'; //--> </script> <?php } ?> </head> <body> I personally would like to see the solution with the form to work as well but that might take a while and is not urgent now, but as I see it it can be used to allow users later on to enable or disable javascript use in their "preferences" on a website, so they might have javascrpt enabled in their browsers but don't want the site to use it or to use use it, but at least they'd have a choice :-) Isn't that what we are here fore? Having choices and making our own decisions?*grin* regards Ralf let me know if get into any problems with the code, I'll help as soon as I can