Jump to content

Muldrick

Members
  • Content count

    131
  • Joined

  • Last visited

Everything posted by Muldrick

  1. Muldrick

    USPS 1-click shipping

    I remember seeing a contribution for adding a "1-click" shipping. When in admin, one could print and pay for USPS shipping through the site. (on the admin side) I'm looking for it now but can't find it anywhere. Was I dreaming? Please help me find it.
  2. I can change the order status to Preparing, Pending, processing, delivered etc. Is there a way to add "shipped" to that list?
  3. Muldrick

    authorize.net problems

    In your (admin) settings on OSC,...Username: be sure to use the username asigned to you by auth.net. (Not your log in name)
  4. Muldrick

    Help with Flash Contrib

    Multimixer, thanks, I'll do that. Sam, thanks for such a productive response! (I bet 90% of your posts are like this)
  5. I'm not sure who's contrib this is, but I'd like to add a stop and play option? Here's the original code, can someone help please? Open index.php in catalog/includes/languages/english/index.php In catalog/includes/languages/english/index.php I added: define('TEXT_MAIN', ' <table width="0%" border="0" cellspacing="0" cellpadding="0" align="right" style="margin-left:10px; margin-bottom:10px"> <tr> <td> <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="350" height="300"> <param name="movie" value="images/yourflash.swf" /> <param name="quality" value="high" /> <embed src="images/yourflash.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="350" height="300"></embed> </object> </td> </tr> </table> -------------------------------------------------------------------------------------------------
  6. Muldrick

    Help with Flash Contrib

    Or at least have the flash play once, not repeat.
  7. Muldrick

    authorize.net problems

    Help pleeeze. (real green at this) I have OSC v2.2 RC2a, installed this last July. I tried the included Auth.net SIM and get this error message when I confirm my order. (My site never even asks for CC info): (123) This account has not been given the permission(s) required for this request. I then used Harald Ponce de Leon contribution and changed these files: includes/languages/english/modules/payment/authorizenet_sim.php includes/modules/payment/authorizenet_sim.php I uninstalled the module and reinstalled it. I still get the same error. I have everything set to live. I've tested a transaction at auth.net (Virtual Terminal) and it works.
  8. Muldrick

    Tried the USPS shipping update, but...

    Someone should be able to help me with this? Pleeeze?
  9. I was working on the USPS update (USPSMethods_2.8d) 1. I disabled my USPS shipping. (I already have an account) 2. I replaced the catalog/includes/modules/shipping/usps.php with the file included in the contribution. 3. I replaced the catalog/includes/languages/english/modules/shipping/usps.php with the file included in the contribution. 4. I replaced the admin/modules.php with the file included in the contribution. 5. I replace admin/includes/functions/general.php with the file included in the contribution. And that should have done it. (right?) Now when I try to log into my admin (to enable the USPS shipping) it won't let me in:( Comes up with: Fatal error: Unknown function: tep_admin_check_login() in public_html/admin/includes/application_top.php on line 215 My line 215 says: // Set the local configuration parameters - mainly for developers if (file_exists('includes/local/configure.php')) include('includes/local/configure.php'); Help?
  10. Muldrick

    Tried the USPS shipping update, but...

    OK, I started all over. I put my original files back and was able to get back into my admin. The problem only starts when I try step 6 in the instructions, which says: STEP 6 ------ Replace admin/includes/functions/general.php with the file included in this contribution. Do this even if you have used versions of USPS Methods. ** OR ** ******************************************************************************** *********** IF YOU HAVE AN ALREADY MODIFIED FILE YOU WILL NEED TO DO THIS INSTEAD OF USING THE DROP IN: ******************************************************************************** *********** ***************************************** Find This code somewhere around line 767: ***************************************** //// // Alias function for module configuration keys function tep_mod_select_option($select_array, $key_name, $key_value) { reset($select_array); while (list($key, $value) = each($select_array)) { if (is_int($key)) $key = $value; $string .= '<br><input type="radio" name="configuration[' . $key_name . ']" value="' . $key . '"'; if ($key_value == $key) $string .= ' CHECKED'; $string .= '> ' . $value; } return $string; } *********************************************** INSERT THE FOLLOWING CODE AFTER THE ABOVE LINE: *********************************************** // USPS Methods 2.5 // Alias function for Store configuration values in the Administration Tool function tep_cfg_select_multioption($select_array, $key_value, $key = '') { for ($i=0; $i<sizeof($select_array); $i++) { $name = (($key) ? 'configuration[' . $key . '][]' : 'configuration_value'); $string .= '<br><input type="checkbox" name="' . $name . '" value="' . $select_array[$i] . '"'; $key_values = explode( ", ", $key_value); if ( in_array($select_array[$i], $key_values) ) $string .= ' CHECKED'; $string .= '> ' . $select_array[$i]; } $string .= '<input type="hidden" name="' . $name . '" value="--none--">'; return $string; } ------------------------------------------------------------------------------------------------------------------------------------------------ I have an already modified general.php file, so I added the code like it says to do. When I go try to login to my admin it says: Parse error: parse error, unexpected $ in public_html/admin/includes/functions/general.php on line 1497 Well, line 1497 is the last line in the code. It only shows ?> Why would that be an error?
×