Jump to content

AlanQ

Members
  • Content count

    39
  • Joined

  • Last visited

Everything posted by AlanQ

  1. By using Search, I've found one other post about this, and they got no reply. Hopefully I'll be more lucky :) Several posts recommend doing all weights in grams instead of kilograms. So that is what I did -- it saves having any decimal values. I've now added some products that are 20kg each = 20000g However, when I look back at the product in admin, the weight is shown as 9999.99 Also, for these items, the shipping module doesn't get the pricing right. Is there a way to increase the upper limit? Or should I completely re-do my catalog in kg? :( Thanks Alan
  2. I'm using the PayPal_IPN module and CCGV(trad). (posting here cos not sure if it's a PayPal_IPN specific 'bug' or more generic) If the Total to pay is zero (which can happen if the customer has used a voucher and 'Include Shipping' is set to true) the customer is still re-directed to PayPal where they find the error message: "Please provide an amount and click Update Totals." Is this a 'bug' or is there perhaps a good reason for not checking to see if total=0.00 ? (I'm not being sarcastic, there may be a good reason :) ) Does anyone have a solution for this? Thanks Alan
  3. AlanQ

    [CONTRIBUTION] CCGV (trad)

    Thank you, Rhea. Having just looked at the details for IPN, I see that 2.2 isn't an essential update/bugfix to 1.4, but rather the 2.x branch is a rewrite, with the 1.x branch still active/supported. Must learn not to panic... :) Cheers Alan
  4. AlanQ

    [CONTRIBUTION] CCGV (trad)

    Hi Rhea, and others I have osC 2.2 and PayPal IPN 2.2. I need vouchers/coupons. Can anyone suggest the best solution: 1. Uninstall IPN2.2, install IPN1.4, then install CCGV(trad) (viz CCGV(trad)_1_2_3_4_5_6_7_8_9_10_11.zip) 2. Use a payment gateway other than PayPal. But if so, which? 3. ...I can't even think of a sensible 3... :( Yours in desperation Alan
  5. AlanQ

    Official PayPal IPN Support Thread

    Big thank you to Terra and AlexStudio for all your help trying to resolve my problem: Turned out to be my fault entirely: Whilst testing, I had my site password protected. And, of course, PayPal's servers can't get passed a password challenge any more than an ordinary user can. :blush: Works just fine now. Cheers Alan
  6. AlanQ

    Official PayPal IPN Support Thread

    Further to my problem of getting this module working on 1&1 shared servers (http://forums.oscommerce.com/index.php?act=findpost&pid=1028257) I've just found this post at http://www.zen-cart.com/forum/archive/index.php/t-55802.html Could this be relevant? Thanks Alan
  7. AlanQ

    Official PayPal IPN Support Thread

    Hi Dr Weird I have the same problem. Terra and AlexStudio have been making various suggestions, but so far nothing has worked. Perhaps one of their ideas will work for you. My first post on this is (click on the back facing arrow)Like you I'm not using SSL. My host is 1&1 in the UK. If ya solve it, please post back your solution. Good Luck Al
  8. AlanQ

    Official PayPal IPN Support Thread

    Sorry, everyone, for multiple posts -- completely unintentional.
  9. AlanQ

    Official PayPal IPN Support Thread

    Hi Alex I tried hardcoding the notify_url. The result is exactly the same -- no worse, but no better -- the status never changes from 'Preparing [PayPal IPN]'. ipn.php and all of the path is lower case.
  10. AlanQ

    Official PayPal IPN Support Thread

    Hi Alex I tried hardcoding the notify_url. The result is exactly the same -- no worse, but no better -- the status never changes from 'Preparing [PayPal IPN]'. ipn.php and all of the path is lower case.
  11. AlanQ

    Official PayPal IPN Support Thread

    Hi Alex I tried hardcoding the notify_url. The result is exactly the same -- no worse, but no better -- the status never changes from 'Preparing [PayPal IPN]'. ipn.php and all of the path is lower case.
  12. AlanQ

    Official PayPal IPN Support Thread

    Hi Terra Under the code snippet in html_output.php I added a line to echo the value of $link. The output is numerous, but every one is the root address of my web site starting http:// (no 's'). So that idea checks out... Any other thoughts...? :)
  13. AlanQ

    Official PayPal IPN Support Thread

    It certainly looks that way.I checked the permissions: ipn.php is 644 and all directories above are 755. Given also that cURL is enabled, it's puzzling. I'm still concerned about the following: $parameters['notify_url'] = tep_href_link('ext/modules/payment/paypal_ipn/ipn.php', '', 'SSL', false, false); $parameters['return'] = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL'); $parameters['cancel_return'] = tep_href_link(FILENAME_CHECKOUT_PAYMENT, '', 'SSL'); All those references to SSL, when I don't have SSL enabled. Especially the 'return'.
  14. AlanQ

    Official PayPal IPN Support Thread

    My original post: Last two replies: Dear Terra and Alex Sorry to go quiet for so long -- I wasn't being intentionally rude and ignoring your replies, I was being chased by the tax man -- all OK now though :) My parameters lines in paypal_ipn.php are: $parameters['notify_url'] = tep_href_link('ext/modules/payment/paypal_ipn/ipn.php', '', 'SSL', false, false); $parameters['return'] = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL'); $parameters['cancel_return'] = tep_href_link(FILENAME_CHECKOUT_PAYMENT, '', 'SSL'); Should the SSL entries be there as I'm not using SSL? In include/configure.php I have define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? Which looks OK...? Looks like that's confirmed: I added a mail(...) at the top of ipn.php, but received no email after placing an order. from phpinfo(): PHP Version 4.4.4 Configure Command: ...'--with-curl'... curl CURL support enabled CURL Information libcurl/7.10.3 OpenSSL/0.9.6g ipv6 zlib/1.2.1 Environment SERVER_PORT 80 No mention of port 443. If I try to reach my page that has the phpinfo() script in it via https, I get an 'unable to connect' error. Thanks again Alan
  15. AlanQ

    Official PayPal IPN Support Thread

    Thanks, Alex, but I think we're at crossed-purposes here.I am using 1&1 but I'm not using SSL, yet. I'll come back to your post when I do decide to enable SSL and hopefully you will have dug me out of the hole before I fall in it :) Cheers Al
  16. AlanQ

    Official PayPal IPN Support Thread

    Hi Terra Thank you for replying so fast. > * Check that the ipn.php is correctly uploaded into the new /ext/ directory Path is /<html root>/ext/modules/payment/paypal_ipn/ipn.php > * Check that "register globals" is enabled for the /ext/ directory. To do this try typing the full pathway into your browser: A completely blank page is returned; no error message. But, an email was sent to my 'Debug E-Mail Address' Title: PayPal IPN Invalid Process Body: $_POST: $_GET: > * If you are hosted with GoDaddy, please implement the GoDaddy fix included in the user guide I'm hosted by 1&1 -- I've read about problems with osCommerce SSL and 1&1 so, at least for now, I've avoided enabling SSL. > If you can advise what you've already tested would be great so we can rule out the usual suspects & find out what's going on. I've tried what I think are the three main tests: 1) Place an order as far as being re-directed to PayPal, then drop the browser. 2) Place an order, make the payment at PayPal, but don't return using the 'Complete your Order Confirmation' link. 3) Place an order, pay at PayPal and finally click 'Complete your Order Confirmation'. They each result in the same 'Preparing [PayPal IPN]' status. > all the best Same to you. Regards -- Alan
  17. AlanQ

    Official PayPal IPN Support Thread

    Pre-ramble: First of all, as several others have said, thanks for a great time-saving module. In fact, thanks for osCommerce, I couldn't have afforded to run my small shop without it. I have read osC_PayPal_IPN_install_guide_READ_ME.html and followed the instructions (I think). There are some bits that I know I don't quite understand. I have also tried searching but I'm not quite sure what to search for, and there seems to be no way to search within a thread (111 pages of posts is a lot to read). My problem: I've got it installed and it almost works. When I make a test purchase, the pre-mature order status is set to 'Preparing [PayPal IPN]'. But, when I complete payment at PayPal, the status does not change , and it is still the same when I click 'Complete your Order Confirmation' (used to be 'Return to merchant') and return to my web site. I have noticed that the 'Complete your Order Confirmation' link is http://www...com/checkout_process.php (I end up at checkout_success.php which looks right from my point of view as a 'customer') But, shouldn't the link be ipn.php ? If so, how do I change it? My module settings are: Enable PayPal IPN Module: TRUE Gateway Server: LIVE E-Mail Address: <The one I've always used with PayPal> Sort order of display: 0 Transaction Currency: Selected Currency Payment Zone: --none-- Force shipping address? TRUE Set Preparing Order Status: Preparing [PayPal IPN] Set PayPal Acknowledged Order Status: default Set PayPal Completed Order Status: default Transaction Type: Aggregate Move tax to total amount: True Page Style Debug E-Mail Address Enable Encrypted Web Payments: False Any help much appreciated. Thanks Alan
  18. AlanQ

    Weight only goes up to 9999.99

    kgt you're brilliant! You've solved my problem simply by asking questions and being my sounding board. Your question sent me off to compile all the info you might need to help me. And by doing that, I found the problem :) In Configuration > Shipping/Packaging I had the 'Maximum Package Weight you will ship' set to 20000. So osC was simply doing exactly what it had been told to do. I, so far, haven't managed to re-create this bit Which is a good sign but still intriguing. Maybe I was just tired. Cheers Al
  19. AlanQ

    Weight only goes up to 9999.99

    Thanks kgt That at least keeps the weights as I set them. But now I've got a further problem which may be related. If I can impose upon you a bit further... For small weights the shipping module calculates shipping prices correctly. But for bigger items (around 10kg, ie weight=10000) it gets it wrong: For one big item it's OK. But for two, instead of adding the weights and then calculating the price, it calculates the price for one and then doubles it. If I combine one big item and some small items, it then comes up with a figure that isn't even in the table! Any ideas? Thanks again Al
  20. Has anyone done this (or part of it) already? Or would the result of me doing it be useful to others? My shop is in the UK. I'm planning to use Royal Mail delivery. They divide the world into four zones: 'UK', 'Europe', 'World Zone 1' and 'World Zone 2'. They define each zone with a list of countries except for 'World Zone 1' for which they say: "World Zone 1 covers all countries not listed in either Europe or World Zone 2." [Just about everything in the UK is as useful as this :D] So, to set up my four shipping zones I need to: 1) Get a list of countries as used by osCommerce did this by copying from the country list on the create account page. 2) Get a list of the ISO two letter country codes http://www.iso.org/iso/en/prods-services/i...ding_table.html 3) Re-sort the iso codes alphabetically by country name 4) Match one list against the other 5) Remove UK (GB) and then manually sort the list into a Europe list and a Zone 2 list 6) Assume everything else is the Zone 1 list 7) Copy and paste the 2 character codes into the appropriate fields on the zone shipping admin page (hoping that no list is longer than 255 characters) 8) Start again from step 5 when I decide to use another carrier! Someone please tell me that someone else has already done this :( Cheers Al
×