Jump to content

lanesharon

Members
  • Content count

    51
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Sharon Lane
  1. lanesharon

    Graphs folder for Banner Manager

    I am getting this error on Banner Manager v1.3: Error: Graphs directory does not exist. Please create a 'graphs' directory inside 'images'. Both Graph Directories are set to CHMOD 777 and all files inside are also set to 777, but that error shows up on everything. I looked in the code and saw a possible problem in the if/else statements. Can someone tell me if they have a solution. Thanks and take care, Sharon
  2. Install PayPal IPN. It does update everything, as long as the customer pushes the PAY button while in the PayPal site processing the order. Take Care, Sharon
  3. I know where it has to be changed. I just don't know how to do the php coding. Another status level has to be added to the order_status table. Maybe a 4 order_status_id for PayPal Complete. Then in paypal_notifiy.php, around this area of paypal_notify.php change the status to the number 4 in the table_orders. $sql_data_array = array('orders_status' => MODULE_PAYMENT_PAYPALIPN_ORDER_STATUS_ID); tep_db_perform(TABLE_ORDERS,$sql_data_array,'update','orders_id='.$item_number); $customer_notification = (SEND_EMAILS == 'true') ? '1' : '0'; $sql_data_array = array('orders_id' => $item_number, 'orders_status_id' => MODULE_PAYMENT_PAYPALIPN_ORDER_STATUS_ID, 'date_added' => 'now()', 'customer_notified' => $customer_notification); tep_db_perform(TABLE_ORDERS_STATUS_HISTORY, $sql_data_array); I am just not a php programmer. Old RPG, COBOL, Assembler, and APL. That oughta tell my age. I will forward this on to the last person who modified the contribution. Maybe they will add it. Take Care, Sharon
  4. I have answered one of my questions through a little trial. I removed the normal PayPal module and ordered a product followed it through to PayPal IPN and clicked the Pay button. It went through my store fine, updated quantities, etc.. Now for my second question. I have tried, process, paypal processing, and pending. The paid orders always show whatever it is that I set it to in ADMIN. They never change the status. The only ones left are default and delivered. Duh, guess what I will try next. Well I tried it, but it switched it from default to Processing. I am going to look into the coding further. Take Care, Sharon
  5. I have it up and running and yes it is working fine, depletes qty, etc. My question is do I have to have both IPN and PayPal running or can I just use IPN? And what should I set the Order Status to in the ADMIN payment module to get this to reset when PayPal has finished their part. And what, pray tell, will it reset to. I don't see one in there that says PayPal completed. For those of you that are having trouble, make sure that your email address for PayPal in ADMIN is set to one of your 4 allowable email addresses in your PayPal account. And make sure that PayPal has activated your IPN for them. Thanks and take care, Sharon
  6. lanesharon

    All Products = Spider Food

    I am really new to this whole process, but I have modified the AllProds module for two additional items. I added a text description and for Apache servers, I have redirected 404 errors to that page through my .htaccess page. It really helps very nicely for accessing missing pages. I think that if someone is trying to access a discontinued item that they may have accessed through a search engine, if I redirect them to the AllProds page, then hopefully they will see a substitute item. You can see it work here (site is still in test mode, not live): http://www.uptowngoodies.com/catalog/allprods.php Now type in anything like: http://www.uptowngoodies.com/catalog/anything.php You get redirected to the AllProds page and it contains a description that makes that redirect a little more understandable. If you do not have an Apache server, but know how to code a 404 redirect page, you may want to consider the AllProds page for that redirect. I have no idea how to make a contribution and really don't have the time right now to learn, but if you are one of those who knows how and you would like to add these mods to the package, I will be more than happy to send the files to you. Thanks and take care, Sharon
  7. lanesharon

    [contribution] "osC_GiftWrap_v1.0"

    Super, that was the problem! It wasn't written in the instructions or I was just too tired to see it. I can send you the folders/files in the order they need to be for OSC 2.2 MS2, because I reordered the original for use on any other stores I may want. If you don't mind me making a suggestion, just rewrite the instructions to have the install instructions all at the end (include that order total activate instruction). And writeup changes for ONLY those lines that have to be added or changed. You can reference the full module, but change the minimum needed. That will keep others out of trouble. Then, you should be good to go for OSC2.2 MS2! Thanks for the heads up on the order total. Take Care, Sharon
  8. lanesharon

    [contribution] "osC_GiftWrap_v1.0"

    Okay, I installed the gift wrap module on OSC2.2 MS2. I had a few little blips along the way. The way the package is publshed, the directories are incorrect. The modules folder (directory) in the catalog side was listed directly under languages. It should be under English, or whatever language you are adapting it to. I had to be extremely careful how I added the changes to each php file. OSC2 must be different than 1, or maybe modifications I have made have made mine different. In any event, I could not wholesale cut and paste the large segments of code that are suggested in the directions. I had to, instead, look at old code vs. changes needed and just add the minimum that I needed. Doing those things, it runs ok on OSC2 MS2. I do need some help, however. On the confirmation page, the gift wrap fee is not listed in as an item in the Billing Information totals. Either I have something wrong, or this was never added. If it was not added, I believe it should be because the totals are confusing. Can you tell me how to get this to dispaly as an item, along with all the other item totals? Thanks and take care, Sharon
  9. Just wanted to add one statement to my other questions. The writeup under this contribution says: Receive payments using PayPal IPN (Instant Payment Notification). That is what made me assume that I SHOULD NOT install the normal PayPal module along with this module. The statement made the contribution sound as if everything was in it to 'receive payments'. Please correct me if I am wrong and if you know. Take Care, Sharon
  10. First I want to ask if there is anyone answering the questions on this forum? I see a lot of questions (including my own), but no answers posted. I have IPN installed on my site and I am at the testing stages. I have placed order through IPN and followed them through all the way through PayPal and back into the starting website (mine). Everything looked good, and the payment did process properly on both accounts (mine and the buyers). I have three problems. The order still says PayPal Processing. I have nothing in my PayPal IPN transactions. My item quantities have not changed. The item qty should be decreased by the amount ordered. I have made some assumptions in doing the IPN install, since I could not find any answers on this forum or from the contributor: I only need PayPal IPN to process orders through PayPal. I DO NOT need the normal PayPal module installed. The Notify URL is set to mysite/catalog/paypal_notify.php And use cURL is set to TRUE Test Mode is set to FALSE Set Order Status is set to PAYPAL PROCESSING Now, if there is anyone on this forum answering questions, I will be most happy to find the answers to my problems. If I do not receive a reply on the forum, then I have to assume that this contribution is not valid and start searching for an alternative. And maybe this forum needs to be removed so that people are not left with the false impression that they can find answers to their questions here. Take Care, Sharon
  11. lanesharon

    [contribution] "osC_GiftWrap_v1.0"

    Has anyone tried this module with OSC 2 M2.2? I could use it if it works well to give the customer the option of an additional gift wrap charge. Would be even better if I could have varied ones based on box. I have tax only for CA order, so I am hoping that will not cause any problems. Do you think it would be doable? Thanks and take care, Sharon
  12. I use the search engine at SiteLevel.com for my Rare and Pediatric Cancer websites. I think it is excellent. Takes time away from my having to answer questions, and makes the users happy too. Great indexing routines, schedules, inclusions, exclusions, etc.. Good website engine. Take Care, Sharon
  13. lanesharon

    Banner Manager v1.3 error

    Thanks so much Rumble. Works like a charm! You have been a very important part of my getting this store up and running. I notice while searching for answers, that most of my them are found in posts by you. And the answers were given without sarcasm or condescension. You are a great asset to these forums for newbies like me. Thanks, Sharon
  14. The search engine on this site is not conclusive. I can tell you that is why I can not find much of the information. I do not know how the indexing for the search engine is done, but it is not thorough. I will put in a search term (word or words) and not get any results. Then I retry using various combinations, still no results. Yet when I am looking through the posts, I will see that same term or terms used in many of the posts. So, why doesn't it show up on a search? If it did, you might not be getting so many recurrent questions. I TRY to use the forum search to find the answers before I ask, but if the search engine is not thorough, it is NOT my fault that I have to re-ask a recurrent question. God knows, I hate to ask stupid questions, but I am a real newbie and need answers. I would much rather be able to quietly search through the archives and find the answer. If you have a solution to the search engine problem, I am sure that will help us greenies. But please don't blame us if the search engine on this website is not what it should be. Take Care, Sharon
  15. I have installed this contribution. It works okay on the catalog side, but in ADMIN I can't get into the banner module. I have tried emailing the contributor directly, but the email address is not valid. I am hoping someone here can help. The error in the ADMIN panel is: Fatal error: Call to undefined function: tep_array_merge() in /home/me/public_html/catalog/admin/banner_manager.php on line 396 That area of banner_manager.php looks like this: if ( (is_object($bInfo)) && ($banners['banners_id'] == $bInfo->banners_id) ) { echo ' <tr class="dataTableRowSelected" onfiltered="this.style.cursor='hand'">' . "n"; $onclick_link = 'page=' . $HTTP_GET_VARS['page'] . '&bID=' . $bInfo->banners_id; } else { echo ' <tr class="dataTableRow" onfiltered="this.className='dataTableRowOver';this.style.cursor='hand'" onfiltered="this.className='dataTableRow'">' . "n"; $onclick_link = 'page=' . $HTTP_GET_VARS['page'] . '&bID=' . $banners['banners_id']; } ?> <td class="dataTableContent" onfiltered="document.location.href='<?php echo tep_href_link(FILENAME_BANNER_STATISTICS, $onclick_link); ?>'"><?php echo '<a href="_java script:popupImageWindow('' . FILENAME_POPUP_IMAGE . '?banner=' . $banners['banners_id'] . '')">' . tep_image(DIR_WS_IMAGES . 'icon_popup.gif', 'View Banner') . '</a> ' . $banners['banners_title']; ?></td> <td class="dataTableContent" align="right" onfiltered="document.location.href='<?php echo tep_href_link(FILENAME_BANNER_STATISTICS, $onclick_link); ?>'"><?php echo $banners['banners_group']; ?></td> <td class="dataTableContent" align="right" onfiltered="document.location.href='<?php echo tep_href_link(FILENAME_BANNER_STATISTICS, $onclick_link); ?>'"><?php echo $banners_shown . ' / ' . $banners_clicked; ?></td> <td class="dataTableContent" align="right"> <?php if ($banners['status'] == '1') { echo tep_image(DIR_WS_IMAGES . 'icon_status_green.gif', 'Active', 10, 10) . ' <a href="' . tep_href_link(FILENAME_BANNER_MANAGER, 'page=' . $HTTP_GET_VARS['page'] . '&bID=' . $banners['banners_id'] . '&action=setflag&flag=0') . '">' . tep_image(DIR_WS_IMAGES . 'icon_status_red_light.gif', 'Set Inactive', 10, 10) . '</a>'; } else { echo '<a href="' . tep_href_link(FILENAME_BANNER_MANAGER, 'page=' . $HTTP_GET_VARS['page'] . '&bID=' . $banners['banners_id'] . '&action=setflag&flag=1') . '">' . tep_image(DIR_WS_IMAGES . 'icon_status_green_light.gif', 'Set Active', 10, 10) . '</a> ' . tep_image(DIR_WS_IMAGES . 'icon_status_red.gif', 'Inactive', 10, 10); } ?></td> <td class="dataTableContent" align="right"><?php echo '<a href="' . tep_href_link(FILENAME_BANNER_STATISTICS, 'page=' . $HTTP_GET_VARS['page'] . '&bID=' . $banners['banners_id']) . '">' . tep_image(DIR_WS_ICONS . 'statistics.gif', ICON_STATISTICS) . '</a> '; if ( (is_object($bInfo)) && ($banners['banners_id'] == $bInfo->banners_id) ) { echo tep_image(DIR_WS_IMAGES . 'icon_arrow_right.gif', ''); } else { echo '<a href="' . tep_href_link(FILENAME_BANNER_MANAGER, 'page=' . $HTTP_GET_VARS['page'] . '&bID=' . $banners['banners_id']) . '">' . tep_image(DIR_WS_IMAGES . 'icon_info.gif', IMAGE_ICON_INFO) . '</a>'; } ?> </td> </tr> Can you see where the problem is and help me? Thanks, Sharon
×