Latest News: (loading..)

reasonable

Members
  • Content count

    47
  • Joined

  • Last visited

1 Follower

About reasonable

  • Birthday 07/22/1958

Profile Information

  1. JAson, Just a thought but take a look in your easypopulate.php file where it lists your temp directory. Did you put it in as /catalog/temp? if so change it to /temp. In your post I see it giving a double path for the temp directory. HTH, Ron
  2. Mibble, Yep that's the problem. If you set attributes to true it quits downloading. Turn it off and it works again. But can't get any of the folks that know what's what to answer. Regards,
  3. Brett, Been trying to get an answer to that for several months. Maybe we will this time. Regards,
  4. If i get rid of the 0 for a product attribute it isn't deleting it ? Has any one else had this problem? Sorry can't help with this part of the question. also when I try to save the file in excel 2003 i get the following error file may contain features that are not compatible with text (tab deliminated). do you want to keep the work book in this format. This is a warning and has nothing to do with the other. You cannot save a multiple page or specially formatted workbook as a tab delimited file. No products_model field in record. This line was not imported Look at the last line of your input file. There is nothing there thus the line not imported message. As long as this message does not appear above the last line there should not be a problem.
  5. Copy the files as per the documentation included in the zip file. Then you can either use the sample output file provided or do an export from EP. I've found the best way to accomplish this is to use an editor that shows line numbers and open the files that need to be modified in it with the instructions open in notepad or another editor.... Then simply cut and paste where the changes go. I'm not a programmer and know nothing about PHP but manage to get most of the contribs to work.
  6. roku, if you're running MS2 then the file should be in your catalog/includes folder. if not then you need to get one of the older versions that works with MS1.
  7. I haven't installed either of those contribs but my guess would be that there is a sql statement to either add or alter a table that you didn't execute... Go through the install instructions again very carefully and see if there is not an instruction to either cut and paste or a .sql file in the contrib to upload. HTH
  8. Well I'm no expert but my first feeling is that you made changes to the files in the /catalog folder and not the /catalog/admin folder. HTH
  9. Okay here we go again with the non-programmer questions. I do not understand php so I am not sure my assumptions are correct here (I'm sure someone will tell me if I'm wrong) but I am trying to understand this. 1. I see only three files that are called in this script and they are standard includes of application_top, database_tables, and application_bottom and do not include categories or any other admin or catalog files. 2. All the logic appears to be file layout and sql functions. Since I cannot download a file that contains attributes would it make sense that there is a problem reading from the database? As I said earlier I can download a full file if I turn the attribs off. Is it possible to set the timeout beyond the 330 in the file even though I am doubtful that it would help? Does anyone know how to modify EP so that it can be run from the command line using the cgi version of php? I managed to figure out how to get past my initial problem with that but then started getting parse errors that go beyond what would seem logical to comment the lines out to avoid (i.e. commenting out the version seems more logical than commenting out the file includes). Thanks,
  10. There is a setting in the easypopulate.php file to change the file to csv instead of tab delimited. Uncomment the csv setting and comment the tab. Problem being is that every comma is going to be interpreted as a new field. It would be much simpler to remove the commas from the categorie names in the original file. At least from my view point as a non-programmer and only mid-level user.
  11. Well I can't help with coding but this would sure make my life easier. A single package to take care of multiple functions? Oh yeah.
  12. Well I added it to the first line of the script right after the <?php and it got rid of the register global errors. But it started a whole list of parse errors. I commented out the first one which was the version number line and then it made it to the temp dir path line. So I figure it's back to the php book to figure it out unless someone else picks up on this and can help with either the command line options or the script itself. Regards
  13. Looked at this since I can't export the files. Log in from your shell account and type in php -v this will tell you if php has cgi support. I couldn't run EP from the command line since it tells me the register globals is turned off. That's an issue I need to address with my host. To test it php -a /path/easypopulate.php runs the script. Don't forget the -a as it tells it to run in interactive mode. And since I know nothing about php itself check at www.php.net for the full command line syntax. Regards,
  14. VJ I sure hope you're still following this. I've been using this since the first attributes fix was figured out by manually adding the fields in the file. Been able to get it all to work until now. This thread http://forums.oscommerce.com/index.php?showtopic=73572 is where I originally posted looking for help. The only attibute mod besides easy populate currently installed is the products attributes item editor 1.3 however the problem exists if I use clean versions of all the files. If I turn the attribs off in EP I can export a file. If they are turned on then I cannot export. Any help would be greatly appreciated. Thanks,
  15. OKay the saga continues. If I turn off the attributes in easypopulate.php then I get a download file that consists of the model number and the end of the record. If I turn attributes on and set the ones that I want to see it times out and gives the page cannot be displayed error instead of creating the file. This is a shared server so I do not have much input on the config of the services. The settings for the time out is already set to the 330 mark in the easypopulate file and everything else has been set for our site. Any further ideas n how to get the downloads to work in a useful manner? Regards,