Jump to content

JJ21

Members
  • Content count

    141
  • Joined

  • Last visited

Everything posted by JJ21

  1. Thanks for the great reply. I will do this.. By the way the previous question that i had about my EP not being able to download a complete.txt file is still not working. I tried the other version that you had sugested but still no go. I rembember before i upgraded there a fix for this but unfortunaly i did not back up my old EP.php File so I could have looked over it lol. I figured i knew EP enough. LOL Thank again if you can help me out with that also. Jon
  2. Hey guys and girls, I have my EP working fine... But im a little bit confused, how do i set up my product attributes? I have the option in my EP file layout, but im not for sure how i use it? I have some products that require different sizes and colors etc. It would be great if someone would just give me a run through, then I think i can figure it out from there. Thank Jon
  3. Hey guys, im having trouble, i just upgraded my EP to V. Easy Populate 2.76d-MS2 and it won't let me download a coplete file or ne for that matter, ive had no problems but liked the some of the new safe features. Ne Ideas?
  4. Are you putting the ERROR at the line also? The file will go ahead and upload but if you don't have have ERROR at the end of the line EP will just throw it out. And remember when you upload more than one file, reaname it to a different file. Don't have two files named the same unless you are updating that file!
  5. Go into your easypopulate.php file and under // Please set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php $tempdir = "/temp/"; $tempdir2 = "/temp/"; Just try to use what i have. It looks like your path might be wrong. Im using the same version as you and i had the same problem at first! By the way you don't have to do the Document Root thing...
  6. JJ21

    "Dynamenu" for osCommerce

    Hi again, i was wondering if someone could help me out, go to My Webpage and check out my menu on left side, now when you go over say Appariel and fasshion, the sub menu is so far out to the right, how do i get that to be closer? Thanks Jon
  7. JJ21

    "Dynamenu" for osCommerce

    Shortening the root menu names worked great.... Now all my tables are good. Thank
  8. JJ21

    "Dynamenu" for osCommerce

    Thank for the suggestions, gerat contrib, will def donate, when all is running good. Thank for the hard effort! Jon
  9. JJ21

    "Dynamenu" for osCommerce

    Thanks for the info, One more question then im all setup... The width issue, i read alittle bit about it in the forums, but really not getting it. If you go My webpage on the left side is my menu, now do u see how the width is not correct, and throwing the rest of my tables off? I tried using the $show_dmcats_as_box = false;, but i couldn't figure were the settings were for the table width, that just made it worse. So i went ahead and used $before_nobox_html = ''; $after_nobox_html = ''; and put in my own tags. So i even tried to set the table with within these tags, but no luck. And is it possible to do text wrap when i do set the width of the table? Thank.... <tr><td width="207"> <?php include(DIR_WS_BOXES . 'dm_categories.php'); ?> </td></tr>
  10. JJ21

    "Dynamenu" for osCommerce

    Thanks for the help so far, i have another question for you, lets say i don't want the arrows for the vert bar, how do i change the settings so they don't even show up? Thank
  11. JJ21

    "Dynamenu" for osCommerce

    Could you just give me a basic .css code that would allow this, and alos, how do i get it so the $show_dmcats_as_box = true;, witdth is smaller? Im trying to fit it now in my vert bar, i like it better there, but ther problem is the width of the box is too long... Thank Jon
  12. JJ21

    "Dynamenu" for osCommerce

    Hey guys, I know its prob in this forum somewere but i can't find it and even googled it! I was wondering wich line is it or how to i say add a background image so my links sit on it? Does this make cents? Im using the horizontal, and it workds great, just trying to tweak it now. Thank Jon
  13. JJ21

    Random Products

    Hi everyone? Hope everyone is doing as well as possible... I wanted my products below to be able to show up random. Now i located the file that is in control of these products showing up like this... All it does is just post the recent 3 products that i have uploaded? So since im not really smart at php, i figured some of you smart guys out there might be able to look at the code below and say well you can do this. Thank for you help... I hope i gave you all the information that you needed!! Now this is the code for these products, i would like it so that when the page loads it show 3 different products automatically... basically pulls them from my database, blah blah blah.... thanks guys ?> <!-- new_products //--> <?php if ( (!isset($new_products_category_id)) || ($new_products_category_id == '0') ) { $new_products_query = tep_db_query("select p.products_id, p.products_image, p.products_tax_class_id, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where products_status = '1' order by p.products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); } else { $new_products_query = tep_db_query("select distinct p.products_id, p.products_image, p.products_tax_class_id, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c, " . TABLE_CATEGORIES . " c where p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and c.parent_id = '" . (int)$new_products_category_id . "' and p.products_status = '1' order by p.products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); } $row = 0; $col = 0; echo ' <table cellspacing=0 cellpadding=0 width=474 align=center> <tr><td height=4 colspan=5></td></tr> <tr><td colspan=5><img src=images/m36.gif width=148 height=15></td></tr> <tr><td height=4 colspan=5></td></tr> <tr><td height=1 width=474 bgcolor=#A90000 colspan=5></td></tr> <tr><td height=16 colspan=5></td></tr> <tr> '; while ($new_products = tep_db_fetch_array($new_products_query)) { $new_products['products_name'] = tep_get_products_name($new_products['products_id']); $product_query = tep_db_query("select products_description from " . TABLE_PRODUCTS_DESCRIPTION . " where products_id = '" . (int)$new_products['products_id'] . "' and language_id = '" . (int)1 . "'"); $product = tep_db_fetch_array($product_query); $new_products['products_description'] = $product['products_description']; echo ' <td width=157 valign=top> <table cellspacing=0 cellpadding=0 width=142 align=center> <tr><td height=42 align=center colspan=2><a class=ml2 href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . $new_products['products_name'] . '</a></td></tr> <tr><td height=8 colspan=2></td></tr> <tr><td colspan=2><img src=images/m40.gif width=142 height=1></td></tr> <tr><td height=4 colspan=2></td></tr> <tr><td width=100 align=center><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $new_products['products_image'], $new_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'vspace=5') . '</a></td><td width=42 height=15 valign=bottom class=ch1>'.$currencies->display_price($new_products['products_price'], tep_get_tax_rate($new_products['products_tax_class_id'])).'</td></tr> <tr><td height=6 colspan=2></td></tr> <tr><td colspan=2><img src=images/m40.gif width=142 height=1></td></tr> <tr><td height=7 colspan=2></td></tr> <tr><td colspan=2><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . tep_image_button('small_view.gif') . '</a> <a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $new_products['products_id']) . '">' . tep_image_button('button_in_cart.gif') . '</a></td></tr> <tr><td height=3 colspan=2></td></tr> </table> </td> '; $col ++; if ($col > 2) { $col = 0; $row ++; echo ' </tr> <tr> '; } else echo '<td width=1 bgcolor=#4C4C4C></td>'; } echo ' </tr> <tr><td colspan=2 height=15></td></tr> </table> '; ?>
  14. Thank for the response, my configure file is set, it is at define('DIR_FS_CATALOG', '/var/www/vhosts/tarojoenterprises.com/httpdocs/store/'); Ne more ideas thank Jon
  15. I had to add to this also, i was looking around and i noticed, imagemagic is creating my pics under thumbnails, and the folder is set to 777, and i can even look at them, but their not showing up on my site? Ne ideas guys thank... Jon
  16. Hey guys, i have a quick question, i noticed some of my pics are comming up fine, while others that are in lets say images/44/picname.jpg, are not comming up, is this cause i have some of my images in a sub folder in the images folder? And if this is the problem is there a code in the imagemagic.php thati can change so it reads files that i are in subfolders to cache them? Thanks Jon
  17. JJ21

    PayPal WPP Direct Payments & Express Checkout Support

    Ok this is for sure now! If you have a two folder system, etc httpdocs, and httpsdocs, then this is what i did, only in the httsdocs includes/configure change the mention line above to https. now what this does it tells https docs to look for th XML files on the https side. It did not effect my site at all. So far the payment module is working great, i have ran about 8 different test on it and all seem to be working. Great module! Have anyquestions just ask me. Remember, IM using httpdoc and httpsdoc file system, so if you are and whenever you try to process credit cards with this change the above and it should work. Mine did, no problems so far!
  18. JJ21

    IT WORKS IT WORKS

    yeah sorry i actually ment to post it in the module forum lol, its the Papal WPP module by Dyno, hes come out with a new way of using paypal that is easy to install and setup, had one problem but figured it out. Its great.. Sorry about that!!!!
  19. JJ21

    IT WORKS IT WORKS

    Ok this is the best day of my life :) :) :) I finally have a payment module that actually works. Thank you so much dyno, I fixed my little problem with my https and it works thank.... I just charged 1.00 onto my debit card through the xpress button and through my site and it works.. now just some tweaking and im ready to make some money thanks for the new module much much easier to install :)
  20. JJ21

    PayPal WPP Direct Payments & Express Checkout Support

    It works, thanks alot guys and thank you dyno, great module, i have changed the file in the previous post from http to https and now i tested it live and it works with xpress and local, its great, thank you so much for the support.... Regards, Jon
  21. JJ21

    PayPal WPP Direct Payments & Express Checkout Support

    Now i chaged this: define('DIR_FS_CATALOG', '/var/www/vhosts/tarojoenterprises.com/httpdocs/store/'); to this: define('DIR_FS_CATALOG', '/var/www/vhosts/tarojoenterprises.com/httpsdocs/store/'); I know it looks the same but look carefully, i chaged the http to https for somer reason it can't go back and forth from my http to my https, but ne ways after you told me to post it dyno i was looking at it and noticed it. it fixed my problem and my site seems to be working just fine, besides i don't think it hurts to run the site in https most of the time ne way lol :) Thanks for the help will keep on letting you know about more bugs if i find ne. Maybe you could tell me though why there are two shipping address in my colums? Thanks it is basically duplicated Jon
  22. JJ21

    PayPal WPP Direct Payments & Express Checkout Support

    Thanks for your support heres my config... // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.tarojoenterprises.com'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.tarojoenterprises.com'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', true); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'www.tarojoenterprises.com'); define('HTTPS_COOKIE_DOMAIN', 'www.tarojoenterprises.com'); define('HTTP_COOKIE_PATH', '/store/'); define('HTTPS_COOKIE_PATH', '/store/'); define('DIR_WS_HTTP_CATALOG', '/store/'); define('DIR_WS_HTTPS_CATALOG', '/store/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/var/www/vhosts/tarojoenterprises.com/httpdocs/store/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
  23. JJ21

    PayPal WPP Direct Payments & Express Checkout Support

    Ok great module, i actually got furhter with this than ne other one, but there is one proplem, i tried your new module dyno, paypal_wpp_0.8, it works great, i was able to get access to paypal but only through http:, when it goes to https: switches over it says this Now this is through my https ok, and i know i have the XML filse located in the right area, but i tried to play with my config file wich finally let me find the cert in https: but i had to change the: in my config file, that found the cert in my https:// Cause i was getting a error about my cert first, now im getting this? Got ne ideas? I have been trying to figure out why even though its pointing to httpdocs, i need it to point to httpsdocs? HELP!!!! LOL GREAT Module though... Jon
  24. JJ21

    PayPal WPP Direct Payments & Express Checkout Support

    [/code]Ok i checked this forum and googled it, but it just saying to make sure your paths are set in my admin, wich they are!! But im getting these errors when i try to check out or trying to check out using express check out? Ne ideas? thanks Now here is my info, Now here is my code for my paypal_wpp.php Thanks for the help guys? //Initialize the connection with PayPal function paypal_init() { global $customer_id, $customer_first_name; require_once ('Services/PayPal.php'); require_once ('Services/PayPal/Profile/Handler/Array.php'); require_once ('Services/PayPal/Profile/API.php'); $handler =& ProfileHandler_Array::getInstance(array( 'username' => MODULE_PAYMENT_PAYPAL_DP_API_USERNAME, 'certificateFile' => MODULE_PAYMENT_PAYPAL_DP_CERT_PATH, //This needs to be an absolute path i.e. /home/user/cert.txt 'subject' => '', 'environment' => MODULE_PAYMENT_PAYPAL_DP_SERVER)); $profile = APIProfile::getInstance(MODULE_PAYMENT_PAYPAL_DP_API_USERNAME, $handler); $profile->setAPIPassword(MODULE_PAYMENT_PAYPAL_DP_API_PASSWORD); $caller =& Services_PayPal::getCallerServices($profile); //Create a caller object. Ring ring, who's there? if (trim(MODULE_PAYMENT_PAYPAL_DP_PROXY) != '') { $caller->setOpt('curl', CURLOPT_PROXYTYPE, CURLPROXY_HTTP); $caller->setOpt('curl', CURLOPT_PROXY, MODULE_PAYMENT_PAYPAL_DP_PROXY); } $caller->setOpt('curl', CURLOPT_SSL_VERIFYPEER, 0); $caller->setOpt('curl', CURLOPT_TIMEOUT, 180); $caller->setOpt('curl', CURLOPT_SSL_VERIFYHOST, 0); if(Services_PayPal::isError($caller)) { if ($this->enableDebugging == '1') { tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, 'PayPal Error Dump', "In function: paypal_init()\r\n\r\n" . var_dump($caller), STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS); } $this->away_with_you(MODULE_PAYMENT_PAYPAL_DP_TEXT_GEN_ERROR . $caller->Errors->ShortMessage . '<br>' . $caller->Errors->LongMessage . ' (' . $caller->Errors->ErrorCode . ')', true); } else { return $caller; } }
  25. JJ21

    oscFlashSlide not showing

    Currently i have installed this also, now i made the folder in the images directory? I also get the flash to come up but no products are showing up. So im working on it... If you guys would like to help pm me or leave a messeage, will let ya know what i found out thanks. Jon
×