Jump to content

sem101

Members
  • Content count

    7
  • Joined

  • Last visited

  1. I don't know what's going on in the Easy Populate contrib download area. It's a mess. People are adding version numbers, modifications, stripping away working code to only suit their needs, getting over-ambitious. I know what it's like wanting to "geek out" and serve the community, but the mods are pure chaos... People are even RE-NAMING both contribs to "EasyPopulater" and "QTYPro" in their modded versions -- wtf? I suggest downloading the clean base version of both and adding your own modifications that work for the time being. I have yet to find one forum post or accurate snippet that works with QTPro. And by "works" I mean 100%. The original authors did fine jobs - trust them. Time spent in the forums and with mod tweaking: 2 WEEKS Time spent starting from scratch: 2 DAYS I've got a beta working solely for my client - but I'm not ready to release a contrib just yet because I don't want to further confuse the osC community. Good luck.
  2. sem101

    [Contribution] STS v4

    Any fix for having the "GZip Compression" enabled and STS 4.1 Blank pages problem? (besides turning them OFF)
  3. Thanks for the Contribution, works great now! Note to anyone else getting further "(TESMODE) ... " errors live or test -- carefully enabling/disabling your FDS (if applicable) is what got mine to work. I had AIM working previously, then enabled some FDS settings, then all hell broke loose... Reverted back to default settings for now to debug :D
  4. Sorry, I was tired and didn't find this forum earlier. Here's what I asked in my previous post titled: "QTPro 4.25 + Easy Populate 2.8 MS2 = almost working!" Question: How do we get the products_stock_attributes to map to the products_stock_quantity so it can be exported/imported via Easy Populate? Right now, I can export a base CSV.txt file with "Activate support for Quantity Tracking Professional?" to "true" -- and I get: v_attribute_values_stock_1_1 v_attribute_values_stock_1_2 v_attribute_values_stock_1_3 etc. But I get the columns without the stock quantities in my exported CSV.txt file. So I add the stock numbers manually in the v_attribute_values_stock_1_1 field and re-import but it won't import the joined attributes: 1-1,2-5 (Tshirt-Size,Color-Black). Notice the comma, does that screw things up? That's what shows up in phpMyAdmin. I've looked through easypopulate.php and stock.php but due to my basic knowledge, I don't know how to achieve this. All help is appreciated! Thanks
  5. Hi there, I have the standard generic attibutes in my store to begin with a clean DB (auto increment = 1): Product: T-Shirt Option Name: Size(id1), Color (id2) Option Values: SM (id1), MED (id2), LG (id3), XL (id4), Black (id5) You get the point :D In Easy Populate I have enabled "Activate support for Quantity Tracking Professional?" to "true". This is excellent, because now I get the columns when I export a generic starter CSV: v_attribute_values_stock_1_1 v_attribute_values_stock_1_2 v_attribute_values_stock_1_3 etc. However, after triple-checking that I have set the QTYPro stock count for my product and it's attributes, the CSV only exports the column -- but not the stock quantity. So poking around, this seems fine, as now I have the column mapped and I'll just add stock quantity to that column and re-import the new CSV with a billion new products. However, now... After changing the stock qty to say "5" in v_attribute_values_stock_1_1 it only maps to my 1st attribute: SM, for example. Guess this makes sense because the column title is 1_1. So now, I go into phpMyAdmin and poke around the products_stock table. I find the column products_stock_attributes where it joins the attributes in the form of: 1-1,2-5. I'm assuming this translates to: 1(Product ID) 1(Size) + 2(Color) 5(Black) ??? The first thing that came to mind was that the Comma interfered with the Easy Populate export? So then I took a look at Stock.php and found were the comma was used, played around with a new character but nothing seemed to work. The only thing I can think of is something in the easypopulate.php file around these lines: (around line 378) //// attributes stock add start if (EP_CONTRIB_QTPRO == 'true') { $stock_attributes = $attribute_options['products_options_id'].'-'.$attribute_values['products_options_values_id']; $stock_quantity_query = tep_db_query("select products_stock_quantity from " . TABLE_PRODUCTS_STOCK . " where products_id = '" . (int)$row['v_products_id'] . "' and products_stock_attributes = '" . $stock_attributes . "'"); $stock_quantity = tep_db_fetch_array($stock_quantity_query); $row['v_attribute_values_stock_' . $attribute_options_count . '_' . $attribute_values_count] = $stock_quantity['products_stock_quantity']; } //// attributes stock add end (around line 1168) //// attributes stock add start if (EP_CONTRIB_QTPRO == 'true') { $key6 = 'v_attribute_values_stock_' . $attribute_options_count . '_' . $attribute_values_count; $header_array[$key6] = $iii++; } //// attributes stock add end There's more in there, but I don't wanna post a shitload of code. If anyone can pick this apart or point me the right direction I'd be so grateful! It seems that given my limited knowledge, I can figure out how to add 1 attribute to a T-Shirt. I can set SM, MED, LG, XL quantities, but I can't set BLACK+SM, BLACK+MED, BLACK+LG, BLACK+XL :( I guess my question is: How do we get the products_stock_attributes to map to the products_stock_quantity so it can be exported/imported via Easy Populate? Sorry for the long post. I'm tired and wired! Thanks!
  6. sem101

    [Contribution] UPS XML Tracking

    Version: UPS_XML_Tracking-2.2_finalMS2 Page: tracking.php Error Message: "This module supports only xpci version 1.0001 of the UPS Tracking Interface. Please contact the webmaster for additional assistance." I've inputted my XML Access Key and I'm currently logged into the UPS site, so I know it works. Any idea what this error message is? Output page shows up fine, but no tracking info, and the error message above. Thanks!
×