Jump to content

idzynes

Members
  • Content count

    14
  • Joined

  • Last visited

Profile Information

  • Real Name
    Landon Shipman
  1. idzynes

    Seperate Pricing Per Customer v3.5

    I successfully have installed SPPC and my client loves it! This install was merged successfully with Wolfen Featured Sets - without any aparent problems. Now I am trying to install the "Hide Products for CG_SPPC" and getting an unexpected T_ELSEIF parse error. (it points to a line around 840 each try) I am fairly certain I see WHERE the source of the problem is... but have no idea how to merge these two contributions to work correctly together. I am pasting ONLY the merges in question... someone please tell me what I have done wrong, or how I can work around this. Notice the fact that wolfen crosses right over the "hide from groups mod" The error is coming from the admin/categories.php page. CODE// BOF Wolfen featured sets for ($i=0, $n=sizeof($languages); $i<$n; $i++) { ?> <!-- BOF SPPC hide from groups mod --> <tr> <td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td> </tr> <tr> <td colspan="2" class="main" ><?php echo TEXT_HIDE_PRODUCTS_FROM_GROUP; ?></td> <td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_SHORT; ?></td> <td><table border="0" cellspacing="0" cellpadding="0"> <tr> <td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?> </td> <td class="main"><?php echo tep_draw_textarea_field('products_short[' . $languages[$i]['id'] . ']', 'soft', '70', '4', (isset($products_short[$languages[$i]['id']]) ? $products_short[$languages[$i]['id']] : tep_get_products_short($pInfo->products_id, $languages[$i]['id']))); ?></td> </tr> </table></td> </tr> <?php $hide_customers_group_query = tep_db_query("select customers_group_id, customers_group_name from " . TABLE_CUSTOMERS_GROUPS . " order by customers_group_id"); $hide_from_groups_array = explode(',',$pInfo->products_hide_from_groups); $hide_from_groups_array = array_slice($hide_from_groups_array, 1); // remove "@" from the array while ($hide_customers_group = tep_db_fetch_array($hide_customers_group_query)) { ?> <tr bgcolor="#ebebff"> <td class="main" colspan="2"><?php if (isset($pInfo->hide)) { echo tep_draw_checkbox_field('hide[' . $hide_customers_group['customers_group_id'] . ']', $hide_customers_group['customers_group_id'] , (isset($pInfo->hide[ $hide_customers_group['customers_group_id']])) ? 1: 0); } else { echo tep_draw_checkbox_field('hide[' . $hide_customers_group['customers_group_id'] . ']', $hide_customers_group['customers_group_id'] , (in_array($hide_customers_group['customers_group_id'], $hide_from_groups_array)) ? 1: 0); } ?> <?php echo $hide_customers_group['customers_group_name']; ?></td> </tr> <?php } // end while ($hide_customers_group = tep_db_fetch_array($hide_customers_group_query)) // EOF Wolfen featured sets ?> I would greatly appreciate any insight on this delima, I really hope someone can show me the light. Has anyone else ran into this? or combined these successfully? Thanks, Landon
  2. idzynes

    Wolfen Featured Sets SUPPORT

    I successfully installed wolfen feaured sets and love it! This install was merged successfully with Seperate Price Per Customers - without a lot of problems. Now I am trying to install the "Hide Products for CG_SPPC" and getting an unexpected T_ELSEIF parse error. (it points to a line around 840 each try) I am fairly certain I see WHERE the source of the problem is... but have no idea how to merge these two contributions to work correctly together. I am pasting ONLY the merges in question... someone please tell me what I have done wrong, or how I can work around this. Notice the fact that wolfen crosses right over the "hide from groups mod" // BOF Wolfen featured sets for ($i=0, $n=sizeof($languages); $i<$n; $i++) { ?> <!-- BOF SPPC hide from groups mod --> <tr> <td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td> </tr> <tr> <td colspan="2" class="main" ><?php echo TEXT_HIDE_PRODUCTS_FROM_GROUP; ?></td> <td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_SHORT; ?></td> <td><table border="0" cellspacing="0" cellpadding="0"> <tr> <td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?>?</td> <td class="main"><?php echo tep_draw_textarea_field('products_short[' . $languages[$i]['id'] . ']', 'soft', '70', '4', (isset($products_short[$languages[$i]['id']]) ? $products_short[$languages[$i]['id']] : tep_get_products_short($pInfo->products_id, $languages[$i]['id']))); ?></td> </tr> </table></td> </tr> <?php $hide_customers_group_query = tep_db_query("select customers_group_id, customers_group_name from " . TABLE_CUSTOMERS_GROUPS . " order by customers_group_id"); $hide_from_groups_array = explode(',',$pInfo->products_hide_from_groups); $hide_from_groups_array = array_slice($hide_from_groups_array, 1); // remove "@" from the array while ($hide_customers_group = tep_db_fetch_array($hide_customers_group_query)) { ?> <tr bgcolor="#ebebff"> <td class="main" colspan="2"><?php if (isset($pInfo->hide)) { echo tep_draw_checkbox_field('hide[' . $hide_customers_group['customers_group_id'] . ']', $hide_customers_group['customers_group_id'] , (isset($pInfo->hide[ $hide_customers_group['customers_group_id']])) ? 1: 0); } else { echo tep_draw_checkbox_field('hide[' . $hide_customers_group['customers_group_id'] . ']', $hide_customers_group['customers_group_id'] , (in_array($hide_customers_group['customers_group_id'], $hide_from_groups_array)) ? 1: 0); } ?>??<?php echo $hide_customers_group['customers_group_name']; ?></td> </tr> <?php } // end while ($hide_customers_group = tep_db_fetch_array($hide_customers_group_query)) // EOF Wolfen featured sets ?> I would greatly appreciate any insight on this delima, I really hope someone can show me the light. Thanks, Landon
  3. idzynes

    [Contribution] Task Manager (Admin)

    Cant go back and edit now... I am sorry - I thought you were referring to step-by-step manual order contribution. Download a comparison program if you need help installing the admin with access levels. I use winmerge, it is a very powerful, easy to use, and free program. Hope that helps.
  4. idzynes

    [Contribution] Task Manager (Admin)

    Still in testing phases (technically) - but all preliminary tests are fine. There may have been some tweaking on the merges (I can not quite remember) - but I DO also have the Step-By-Step installed and it works great as well.
  5. idzynes

    [Contribution] Task Manager (Admin)

    Although I have only begun to test, everything seems to work with the newer admin contribution located here as well: http://www.oscommerce.com/community/contributions,1359 It is a lot newer
  6. idzynes

    Store statistics

    OK - I have tested this and it works, my database problem cleared up when I deleted the tables and manually ran the sql. If you are still having problems installing this with the Admin with Access Levels - let me know.
  7. idzynes

    Store statistics

    I tried to install this on a version with Admin Access levels, I did not get far enough to confirm my previous post because I can not seem to get past some database issues. The database tables are defined in the catalog and admin, and I have confirmed that the tables DO exist in the database. But... I still get the follwing error when I try to select the Store_Statistics pages in admin: 1146 - Table 'store_viewed' doesn't exist select * from store_viewed where ip_address='' and date_format(store_viewed_date, '%Y%m%d') = date_format(now(), '%Y%m%d') [TEP STOP]
  8. idzynes

    [Contribution] Task Manager (Admin)

    The SQL error I was getting relates to inserting the test admin task. I am not good enought to figure out which column doesn't match the value count at row 1 - but ommitted this line and sql uploaded fine. INSERT INTO `admin_tasks` VALUES (1, 1, 1, 1, 2, 'Test Task', 'This is a Test Task To Ensure that your install went smoothly', '2006-04-04 15:59:10', '2006-04-04 16:58:17, 2006-04-04 16:58:17'); Then I had the division by zero error mentioned by azar - which cleared up when I inserted my own test tasks thru admin. I too see some missing (or incorrect) language defines... other than that it seems to be perfectly compatible with the newest Admin with Access levels #1359 Thanks for sharing this HUGE contribution! Great work!!!!
  9. idzynes

    [Contribution] Task Manager (Admin)

    If this has to be installed with Admin with Access levels - seems like it would be better to use the new version of that 1359 - posted over a year ago. Would this not work? I am getting SQL errors on sql upload.
  10. idzynes

    [Contribution] Task Manager (Admin)

    So can anyone tell me... can we install this by just intalling the OLD sql - the new sql - and the modified files?
  11. idzynes

    Store statistics

    mth_it Are you running CRE loaded, or something with Admin Levels with Access installed? If so, you just need to go to Admin>>Administrator>>FileAccess>> Then click on the REPORTS to select it - - then click on STORE FILES button to the right, select and store the three files orders_statistics.php, products_statistics.php, and store_statistics.php I have not installed this yet - but this is normal proceedure with Admin Levels with Access.
  12. This is a great contribution that has improved my life as a developer - thanks for all the support here! I have this successfully installed with a number of contributions with a little tweaking on a few. The only contribution I am having troubles with now is Special Price Per Customer. I have the customers_groups.php in the database and have added it to the file_access list... but the link on the left column will not show up. If I type admin/customers_groups.php - the pages now displays properly... can anyone just tell me how to get the link on the left column to work for SPPC? Thanks a million!!! Landon
  13. idzynes

    [CONTRIBUTION] CCGV (trad)

    Thank you for this improved contribution... I always thought I installed the original wrong - as it turns out everyone had the same problems. Thanks again. Anyway - everything worked for me except I created a javascript error and it seems no one else had the same problem. Can anyone tell me what might be conflicting or causing this error? I can post a list of the modifications - all contributions and less than 10. Error code pasted below: Warning: Missing argument 1 for javascript_validation() in /home/yourid/public_html/ims-osc/includes/classes/payment.php on line 108
  14. idzynes

    Customer Updates - Order Comments

    I added this contribution to my set up... I used a new order status called Order Update which was status id 4 - but when I log in as a customer and click update... nothing updates. The text I type is still active in the LIVE text box. Any ideas what I missed? I get no error message.
×