Latest News: (loading..)

realhotstuff

Members
  • Content count

    52
  • Joined

  • Last visited

Community Reputation

0 Neutral

About realhotstuff

Profile Information

  • Real Name
    Real Hot Stuff

Contact Methods

  1. I think this is similar problem with paypal_ipn module. Someone will need to modify paypal express and other paypal modules to fix the problem.
  2. Update to this issue. If I did not confirm the order and go through the check out process again, the discount shows up on the order confirmation page. I am thinking this is related to the code in checkout_confirmation here? something to do with the session? //kgt - discount coupons if( tep_not_null( $coupon ) && is_object( $order->coupon ) ) { //if they have entered something in the coupon field $order->coupon->verify_code(); if( MODULE_ORDER_TOTAL_DISCOUNT_COUPON_DEBUG != 'true' ) { if( !$order->coupon->is_errors() ) { //if we have passed all tests (no error message), make sure we still meet free shipping requirements, if any if( $order->coupon->is_recalc_shipping() ) tep_redirect( tep_href_link( FILENAME_CHECKOUT_SHIPPING, 'error_message=' . urlencode( ENTRY_DISCOUNT_COUPON_SHIPPING_CALC_ERROR ), 'SSL' ) ); //redirect to the shipping page to reselect the shipping method } else { if( tep_session_is_registered('coupon') ) tep_session_unregister('coupon'); //remove the coupon from the session tep_redirect( tep_href_link( FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode( implode( ' ', $order->coupon->get_messages() ) ), 'SSL' ) ); //redirect to the payment page } } } else { //if the coupon field is empty, unregister the coupon from the session if( tep_session_is_registered('coupon') ) { //we had a coupon entered before, so we need to unregister it tep_session_unregister('coupon'); //now check to see if we need to recalculate shipping: require_once( DIR_WS_CLASSES.'discount_coupon.php' ); if( discount_coupon::is_recalc_shipping() ) tep_redirect( tep_href_link( FILENAME_CHECKOUT_SHIPPING, 'error_message=' . urlencode( ENTRY_DISCOUNT_COUPON_SHIPPING_CALC_ERROR ), 'SSL' ) ); //redirect to the shipping page to reselect the shipping method } } //end kgt - discount coupons
  3. I am having the same problem with Paypal Express Checkout. Does anyone have a solution?
  4. I found the quick way to do it. I modified the code in checkout_processing.php. I put in blanks for all credit card related fields.
  5. Now that Linkpoint wprks fine for me. I would like to know what lines of code that I need to change so I don't store CC info in my database. I would like to be certified as PCI compliance. It is just a lot easier not to save the CC info. Thank you for all the great support here.
  6. After spending more time on the problem and finally figured out it was caused by my isp's DNS. My FTP was pointing to the old server and my browser was pointing to the new server. I kept changing the code and ftp it to the old server while testing on the new server. I ftped the new code to the new server and everything worked fine now. To be clear, I un-commented the 2 lines mentioned before and everything worked. Thank you iofast for your quick reply. I really appreciate it.
  7. Thank you very much for the quick response. I modified the code as you instructed, but still no good. This issue is strange, It was working after I migrated everything to a new server. I then installed a new SSL on the server and it stiopped working. I had them switched back to the original SSL and still no good. I searched the forum and someone had similar problem as I am having now. They claimed that after uncommented out the two lines solved the problem. I did that too but still no good. Someone also suggested downloade the new pem file. I followed that as well, still no good.
  8. Dan, Did you ever get this problem fixed? I am having the same issue and can not fix it.
  9. I migrated my server to a new hosting. It started working fine. I changed to a new SSL then it stopped working. I had my support guys changed back to the old SSL and still not working either. I then turn on the debug and got the same error as mentioned before: Warning: htmlspecialchars() expects parameter 1 to be string, array given in /home/realhots/public_html/includes/modules/payment/linkpoint_api/lphp.php on line 172 items = debugging = true I've uncommented the two lines in lphp.php fiel as suggested in previous posts. I alos downloaded the new pem file, neither one helped. Did any one really get this problem fixed? If so, can someone provided mea solution? I've also tried the new version of the contribution. It did not work either. Someone please help.
  10. Go to the uspstable.php (under module, not languages). At line 41 $check_query = tep_db_query("select zone_id from " . USPSTABLE_ZONES_TO_GEO_ZONES . " where geo_zone_id = '" . MODULE_SHIPPING_USPSTABLE_ZONE . "' and zone_country_id = '" . $order->delivery['country']['id'] . "' order by zone_id"); change it to: $check_query = tep_db_query("select zone_id from zones_to_geo_zones where geo_zone_id = '" . MODULE_SHIPPING_USPSTABLE_ZONE . "' and zone_country_id = '" . $order->delivery['country']['id'] . "' order by zone_id");
  11. Anyone having the same problem? I really need help!
  12. Need help with the residential surcharge and FedEx surcharge. What value should I put in these fields? Should these values be returned from FedEx? Both values are different by different service type. Someone please help. I am losing money if I put in low FedEx surcharge for express services. The rates for ground/home will be too high if I put in high number for FedEx surcharge.
  13. It was 'NONE' first time I used it.
  14. I have posted the same question but got no answer yet. Really hoping someone can help. My international rates are good, but the domestic surcharge and fuel charge screwed up the rates.
  15. The rates that I am getting back is lower than my actual rates especially like 2nd day and next day. I checked the actually rates and the fuel surcharge is very high. Does everyone get the correct rates by using this module? If so, can anyone let me know what I did wrong?