Latest News: (loading..)

k-sea

Members
  • Content count

    8
  • Joined

  • Last visited

About k-sea

  • Birthday 06/03/1974

Profile Information

  • Real Name
    Casey Dougall
  • Location
    Jamaica, VT USA
  • Interests
    snowboarding,<br />working for hayes brothers snowboards, stratton mountain resort, Luke Mitrani and myself on web shit, being a DJ "records" not CD's
  • Website
  1. Henery, Correct, I read your post on where the // Include OSC-AFFILIATE should be placed. load it before that line... Sorry My mistake for posting the wrong location. Too much coffee or something I've changed that and yet it still proceeds to give me the insert error. Before testing I removed all data in the sales table. ON my second order I received the insert error ... Never mind... It's working... With this first snow fall in vermont my brain was focused on snowboarding and not code modifcations... I had oscommerce in two directories on my computer and when I changed the checkout_process.php file it was the wrong one. OSCAffiliate is now working 100%! Even worked with 2checkout so I'm happy. Thank you "henri" and "snowman" for your assistance.
  2. Henery, Correct, I read your post on where the // Include OSC-AFFILIATE should be placed. load it before that line... Sorry My mistake for posting the wrong location. Too much coffee or something I've changed that and yet it still proceeds to give me the insert error. Before testing I removed all data in the sales table. ON my second order I received the insert error ...
  3. So the order id is not the customer "order id" I gues that's where I'm getting confused. The only way I can get this to work is if I change the structure of the affiliate_order_id to "AUTO_INCREMENT" If I do this it works like a charm but I was figuring it was connected to the customers order number.
  4. Yeah I'm still receiving the duplicate entry error durring checkout_process.php. Sales data doesn't make it to affiliate sales table. Everything else works fine. Just to be sure on this - the order ID being inserted should be the same as the customer order id right? The install document say to place the affiliate_checkout_process like this. // Include OSC-AFFILIATE require(DIR_WS_INCLUDES . 'affiliate_checkout_process.php'); // load the before_process function from the payment modules $payment_modules->before_process();
  5. I keep having troubles on the checkout_process with the affiliate sale not going into the database correctly... 1062 - Duplicate entry '0-1' for key 1 insert into affiliate_sales (affiliate_id, affiliate_date, affiliate_browser, affiliate_ipaddress, affiliate_value, affiliate_payment, affiliate_orders_id, affiliate_clickthroughs_id, affiliate_percent, affiliate_salesman) values ('1', '2003-10-20 18:06:32', 'Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; MSN 8.0; MSN 8.5; MSNbMSNI; MSNmen-us; MSNcIA)', 'my ip address', '29.99', '1.2', '', '4', '4.0000', '1') I've tried all kinds of stuff with this - reinstalls, drop and reload of database, still nothing is resolving this issue. This is on a new install of oscommerce MS2 with osaffiliate 2.0
  6. I'm trying to test the affiliate system the sales report keeps stating on status "Deleted (Admin)" Any idea why that is? Is this a precaution to keep affiliates from making sales themselves?
  7. I'm trying to test the affiliate system the sales report keeps stating on status "Deleted (Admin)" Any idea why that is? Is this a precaution to keep affiliates from making sales themselves?