Jump to content

damonik

Members
  • Content count

    5
  • Joined

  • Last visited

  1. damonik

    [Contribution] STS v4

    Has anyone provide any help on linking Article Manager into STS? I added: $sts->start_capture(); require(DIR_WS_BOXES . 'articles.php'); $sts->stop_capture('articles.php', 'box'); Into sts_user_code.php But once it was called in the template, got the error: Fatal error: Cannot redeclare tep_show_topic() (previously declared in /home/mysite.com/htdocs/catalog/includes/boxes/articles.php:13) in /home/mysite.com/htdocs/catalog/includes/boxes/articles.php on line 13 Anyone managed to link Article Manager successfully?
  2. damonik

    AJAX Attribute Manager support

    Awesome, fixed my problems - thanks heaps for that :)
  3. damonik

    AJAX Attribute Manager support

    Hi all, Anyone have any ideas about this post? http://forums.oscommerce.com/index.php?s=&...ndpost&p=834123 Really would love to use this addition but I just cant figure out what is going wrong.. Cheers, Damo
  4. damonik

    AJAX Attribute Manager support

    That is the first step I tried but gives me the error: Warning: main(): Unable to access classes/attributeManagerConfig.class.php in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 31 Warning: main(classes/attributeManagerConfig.class.php): failed to open stream: No such file or directory in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 31 Fatal error: main(): Failed opening required 'classes/attributeManagerConfig.class.php' (include_path='') in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 31 Very annoying because the beta works and looks great!! Anyone have any other ideas? Cheers, Damo
  5. damonik

    AJAX Attribute Manager support

    Hi all, I've been playing with this contribution for a while and can get the v1.5 beta contribution working. Unfortunately once I upgrade to the latest version v2.1 I get the following messages. Warning: main(): Unable to access classes/amDB.class.php in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 23 Warning: main(classes/amDB.class.php): failed to open stream: No such file or directory in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 23 Fatal error: main(): Failed opening required 'classes/amDB.class.php' (include_path='') in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 23 I tried the following fix: // db wrapper if(class_exists("amDB")) require_once('classes/amDB.class.php'); // session functions if(function_exists("amSessionUnregister")) require_once('includes/attributeManagerSessionFunctions.inc.php'); And got the resulting errors: Warning: main(): Unable to access classes/attributeManagerConfig.class.php in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 31 Warning: main(classes/attributeManagerConfig.class.php): failed to open stream: No such file or directory in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 31 Fatal error: main(): Failed opening required 'classes/attributeManagerConfig.class.php' (include_path='') in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 31 So I went and put in a if(class_exists) or if(function_exists) for the remaining require_once calls. And ended up with Fatal error: Undefined class name 'stopdirectaccess' in /home/**.net.au/htdocs/catalog/backend/attributeManager/attributeManager.php on line 55 At which point I just thought I would write this post! :lol: I am using: osCommerce 2.2-MS2 with PHP Version 4.3.11 Hope this info can help with this problem! Cheers, Damo
×