Jump to content

goodolandy

Members
  • Content count

    25
  • Joined

  • Last visited

  1. goodolandy

    Simply Hide Products (SHP)

    Hello Pronux, I first want to say that I think your script is a great add-on for anyone doing e-commerce and should be an already built in feature. I have not yet fully tested it but so far it is looking great. I just wanted to pass along a feature that would be nice to have incorporated in to SHP, the allowing of using customer names OR customer groups. I also have the add-on "Separate Price Per Customer" installed which allows the creation of user groups so it would be nice to choose groups instead of each individual user. I would even be willing to try and incorporate it myself but I am not a PHP expert so I am not exactly sure which code and in which file I would need to edit. Anyways, keep up the great work. Andy
  2. goodolandy

    Multi_Vendor_Shipping new thread

    There is no repeat HOWEVER I did go back and re-read the module.txt file just in case I had missed something...I did. After making this file I went a head and put a copy of it both under includes/modules/vendor_shipping and includes/lanuages/english/modules/vendor_shipping when I only needed to have it in the first while having the original in the second. After putting the original under the languages folder I now see the entire list of shipping options but with Warnings messages. At the very top of the list I receive; Warning: constant(): Couldn't find constant MODULE_SHIPPING_CANADAPOST_ZONE_1 in /includes/modules/vendors_shipping/canadapost.php on line 85 The other warnings are listed next to each shipping option twice but goes away when I click on the install button to the right; Warning: constant(): Couldn't find constant MODULE_SHIPPING_FEDEX1_SORT_ORDER_1 in /includes/modules/vendors_shipping/fedex1.php on line 120 Again, I have compared line 85 in the canadapost.php to the fedex1.php and again, do not see anything out of place. Should I maybe post the canadapost.php file I put together using the instructions in module.txt in case someone following this thread is able to see an error? I did get myself a book on PHP but it really isn't helping. Andrew
  3. goodolandy

    Multi_Vendor_Shipping new thread

    Hello again, I seem to have almost everything working now except when I click on "Manage" in the Venor Manager admin menu. I get the the error: Fatal error: Cannot redeclare class in includes/modules/vendors_shipping/canadapost.php on line 20 That code is: class canadapost { I compared the canadapost file I did per instructions from module.txt to fedex1.php and it had basically the exact same line only instead of canadapost it's fedex1. Andrew
  4. goodolandy

    Multi_Vendor_Shipping new thread

    Ok, I got categories to work. I used Winmerge and now categories appears just fine. Not sure where I went wrong the first time but anyways I'm off to take a look at the rest to make sure there isn't any other errors. I'll keep you posted. Andrew
  5. goodolandy

    Multi_Vendor_Shipping new thread

    My categories.php is not the standard file because part of the Canada Post add-on is to modify this file so when adding the MVS entries, I made sure not to remove the lines of code for the Canada Post module. Andrew
  6. goodolandy

    Multi_Vendor_Shipping new thread

    Hi John, the program I use is called Programmers File Editor. I did some searching in the help and it does do something similar to what you describe only it doesn't highlight but rather takes your cursor to the other end of the code. Not sure if this will work but I thought I would // each line I was instructed to input and then remove the // from each section to find out which add-in is now causing what you see in the image above. Andrew
  7. goodolandy

    Multi_Vendor_Shipping new thread

    Ok, I counted all the { and } and found 1 } missing so I went and applied it near the end of the file because I don't know where to put it and I've notice that there can be a few { before coming to any }. There error is now gone but categories is no longer displayed properly and the products are not being listed. Below is a screen shot of how the category menu is now coming up. Andrew
  8. goodolandy

    Multi_Vendor_Shipping new thread

    Okay, I have finished doing all the edits and I'm receiving an error in Admin when trying to visit the categories section. The error is a parse error, unexpected $ in admin/categories.php on line 1189 but when I checked the file, there is no line 1189. Total number of line is 1188. Any thoughts?
  9. goodolandy

    Multi_Vendor_Shipping new thread

    Thanks Jim, I'll keep that # sign feature in mind for future code postings. I kind of figured that all I would have to change was what you mention but coming so something that different from what is in the instructions kind of through me back. I've also been trying a bit to understand the different PHP commands while running a personal website using PHP Nuke but I do need to get myself a nice simple book for reference. I've checked my local library but those books which are not lost are written as if the reader is already above the basic learning level. I'll keep working at the script and see how far I can get with it. :)
  10. goodolandy

    Multi_Vendor_Shipping new thread

    I'll keep working on it but my PHP knowledge is below basic, in fact all I know is that every line seems to have to end with a ; or { and I'm not sure why. I guess I should try and find myself a PHP for Dummies book. :D
  11. goodolandy

    Multi_Vendor_Shipping new thread

    Hello everyone, I am currently trying to install this module on my site and I was following the module.txt file. Everything was going good until about half way down the instructions. The shipping module I'm trying to edit is the Canada Post 3.7 rev1 and I'm stumped at the following point in the module.txt file; Now look for code similar to this: --------------------------------------------------------------------------------------- $this->quotes = array('id' => $this->code, 'module' => MODULE_SHIPPING_TABLE_TEXT_TITLE, 'methods' => array(array('id' => $this->code, 'title' => MODULE_SHIPPING_TABLE_TEXT_WAY, 'cost' => $shipping + MODULE_SHIPPING_TABLE_HANDLING))); In the Canada Post module, the code is not like the above, infact only the top two lines are similar. Here is what is in the canadapost.php file; $this->quotes = array('id' => $this->code, 'module' => $this->title . ' (' . $this->boxCount . MODULE_SHIPPING_PACKAGING_RESULTS . ')'); $methods = array(); for ($i=0; $i<sizeof($canadapostQuote); $i++) { list($type, $cost) = each($canadapostQuote[$i]); if ( $this->cp_oniline_handling == true) { if ( $method == '' || $method == $type ) { $methods[] = array('id' => $type, 'title' => $type, 'cost' => $cost + $this->handling_cp); } } else { if ( $method == '' || $method == $type ) { $methods[] = array('id' => $type, 'title' => $type, 'cost' => (SHIPPING_HANDLING + $cost)); Has anyone been able to edit this module properly so it can work with the MVS module? I proceeded to the next step but it too I can not do because of the major differences between the module.txt and the canadapost.php file.
  12. goodolandy

    FAQDesk version 1.0 --- Released

    Just went through this entire thread but no ones has seem to have had the problem I'm now having. Do to stupid me deleting a certain table, I had to re-install my cart from scratch. I now have everything back the way it was except this time around the FAQ Desk is not working. When I'm in admin and choose to add a new question, I received the following error under the heading "Short Answer": Warning: main(includes/modules/faqdesk/html_editor_images/summary_bb.php): failed to open stream: No such file or directory in /admin/faqdesk.php on line 548 I checked the FAQ Desk files and notice that in the package there was no html_editor_images directory or summary_bb.php file so why would that directory and file be listed in faqdesk.php?
  13. Hello everyone, first there has been some posts from people saying things were not being subtracted from the final total. What I did to solve that problem was make Total sort order 800. Now I am still having a problem, one that I keep getting with every single version of the contribution and that is orders not being listed in admin>customers>orders Has anyone figured out this problem yet?
  14. Thanks for your reply Sterling and I'll give that jedit program a try. I've been using Winmerge which is nice, just wish the program would allow the user to choose part of a highlighted section to transfer over to the comparing file. Andrew
  15. First Tanya, don't expect to see a reply to the question of why 5.03 causes the orders not to show up in admin. The question has been asked numerous times and no one has given an answer. Must be a mystery that no one can figure out. :-) I do have two other errors that hopefully someone know the answer to. The first one is with v5.0. I copied the proper items over and would received an error pertaining to the following line: $payment_modules->update_status(); That line is in my checkout_confirmation.php file around line 51. The error had something to do with update_status so I put // in front of the line and everything seem to be working fine. What is that line and is it really important? After solving that, I started to upgrade from v5.0 to v5.03. When completed I got a parse error in my checkout_payment.php file on a line that didn't even exist. The error would give say line 412 but the file only had 411 lines. Anyone know what would cause this such error?
×