Jump to content

lildog

Members
  • Content count

    613
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by lildog

  1. lildog

    photo gallery for oscommerce

    Groggo, Usually this means there are extra characters(usually spaces or line feeds) after the final '?>' also check the appropriate language files for the same thing. That is almost always the answer. lildog
  2. lildog

    photo gallery for oscommerce

    I agree, I don't know everything about php and there were alot of changes I made to this contrib. I will try the fix and add it in. Thank you very much for your support! With out everyone helping out osc wouldn't be what it is. BTW, you will find ALOT more junk code. I made tons of changes, but got behind and had to move on. lildog
  3. lildog

    photo gallery for oscommerce

    Thank you for your help! I am going to add the changes in and upload a fixed version. lildog
  4. lildog

    photo gallery for oscommerce

    I have added many features to photo Gallery. Admins can add as many pics to users accounts as they want, admins can set users to unlimited photo uploads, put thumbnails in the clean gallery box, created an new gallery box in admin outside of the config box, added a slideshow infobox, cleaned up some code a bit, made some text more intuitive to users, added a short description text to gallery page. If anyone is interested let me know. lildog
  5. lildog

    photo gallery for oscommerce

    I was doing an install for a customer and ran across this error. It was caused by seo friendly urls turned on in the admin panel. The fix for that is : I fixed it by setting seo friendly urls to off for the following link: in gallery user: FIND: echo '[<a href="'.tep_href_link($link).'" onclick="return hs.htmlExpand(this, { objectType: \'iframe\',outlineType: \'rounded-white\', outlineWhileAnimating: true } )">' .TEXT_EDIT.'</a>]<br>'; REPLACE WITH: echo '[<a href="'.tep_href_link($link,'','SSL','',false).'" onclick="return hs.htmlExpand(this, { objectType: \'iframe\',outlineType: \'rounded-white\', outlineWhileAnimating: true } )">' .TEXT_EDIT.'</a>]<br>'; Good luck, lildog
  6. lildog

    photo gallery for oscommerce

    do you have seo friendly urls on in admin? lildog
  7. Why does this annoy you? It is part of the rss specs.... webMaster: Email address for person responsible for technical issues relating to channel. betty@herald.com (Betty Guernsey) See here(the origins of rss): RSS Specs
  8. I will look into this.....Ok, it looks like the products are ordered not by any date but by the products id. It makes sense to order them by modified date so you can breath new life into an old product. I will make some changes and upload a new version. lildog
  9. catalog/admin/categories.php: just delete , p.products_to_rss from the sql query. so it looks more like: select p.products_id, pd.products_name, p.products_quantity, p.products_image, p.products_price, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status from products p, products_description...(rest of the query) lildog
  10. Looks to me like you forgot to run the sql OR maybe didn't define the table in admin/includes/database_tables.php. That is just a guess though. To just put a bandaid on it you could just delete p.products_to_rss from the query. lildog
  11. This is a hard error to diagnose, but for me it usually happens when I try to echo something after a form has been sent, it is usually when I am trying to debug and echo some variables out after the form info was sent to the next page. Google the error and you will find alot of hard to understand info. Also see here.. lildog
  12. lildog

    Dynamic SiteMap

    Jack, I know of the problem, I think. It is going to be in your information.php box file. If I am correct it has to do with the $info_box_contents[] = array and how the ccgv link is added in. It needs to be added like all the other links.... Sorry I cannot be specific, I pulled ccgv from my site. lildog
  13. lildog

    Enable/Disable categories contribution

    Waiti, Thanks for the fix. Do you know if the new code will also work with php4.x? If so I will add it into the contrib. lildog BTW, the english was fine.....:)
  14. lildog

    Dynamic SiteMap

    Yeah if you have ssl off it will not use ssl links........So what do the links look like? I never took into the fact that SSL may be off. lildog
  15. lildog

    Dynamic SiteMap

    Now that I am done complaining about it. I uploaded a newer version that hopefully everyone can open. If not let me know and I will(quietly, without complaint) try to fix the problem. lildog
  16. lildog

    Dynamic SiteMap

    It's the F*$*G windows. Can't open anything.Is it the filenames or the lineendings or the file extensions. Any number of GD things flummux it up. I will fix it for you PC guys. How is everyone else opening it? lildog
  17. lildog

    Dynamic SiteMap

    I have been real busy lately. I will try to run down the problem....I know it has to do with the info pages unlimited fix, because without it everything works real well. lildog
  18. lildog

    Dynamic SiteMap

    Looks like you missed the define in admin/icludes/database_tables.php lildog
  19. No I don't know where, I am not an rss expert by any stretch of the imagination, but here is a starting point: http://www.rss-specifications.com/rss-submission.htm lildog
  20. Shawn, it looks to me like you missed the define in catalog/includes/filenames.php. Your feed works the link is wrong: http://swiss-watch.articlesmymoney.com/rss.php?language=en lildog
  21. For those of you recieving the invalid token errors try this: in catalog/rss.php: ***FIND: function replace_problem_characters($text) { ***ADD AFTER: $formattags = array("&"); $replacevals = array("&"); $text = str_replace($formattags, $replacevals, $text); ***FIND: $in[] = '@&(amp|#038);@i'; $out[] = '&'; ***REPLACE WITH: //$in[] = '@&(amp|#038);@i'; $out[] = '&'; PLEASE let me know if this works for you. I am working on an update to fix some minor validation errors. lildog
  22. lildog

    Dynamic SiteMap

    I just noticed this, I will look into it soon. lildog
  23. lildog

    Manual Order Maker

    This was one of my earlier contribs and it (as you know) kinda piggy backs on Order editor and is just a bit, I think your question needs to be in that forum. I think. lildog
  24. lildog

    Dynamic SiteMap

    I have posted a new version that includes the extra bullet fix above. lildog
  25. lildog

    Dynamic SiteMap

    oops....that is a custom box I have. The edit needs to be applies to:catalog/includes/boxes/information.php. AND DON'T FORGET: This same basic step needs to be performed for any boxes where you want the all products link to show in the sitemap.(note this only works on certain boxes, hopefully this will get more attention in the future) lildog
×