Jump to content

bobsi18

Members
  • Content count

    436
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by bobsi18

  1. bobsi18

    eparcel (Australia) backend system

    Good timing~! After reading about the recent Australia Post increases, I'm investigating using eParcel instead, so I would definitely be interested in this :)
  2. Old old thread, but I just wanted to post that I was having a similar issue, and it turned out to be a register globals issue - the "Bug fix for reg globals off" on the main contribution page (http://addons.oscommerce.com/info/1119) fixed it for me
  3. Also interested in this :)
  4. bobsi18

    Percentage Discount System

    I'm also after something like this - all of the links there seem to be a discount based on the number of items ordered - I'm after something (like the OP) that gives a discount based on the $$ total of the order? EDIT: have found this contribution, might be what I'm looking for: http://addons.oscommerce.com/info/204
  5. bobsi18

    ### POINTS AND REWARDS MODULE V1.00 ###

    Hi all, I've just started searching for solutions, but was wondering if anyone has any suggestions? I am running a MS2 shop, and have had points/rewards running on my shop for about 3 years, working brilliantly, thanks :) My site's server recently changed from PHP4/MYSQL4/register_globals on to PHP5/MYSQL5/register_globals off, and I thought it had gone ok, but I was wrong. Everything on the admin side is working (I can manually add points, adjust points, delete points etc), but customers are unable to redeem points when checking out. The box to tick "use points" is still there, it still correctly says how many points are available, but it doesn't allow the points to be used. If the points total is less than the order total, it just completes the checkout without redeeming the points. If the points total is more than the order total, it throws the error "REDEEM POINTS ERROR You do not have that many Points to spend." I had a look at the newer versions that have been submitted to the contributions, but it appears that they are for a RC2 shop rather than the MS2 shop. Any ideas on what to look for to fix this?
  6. bobsi18

    JUST RELEASED! Printable Catalog

    Fixed the sorting issue... This appears to be a register_globals issue - to fix, find switch ($listing) { and replace with switch ($_GET['listing']) { in catalog_products_with_images.php Still trying to figure out the page links issue. Not sure if I'll be able to figure it out...
  7. bobsi18

    JUST RELEASED! Printable Catalog

    I'm also having this problem - I had it working fine on a register_globals on/mysql4/php4 server, but I have just moved to register_globals off/mysql5/php5 and the sorting and the page links no longer work. Have no idea why. For now, I guess I'll have to take this off the website - hopefully there is a solution out there somewhere in the future :)
  8. bobsi18

    PHPList integration to OsCommerce

    I think I've fixed this. Let me know if there is a better fix, or I've done something wrong... On an oscommerce installation with the phplist addon installed, open create_account.php. find (line 38 of my modified store): replace with: find replace with find: replace with find: replace with
  9. bobsi18

    PHPList integration to OsCommerce

    Geah, I've got phplist integrated with oscommerce, and I'm having a few problems. When a customer signs up for an account, if they have an ' (apostrophe) in their name, it throws an error: I have no idea what to do about this, any ideas?
  10. Oh sob, it appears that this is why this is not working on my (local) test site: I have i/m successfully working on my server site, but am trying to set up a local site - the GD library info states: Whilst my server site GD library info states: All images with text watermarks are breaking on the local version, everything else is working fine. If anyone has any suggestions, please let me know, otherwise it looks like I'll have to live without text watermarks :(
  11. Ahhh, I honestly thought I'd done the right thing - whoops. Have installed (over the top of the original installation) and is now working great (realised after writing my last post that it wasn't really working - I was getting the redirect error after enabling "automatic redirects"). Doing a full install has fixed this. I had an issue originally (PHP Warning: strpos(): Empty delimiter in /includes/classes/seo.class.php on line 2580), but found earlier in this thread advice recommending that in includes/configure.php DIR_WS_HTTP_CATALOG should be / (for an installation in the root) - somehow this had changed between my server copy and my local copy - all fixed now. Thanks for your help Jack :)
  12. No, I didn't, I just did an upgrade as I was going from V2.1. The upgrade instructions noted to replace the seo.class.php file, and then to call the site in my browser. It mentions to "Re-configure through the admin control panel", but I just presumed that was to confirm that you wanted the same settings, and to see if I wanted to use any of the new settings (which I didn't). In any case, I found a spot in this thread where you advised uninstalling and reinstalling the contribution (using the options in the admin side), and then turning off all of the options. I have done this, and my site is working again, with the correct URL names. I've added my preferred settings back in (to cache categories and product info) and it's all good :)
  13. Ok, I've installed/upgraded (which was painless, just dropping in the new seo.class.php. However, I now have an issue on the site, I'm getting the "Too many redirects" error page (Too many redirects occurred trying to open “http://mysite/category-c-1.html”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.) This is happening for category pages and product info pages. I have reset SEO URLs cache, I'm not sure where to go from here. I didn't change anything in the .htaccess file, it says: Options +FollowSymLinks RewriteEngine On RewriteBase / RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
  14. Thanks for your responses Jack and FWR Media, I'll get to installing it and (hopefully) report back with an all clear :) At this stage, I'm trying to get my site up off the ground asap, as I have a migration to new servers imminent. After this is taken care of, I plan on revisiting my site and starting afresh on RC2, at that stage I'll make the decisions about what is best for my site (I first set up my site about 3 years ago, so much of my code and addons are from then). What's most important is that new URL's are the same as old URL's, so as not to lose any work done on search engines etc. I also have Jack's header tags installed - I'm fairly confident that it's a combination of this contribution and my insistence on fully describing each and every one of my products on my site (many others in the industry don't) that has put my site above my competitors who have very similar (code-wise) sites.
  15. Ok, I'll jump to it and start installing it... Just a quick one - is "Ultimate SEO 2-2.2d-9" suitable? (uploaded 23 Mar 2010) or is there a better one that you would recommend? Also, is it fair to presume that once installing V2.2d, this isn't backwards compatible? I was planning on uploading my (PHP5/MYSQL5 ready) site to the existing server (PHP4/MYSQL4) before it is migrated across to the new server - would this no longer be possible?
  16. Hi all, Looking for some advice. I'm moving my installation of oscommerce to a new server with php5/mysql5 installed. I'm pretty sure that SEO URLS is working correctly. I had one issue early on, I had to replace <? with <?php in /includes/classes/seo.class.php. Now it looks like I have one issue left. Previously, on my site, category pages were showing up as: www.mydomain.com/categoryname-c-01.html . On my new installation, they are showing up as www.mydomain.com/-c-1.html. My .htaccess area looks the same (as far as I can see!) - it has listed: Options +FollowSymLinks RewriteEngine On RewriteBase / RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING} Any suggestions?
  17. Hey all, having a few issues with this contribution. Have it working fine on my main installation (which uses MYSQL4/PHP4), but I am attempting to change servers, and am having trouble on the new installation (MYSQL5/PHP5). I'm not sure if it's a problem because of the migration, or a problem because of the php/mysql versions. I'm getting the following errors when I view any images on my site: PHP Notice: Undefined variable: config_values in /imagemagic.php on line 28 PHP Notice: Undefined variable: page_prefix in /imagemagic.php on line 156 PHP Notice: Undefined variable: config_values in /imagemagic.php on line 28 PHP Notice: Undefined variable: page_prefix in /imagemagic.php on line 156 PHP Notice: Undefined variable: image_watermark in /imagemagic.php on line 269 PHP Notice: Undefined variable: frame in /imagemagic.php on line 270 PHP Notice: Undefined variable: bevel in /imagemagic.php on line 271 PHP Notice: Undefined variable: text_watermark in /imagemagic.php on line 272 PHP Notice: Undefined variable: page_prefix in /imagemagic.php on line 279 PHP Notice: Undefined variable: image_watermark in /imagemagic.php on line 269 PHP Notice: Undefined variable: frame in /imagemagic.php on line 270 PHP Notice: Undefined variable: bevel in /imagemagic.php on line 271 PHP Notice: Undefined variable: text_watermark in /imagemagic.php on line 272 PHP Notice: Undefined variable: page_prefix in /imagemagic.php on line 279 PHP Notice: Use of undefined constant file - assumed 'file' in /imagemagic.php on line 393 PHP Notice: Use of undefined constant file - assumed 'file' in /imagemagic.php on line 393 I've searched on this, and have found that people recommend that these errors can be ignored - is this so? (the information that I found was very general, not referring to this particular contribution). Also, my thumbnails are working, but the main images aren't. I have text watermark setup - if I disable the text watermark, the main images work too (the errors occur regardless). Not sure where to go from here, I need/want the text watermarks on my site, and I'm apprehensive to leave so many errors! *sigh* as soon as my site is functioning with register_globals off, mysql5 and php5, I will be writing up a post on what I had to do to get it there!
  18. bobsi18

    Fancier Invoice & Packingslip v1.0

    Ok, I figured it out. Had forgotten that there was another configure.php file (in /includes/local) - had to change some settings in there.
  19. bobsi18

    Fancier Invoice & Packingslip v1.0

    How did you fix this? I am having this problem.
  20. Just wondering if anyone has any suggestions...
  21. Hey all - I'm just wondering if anyone else has experienced slow connected times using this contribution? I've been using the contribution for over a year now, and have just recently noticed that my site is slowing down... Upon investigation, I found that one query is particularly slow, and I've identified it to be from this contribution. I've got a copy of this site also running - a "test center", which has all of the same files, but the database has very little information in it, and the query doesn't seem to take anywhere near as long. So maybe it's because the table is starting to get full? Any ideas? These are the results from my site: length of time => 0.101127 problem query => update visitors set counter = counter+1, online = now() where browser_ip = 'my ip address' AND browser_language = 'en-us' AND to_days(now()) - to_days(date) < 1
  22. bobsi18

    Shipping Based on weight and total price

    Ahh, never mind, I found a contribution that *nearly* does everything I need: http://addons.oscommerce.com/info/4187 not sure why I couldn't find it before!
  23. Hey all, I'm trying to find a shipping module that will help me achieve the following: Up to $100 Up to $200 Up to $300 Up to $400 500grams $8 $9.5 $11 $12.5 3kg $12 $13.5 $15 $16.5 6kg $24 $27 $30 $33 9kg $36 $40.5 $45 $49.5 Does this make sense? Any ideas on modules to use/modify? Thanks
  24. bobsi18

    Shipping Based on weight and total price

    Geah, I did format that so that it was easier to read, but the forum has pushed it all together... Basically, the prices range from $8 for 500grams and under $100, to $49.50 for (up to) 9kg and under $400, with varying prices in between.
  25. bobsi18

    Automatically send data feed to Froogle

    Just wondering if anyone has managed to get this working with attributes that change the price? For example, I have some products that have different sizes, and use the attributes to change the price, eg the main price for the item is $2, but then the attributes override and small is $2, large is $4. The price going to Google is $2, but I'd prefer if it was $2-$4 or something similar? Also, I have some items that are $0.00, that I'd like to list in google if at all possible, I was thinking of changing their price (in the google feed only) to $0.02 or something similar, but having a hard time doing this - any suggestions? Thanks~
×