Jump to content

di11on

Members
  • Content count

    57
  • Joined

  • Last visited

Everything posted by di11on

  1. The table: ebay_auctiontype is empty. Its used to populate the contents of the auction type dropdown in the new listing screen. What should this table contain?
  2. Never mind - this problem is caused by the ebay_products table being empty. I just populated it with the products_description from the products_description table. Currently sorting out a problem with shopping_cart.php which seems to be a typo of mine!
  3. I've installed this and apart from a few missing Defines, everything seems to be ok...except I'm getting the following error in my edit product and new product pages: Warning: reset() [function.reset]: Passed variable is not an array or object in C:\Server\Apache2\htdocs\wtoys\admin\includes\classes\object_info.php on line 17 Warning: Variable passed to each() is not an array or object in C:\Server\Apache2\htdocs\wtoys\admin\includes\classes\object_info.php on line 18 I can't see any of the information for my products - all the fields are empty. Looking at the database, I know the information is there. To verify it wasn't an error on my part making the chages to categories.php, I used the categories.php that came with the installation package. This gives the same error. I've successfully uploaded a new listing to the ebay sandbox and dowloaded the ebay categories etc. so I know that functionality is working... just seems to be some error in categories.php. Can someone please help? Many thanks, Jody
  4. di11on

    Fancier Invoice & Packingslip v1.0

    Took me a while to find this one. The problem is an absolute reference to the catalog directory, so if your store is located in the root, you'll get this problem. In includes/modules/email_invoice/templates/html_invoice.php change <td background="<?php echo HTTP_SERVER; ?>/catalog/images/borders/maingrey_06.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_06.gif" width="19" height="21" alt=""></td> to <td background="<?php echo $ei_image_dir; ?>borders/maingrey_06.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_06.gif" width="19" height="21" alt=""></td> change <td background="<?php echo HTTP_SERVER; ?>/catalog/images/borders/maingrey_02.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_02.gif" width="24" height="16" alt="" ></td> to <td background="<?php echo $ei_image_dir; ?>borders/maingrey_02.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_02.gif" width="24" height="16" alt="" ></td> change <td background="<?php echo HTTP_SERVER; ?>/catalog/images/borders/maingrey_04.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_04.gif" width="11" height="21" alt=""></td> to <td background="<?php echo $ei_image_dir; ?>borders/maingrey_04.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_04.gif" width="11" height="21" alt=""></td> change <td><img src="<?php echo HTTP_SERVER; ?>/catalog/images/pixel_trans.gif" width="1" height="7" alt=""></td> to <td><img src="<?php echo $ei_image_dir; ?>pixel_trans.gif" width="1" height="7" alt=""></td> change <td background="<?php echo HTTP_SERVER; ?>/catalog/images/borders/maingrey_08.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_08.gif" width="24" height="18" alt=""></td> to <td background="<?php echo $ei_image_dir; ?>borders/maingrey_08.gif"><img src="<?php echo $ei_image_dir; ?>borders/maingrey_08.gif" width="24" height="18" alt=""></td>
  5. Hi folks, When I look at the google crawl stats for my site, google reports that the following URLs are cuasing redirect errors. Does anyone know what is causing this and how it might be resolved? Thanks in advance, Jody http://www.vintagevibrations.com/catalog/i...6068dfd212c7d0c 58d4836&amp;amp;amp;sort=2d&amp;amp;amp;pa ge=1&amp;products_id=100 http://www.vintagevibrations.com/catalog/i...6068dfd212c7d0c 58d4836&amp;amp;amp;sort=3a&amp;amp;amp;pa ge=1&amp;products_id=100 http://www.vintagevibrations.com/catalog/i...mp;amp;amp;page =1&amp;amp;sort=2d&osCsid=568b77e9976068df d212c7d0c58d4836 http://www.vintagevibrations.com/catalog/i...mp;amp;amp;page =1&amp;amp;sort=3a&osCsid=568b77e9976068df d212c7d0c58d4836 http://www.vintagevibrations.com/catalog/i...dfd212c7d0c58d4 836&amp;sort=2d&amp;page=1&products_id =100 http://www.vintagevibrations.com/catalog/i...dfd212c7d0c58d4 836&amp;sort=3a&amp;page=1&products_id =100 http://www.vintagevibrations.com/catalog/i...age=1&sort= 2d&osCsid=568b77e9976068dfd212c7d0c58d4836 http://www.vintagevibrations.com/catalog/i...age=1&sort= 3a&osCsid=568b77e9976068dfd212c7d0c58d4836 http://www.vintagevibrations.com/catalog/i...d0c58d4836& sort=2d&page=1&products_id=100 http://www.vintagevibrations.com/catalog/i...d0c58d4836& sort=3a&page=1&products_id=100 http://www.vintagevibrations.com/catalog/i...212c7d0c58d4836 http://www.vintagevibrations.com/catalog/i...212c7d0c58d4836
  6. Thanks a million for that Jack... that actually gave me enough information to get rid of the error... was missing some java script for a contribution I have installed. Thanks a gain, Jody
  7. Hi folks, Thank you for this contribution - it looks quite nice and is very easy to use. I've just installed it and it works perfectly...except, when I click on Links it takes me to the link categories page. This loads up nice and quickly but there is a warning trying at the bottom left in my browser telling me there's an error... here are the details: Line: 341 Char: 1 Error: Object Expected Code: 0 url: http://www.vintagevibrations.com/catalog/l...=XXXXXXXXXXXXXX When I click on a category, the links for that category load up VERY slowly. The do eventually display and everything looks fine. The browser error when clicking on the warning triangle is now this: Line: 368 Char: 1 Error: Object Expected Code: 0 url: http://www.vintagevibrations.com/catalog/l...=XXXXXXXXXXXXXX Any help with this would be greatly appreciated, Thanks, Jody
  8. di11on

    Current AUctions V2.0

    Hi folks, Anyone have any inspiration for this one? Thanks, Di11on
  9. di11on

    [contribution] Star Product

    Hi folks, I'm having a problem with this contribution. It works great, except when I click on the buy now button it takes me to the shopping cart. If I then click on continue shopping, I get a ''page cannot be displayed'' error. You can see it here: www.vintagevibrations.com Thanks in advance, Di11on
  10. di11on

    Current AUctions V2.0

    Hi folks, I'm getting the following error: Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/v35163/public_html/catalog/includes/modules/current_auctions_module.php on line 54 It was working fine for me until recently. I've installed Ultimate_SEO_URLs - could that be the problem? Only other thing I can think of is that my ISP has changed their secuirty settings! Anyone have any ideas? Thanks in advance, Di11on
  11. di11on

    Fancier Invoice & Packingslip v1.0

    Perhaps you could revert to $oID and put in these lines of code somewhere near the top of your email template files, something like this if (int)$oID == 0 { $oID = $order_id; }
  12. di11on

    Fancier Invoice & Packingslip v1.0

    Yikes typo in previous post. It should read: In catalog\includes\functions\general.php find in tep_address_format: } elseif (isset($address['country']) && tep_not_null($address['country'])) { $country = tep_output_string_protected($address['country']); and reaplce with } elseif (isset($address['country']) && tep_not_null($address['country'])) { $country = tep_output_string_protected($address['country']['title']); Sorry about that
  13. di11on

    Fancier Invoice & Packingslip v1.0

    Sorry - yes I forgot to include a correction to catalog\includes\functions\general.php that fixes a general bug find in tep_address_format: } elseif (isset($address['country']) && tep_not_null($address['country'])) { $country = tep_output_string_protected($address['country']); and reaplce with } } elseif (isset($address['country']) && tep_not_null($address['country'])) { $country = tep_output_string_protected($address['country']['title']);
  14. di11on

    Current AUctions V2.0

    Bumpity bump... Can anyone help me with my red xs appearing for my Auction Items in place of the actual images? Many thanks in advance, Jody
  15. Would it be against PayPal TOS if I were to change the description of the PayPal IPN payment method to something like Credit/Debit Card (Provided by PayPal) ... just to emphasise to the customer that they don't need a PayPal account to pay. Thanks, Jody
  16. di11on

    Fancier Invoice & Packingslip v1.0

    Instructions For Getting This Great Contribution to Work with Paypal IPN (osCommmerce_PayPal_IPN_v1.2) These are the steps required in addition to those in the installation guide that comes with the contribution, in order to get it to work with the official osCommmerce_PayPal_IPN_v1.2 contribution. Backup your files before performing these steps!!! It worked for me, but nothing is guaranteed in the coding world! Repeat Step 7 of the installation instructions for /catalog/includes/modules/payment/paypal_ipn.php, as follows Step 7b: Open: catalog/includes/modules/payment/paypal_ipn.php Directly under: // lets start with the email confirmation Add this: // START HTML Invoice if (EMAIL_INVOICE == 'true') { require(DIR_WS_MODULES . EMAIL_INVOICE_DIR . FILENAME_EMAIL_INVOICE); } else { // END HTML Invoice Directly above: // load the after_process function from the payment modules $payment_modules->after_process(); Add this: // START HTML Invoice } // END HTML Invoice Further Steps Required Open catalog/includes/modules/email_invoice/email_invoice.php Find this code near the beginning of the file: require(DIR_FS_ADMIN . DIR_WS_LANGUAGES . $language . "/" . FILENAME_ORDERS_INVOICE); Replace this with // Edited to make Fancier Packing SLip and Invoice v 1.2 work with Paypal IPN // require(DIR_FS_ADMIN . DIR_WS_LANGUAGES . $language . "/" . FILENAME_ORDERS_INVOICE); $language_query = tep_db_query("select directory from " . TABLE_LANGUAGES . " where languages_id = '" . tep_db_input($languages_id) . "'"); $language = tep_db_fetch_array($language_query); $language_dir= $language['directory']; require(DIR_FS_ADMIN . DIR_WS_LANGUAGES . $language_dir . "/" . FILENAME_ORDERS_INVOICE); Open catalog\includes\modules\email_invoice\templates\html_invoice.php Replace all instances of $oID with $order_id I imagine you will need to repeat this for all files in the template dir that you intend to use, but I haven't verified this. Hey presto... it should now work! I hope this is of some help to people out there!
  17. di11on

    Official PayPal IPN Support Thread

    I have a couple of questions. Could someone please tell me what the major differences are between the PayPal IPN payment method (as implemented by this contrib) and PayPal Express Checkout (Direct Payments). In both you are directed to the Paypal website for payment and are returned to the merchant site afterwards. Also, is it possible when directed to the paypal webiste, to arrive at the credit card entry screen rather than the paypal login screen? I.e. as it is implemented, you are taken to the paypal login screen. If you don't have an account you need to click on ''don't have a paypal account''? Is it possible to go straight to the page you arrive at when clicking on ''don't have a paypal account'' without having to go through the paypal login screen? Basically, as PayPal will be the only payment method to begin with, I want to assume the buy does not have a PayPal account rather than the other way round. Many thanks, in advance. Jody
  18. di11on

    PayPal Website Payments Pro - v0.1

    OK - I've got Express Checkout working on Sandbox, but when I am sent to paypal to enter my account details and confirm, it sends me back to the Shipping page of my site. This means the flow for an order is: Checkout -> Shipping -> Payment Information (select Paypal Express Checkout) -> Confirm Order -> Paypal Login -> Paypal Review Payment -> Shipping -> Payment Information (Paypal Selected) -> Confirm Order -> Finished This is very cumbersome. Is it the intended functionality, that after leaving paypal, you are taken back to the shipping page? Any help would be appreciated. Many thanks, Jody
  19. di11on

    PayPal WPP Direct Payments & Express Checkout Support

    Hi - sorry about that... thanks for letting me know! Cheers, Jody
  20. di11on

    Current AUctions V2.0

    Hi, Most of the time, I'm getting red x's for my pictures in the Current Auctions listing. Sometimes, I see some of the pictures. It was working fine when I was hosting the site locally, but when I got it hosted, that's when the difficulties started, I think! I'm using the Image Magic contribution - does that impact on this? I see the tep_image function is used, so it shouldn't be too much of a problem. Any inspiration? Many thanks, Jody
  21. di11on

    PayPal WPP Direct Payments & Express Checkout Support

    OK - I've got Express Checkout working on Sandbox, but when I am sent to paypal to enter my account details and confirm, it sends me back to the Shipping page of my site. This means the flow for an order is: Checkout -> Shipping -> Payment Information (select Paypal Express Checkout) -> Confirm Order -> Paypal Login -> Paypal Review Payment -> Shipping -> Payment Information (Paypal Selected) -> Confirm Order -> Finished This is very cumbersome. Is it the intended functionality, that after leaving paypal, you are taken back to the shipping page? Any help would be appreciated. Many thanks, Jody
  22. di11on

    PayPal WPP Direct Payments & Express Checkout Support

    Update: Found out how to get the cert. I'd already requested credentials and had selected: ''API Signature'' rather than ''API SSL client-side certificate''. So I had to remove my credentails and then had the option to request a certificate. I'd still like to know what I should fill in for the following two configuration items, though: - PayPal BN - IPN Notification URL Many thanks in advance (again), Jody
  23. di11on

    PayPal WPP Direct Payments & Express Checkout Support

    I'm having difficulty getting an API certificate for my Sandbox business account for use with Express Checkout. All the guides I've looked at for this procedure tell me to log into the sandbox account and navigate to Profile-> API Access -> Request API Certificate However, I only see Request API Credentials (not certificate). When I download my credentials, I get a username password and signature, but I cannot, for the life of me, see how to get a certificate. When I look under certificates in my Developer Central Account, I see none. Perhaps someone can help! I presume I need a certificate to get Express Checout working using this contrib. Finally, what should I set the following configuration items to? - PayPal BN - IPN Notification URL Many thanks in advance, Jody
  24. Finally got it working!!! This was the problem: The results are really great! Just what I was looking for What would be really helpful, would be a troubleshooting checklist at the end of the readme file which could spare people a lot of time trawling through this thread. Might also save you some time Tom :-) A list of things to check like: - Is thumbnail folder created? - Is SAFE MODE is OFF? - Is DIR_FS_CATALOG path set correctly in configure.php? - Is thumbnail server caching turned off? - Is error reporting turned off in PHP.ini as follows: error_reporting = E_ALL & ~E_NOTICE Etc. Thanks Jody
×