Jump to content


  • Content count

  • Joined

  • Last visited

Everything posted by stardust

  1. stardust

    [contribution] Simple Template System (sts)

    I tried to edit my previous post, but since i couldn't, here's my configure.php: <?php /* osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://localhost'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'localhost'); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/shop/'); define('HTTPS_COOKIE_PATH', ''); define('DIR_WS_HTTP_CATALOG', '/shop/'); define('DIR_WS_HTTPS_CATALOG', ''); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); Hope this helps :)
  2. stardust

    [contribution] Simple Template System (sts)

    Thanks for the hint Rigadin, but this problem still bother me.I?m running my shop on Apache2Triad 1.3, just to test all the stuff.Since I don't know how to follow the first hint, i forced the use of cookies, and then, the shop keep asking me to allow the use of cookies in my browse (IE 6 and Firefox 1.5).No matter what i do in the browse config, it is still asking for the same thing, always and always both IE and Firefox. Is the prob in my shop (something to do with that /tmp directory?I forced the use of cache too, to make it use the tmp folder, but nothing...) or in the Apache?Or maybe in the domain name?In the instalation of the shop, i left everthing as default, the url it use is http://localhost/shop (it doesn't uses those domain terminations like .com) . *I installed another shop (with the original version of OsCommerce 2.2 - not in my language) in the folder that Apache uses as the directory for sites, i called it "Test".I did the same thing, forced the use of cookies, and the same error happens.No matter if I?m using STS or BTS. **Both IE and Firefox are enabled to use cookies, they even have some stored in their cache. . ***I?m also using the same Apache2Triad to test and build a forum using phpbb2, with the forum, the cookies works, their name: localhost phpbb2mysql_sid localhost phpbb2mysql_data localhost lang ****The file name of the "original" version of Oscommerce that found the some prob of mine is oscommerce-2.2ms2-051113.zip.Anyone here uses the same version?If so, did you found the same prob?Is it some kind of bug?
  3. stardust

    [contribution] Simple Template System (sts)

    I?m using the sts_template system and made some links on my page some using images and others as text.But i found a problem that i dont know what to do.For example, the "home" link.I dont want to use those $breadcumbs i only want a link "home".If a user makes login, ALL the other links (infoboxes) changes to something like this: link.php?osCsid=e85739eeb741b7225ed053fb54740742.I know that those numbers are some sort of identification of the user. Then i creat the link "home" in the sts_template, and put it like this: "<a href="index.php">Home</a>".If a logged user click on this link, he will logoff, because it doesnt generate those letters and numbers of identification. I wanted to know what should i do to generate that code.Thanks PS: Forgive my english :blush:
  4. stardust

    Product Listing in Columns v2.0

    How do i download it?In the contributions page of OsCommerce there?s no link :blink: