Jump to content



Omar_one

Member Since 27 Mar 2016
OFFLINE Last Active Yesterday, 22:32
-----

Topics I've Started

moving the site from sub-folder to root

14 April 2017 - 15:43

Hello everyone,

 I am trying to move the shop from sub-folder, and it working well,

I have been modifying the configure.php files and .htaccess file,

after a few hours,   I got blank page (just the catalog the admin weork well) with  some errors about the duplicate configuration keys, so I checked the use phpmyadmin  to found out these duplicate configuration keys and uninstall  it,

After that I got just blank page without errors, and if I move it back to sub-folder work well .

beside that i haven't got this errors when the shop in  sub-folder...

 

Did I miss something.

I am using osc 2.3 bs Edge

 

Thank your for any help

Omar


Specials Ribbon Overlay For OsCommerce 2.3.4/BS

14 March 2017 - 19:25

Hello,

This addon adds a ribbon to every product having a special price.

No new files
edited 2 file

here is the addon

http://addons.oscommerce.com/info/9557

 

here is a screenshot


PHPMailer Bug Leaves Millions of Websites Open to Attack

13 January 2017 - 12:44

Hello everyone.

 

The developers of PHPMailer have patched a critical vulnerability that can be exploited by a remote attacker for arbitrary code execution.

 

The vulnerability was patched by PHPMailer developers on December 24 with the release of version 5.2.18. All prior versions are affected...

 

What to do??

If you are using PHPMailer older than 5.2.18 in your own PHP applications, themes or plugins, please upgrade to PHPMailer 5.2.18 or newer immediately..

 

BR

Omar

 

 

 

 


Attribute filter Drop-downs

23 December 2016 - 21:28

Hello

I have install Attribute filter Drop-downs add-on http://addons.oscomm...com/info/5997 .  on osCommerce 2.3 BS Edge,

and it work well.

I edited that the  Attribute filter Drop-downs box will be hidden on the  index page and show when another pages,

So I would like that when I chose some category that  the Attribute filter will look from chosen category not from all categories.

any advice?

here is the code

  <?php 
 
//return the setting options

// consists of: Shape 5, Type 1, Size 6, Material 7
//if a value has been selected, it will show as selected.

$opts = array( 1 => 'Size', 2 => 'Colour');

// the number before the word represents the option ID in the `product_options` table
// the word after contains the displayed name of the dropdown box, which would usually be the same as the name

//title of the box

$heading = 'Shop By:';

// you should not need to edit below this line 
//------------------------

$mainhtml = ""; //the var to hold all of the html

foreach ( $opts as $opt => $name) {
	
	unset($html);
	
	$html = "<tr><td width='125px'>
				$name 
			</td></tr>
			<tr><td>
			<SELECT name='$opt' onchange='document.m_srch.submit();'>
			<OPTION value='not'>---</OPTION>";//print the name of the box and start the drop down
	
	$sql = "SELECT `products_options_values_id` from `products_options_values_to_products_options` WHERE `products_options_id`='$opt'"; 
	$res = tep_db_query($sql);// get the values of all the options for that catagory
	while($id = tep_db_fetch_array($res)){
	
		$optnamear = tep_db_query("SELECT `products_options_values_name` from `products_options_values` WHERE `products_options_values_id`='$id[products_options_values_id]'");
		
		$optname = tep_db_fetch_array($optnamear);
		
		//create the dropdown
		
		$html .= "<OPTION value='$id[products_options_values_id]' ";
		
		if($_GET[$opt] == $id['products_options_values_id']){
			$html .= "selected='selected'"; // if the product has already been selected keep it selected!
			} 
		
		$html .= ">$optname[products_options_values_name]</OPTION>";
		
		
		}
		
		$mainhtml .= $html."</SELECT></td></tr>";
		
		
	
	} 


echo "<tr><td>
<table border='0' width='100%' cellspacing='0' cellpadding='0'>
  <tr>
    <td  width='100%' height='14' class='infoBoxHeading'>$heading</td>
	</tr>
	</table>
	<table border='0' width='100%' cellspacing='0' cellpadding='1' class='infoBox'>
			<tr><td>
			<table class='infoBoxContents'>
			<FORM name='m_srch' action='advanced_search_result.php' method='get'>
			<INPUT type='hidden' value='1' name='m_op'> <INPUT type='hidden' value='1' name='keywords'> \n
			$mainhtml
			</table>
			</td></tr>
			</FORM>
		</table>
	</td></tr>";  

?> 

 Or if some one have some add-on close to this that work on products_listing page?.

BR

Omar


product images not showing ocs 2.3 edge

12 November 2016 - 09:57

Hello,

the product images not showing but there are on the database and the uploading work also to the server.  and when I open the product image link on new tab

it show this error

Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500

i am not sure if it is  ..htaccess file but delete it was and re-upload new one was not help..

 

ocs 2.3 edge

any help