Jump to content



kymation

Member Since 10 Sep 2003
OFFLINE Last Active Today, 02:01
*****

#1753127 Theme Switcher and Oscommerce 2.3.4

Posted by kymation on 08 February 2017 - 17:12

The corners are generated by the theme, if I remember correctly. Use one of the theme generators available online to create a new theme and set corner radius to 0. I believe there is a link to a theme generator in the support thread for Theme Switcher, but there are many to choose from.

 

Regards

Jim




#1752531 Silly Question I think.....or Hope !

Posted by kymation on 23 January 2017 - 01:56

Most of the colors in 2.3.4 BS come from the theme. You can install a new theme manually or use the Theme Switcher Addon to manage your themes. There are many free themes available on the Internet or you can create your own.

 

There are many color picker addons (either for your OS of for your browser) that will tell you what color is being used. You can also read the color numbers from the code using Firebug or the debugger in Chrome.

 

Regards

Jim




#1751691 Xsell in Cart for Modular Shopping Cart (Responsive)

Posted by kymation on 30 December 2016 - 01:50

I missed this comment somehow. Sorry for being so slow.

 

The call to the function is spelled the same way, so everything works just fine. However, it's inconsistent with the rest of the module, so the spelling really should be changed both places.

 

Thanks for bringing that to my attention.

 

Regards

Jim




#1750626 2.4 Series

Posted by kymation on 01 December 2016 - 23:29

I have done a lot of testing and the 2.4 Beta is very solid. The obvious bugs have already been fixed, along with most of the non-obvious bugs. The remaining bug reports seem to be edge cases that most store owners will never see. The current codebase is already of better quality than any of the 2.2 versions, none of which were ever actually released. I would not hesitate to use this code to build a simple store that did not need a lot of Addons. It's that solid.

 

The osCommerce downloads page also shows the 2.4 Beta download, so anybody who's paying attention will see that osC is being updated. I don't know when the final release will be, but with the one-click update engine in place it doesn't really matter. The version numbers start to become meaningless when it's that easy to keep up to date.

 

Regards

Jim




#1750547 Introducing the Conversational Form : Futur of the web form ?

Posted by kymation on 30 November 2016 - 02:53

Very light gray text on a white background. Tell them to go look up the Web Accessibility Standards and let me know when they've fixed that mess.

 

Seriously, are there any web designers who realize that some of us don't have perfect eyesight?

 

Regards

Jim




#1750455 [Addon} Modular Front Page

Posted by kymation on 27 November 2016 - 21:41

There is a static version of the New Products module included in the Modular Front Page download. There is a static Featured Products Addonavailable. I don't know what you're using the Nivo Slider for, but it probably duplicates one of the above.

 

Regards

Jim




#1750449 [Addon} Modular Front Page

Posted by kymation on 27 November 2016 - 20:36

It sounds like one of the other modules is interfering. Try adding this code before the first div in /includes/modules/content/front_page/templates/cm_fp_text_main.php:

        <div class="clearfix"></div>

From the module list you posted above, everything on your front page is going to be moving. This is a common beginner's mistake. You will drive away many of your customers, and make the front page essentially unusable. I suggest you remove all but one of those, and make the rest of the modules static.

 

Regards

Jim




#1750202 osCommerce Online Merchant v2.4.0 Joli Beta

Posted by kymation on 21 November 2016 - 22:03

I know this has been said before, but can we please get rid of the ancient demo products? They may have been fresh and relevant 15 years ago, but now they just make osCommerce look old and tired.
 
The community has donated a nice selection of new products that are available to use. If you don't want to use those, please find some modern products that you like and use those instead.

 

Regards

Jim




#1749251 Install on new LAMP server PHP7 and MySQL 5

Posted by kymation on 29 October 2016 - 03:43

Or you can avoid all of these patches by installing the Bootstrap Edge version, and be up to date as well.

 

Regards

Jim




#1748957 Spam addon

Posted by kymation on 22 October 2016 - 16:53

There is definitely spam in the Addons section. I found two that were pure commercial advertising and another that was malicious code. I reported all of them, and nothing was ever done. You should probably just ignore this one.

 

Regards

Jim




#1748661 Call the value of the variable category in boxing module

Posted by kymation on 16 October 2016 - 23:47

Add this line just above the code you posted:

global $current_category_id;

Regards

Jim




#1748309 USPS Rate V4, Intl Rate V2 (official support thread)

Posted by kymation on 08 October 2016 - 21:15

Yes it requires commercial rates. Beware the Online vs. Retail as that also changes the rate structure.

 

Regards

Jim




#1748098 OSC 2.2 Links do not work in Admin

Posted by kymation on 02 October 2016 - 18:44

My advice is to walk away. You are going to spend a hundred (or more) hours fixing this old code, at least if you do it properly. By properly I mean a fully working, secure site. If you're not willing to donate all of that work, and you friend is not able to do it, his employer needs to hire somebody who can. It's that simple.

 

Regards

Jim




#1747904 Compatibility Core Change

Posted by kymation on 28 September 2016 - 01:19

Thanks to @raiwa for taking a shot at this. This will remove a lot of the barrier to using older (2.3.x) Addons.

 

The code that Gary mentioned is here if anybody wants to look at it or use it. It does modify application_top.php as that was the only way to make it work when I wrote the code. Of course that modification could be in another file, such as the compatibility function file that Gary mentioned, or in a hook.

 

I don't want to start another flame war, but I think that a hook in application_top.php would be good enough for 99% of the old Addons. The exceptions are probably too complex and invasive to work with the new code, so they will have to be modified before they can be used. I'm fine with covering the majority with a simple compatibility Addon. If that means I have to write some code, I'll do that.

 

Regards

Jim




#1747485 USPS Rate V4, Intl Rate V2 (official support thread)

Posted by kymation on 12 September 2016 - 16:14

@opus_uno2001  No, add the line. It doesn't replace anything.

 

Regards

Jim