Jump to content



Issue Information

  • #000665

  • 0 - None Assigned

  • New

  • 2.3.3.3

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

admin/review.php Error 2.3.3.4

Posted by joli1811 on 01 January 2014 - 01:00

Error log from admin

[31-Dec-2013 19:52:46 America/New_York] PHP Warning: array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #3 is not an array in /home/xxxxxx/public_html/demo9/admin/reviews.php on line 221
[31-Dec-2013 19:52:46 America/New_York] PHP Warning: array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #2 is not an array in /home/xxxxx/public_html/demo9/admin/reviews.php on line 222
[31-Dec-2013 19:52:46 America/New_York] PHP Warning: reset() expects parameter 1 to be array, null given in /home/xxxxxx/public_html/demo9/admin/includes/classes/object_info.php on line 17
[31-Dec-2013 19:52:46 America/New_York] PHP Warning: Variable passed to each() is not an array or object in /home/xxxxxx/public_html/demo9/admin/includes/classes/object_info.php on line 18
[31-Dec-2013 19:52:49 America/New_York] PHP Warning: array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #1 is not an array in /home/xxxxxx/public_html/demo9/admin/reviews.php on line 75
[31-Dec-2013 19:52:49 America/New_York] PHP Warning: reset() expects parameter 1 to be array, null given in /home/xxxxxx/public_html/demo9/admin/includes/classes/object_info.php on line 17
[31-Dec-2013 19:52:49 America/New_York] PHP Warning: Variable passed to each() is not an array or object in /home/xxxxxx/public_html/demo9/admin/includes/classes/object_info.php on line 18

Fix I done was to change lines to...

Line : 75

$rInfo_array = array_merge((array)$reviews, (array)$products, (array)$products_name);
$rInfo = new objectInfo($rInfo_array);

and

lines : 221 to
$review_info = array_merge((array)$reviews_text, (array)$reviews_average, (array)$products_name);
$rInfo_array = array_merge((array)$reviews, (array)$review_info,(array) $products_image);
$rInfo = new objectInfo($rInfo_array);

seems to be working nothing more now in the error log.
Regards
John

This fix only hides the error; it does not solve the underlying problem. The error messages are trying to tell you that data is missing. You need to find out why that data is missing and fix that.

Regards
Jim

Hi Jim ,

Yes you are right I was upgrading an old database when this happened corrected now the Table:reviews

the good thing that came out is found a small bug in the /admin/includes/ language defines

define('TEXT_INFO_IMAGE_NONEXISTENT', 'IMAGE DOES NOT EXIST');

should be

define('TEXT_IMAGE_NONEXISTENT', 'IMAGE DOES NOT EXIST');

or maybe this needs to be added extra

so happy days caught a bug /w00t.gif' class='bbc_emoticon' alt='(w00t)' />

Thanks
John

I reported that little bug sometime ago http://forums.oscomm...r&showissue=641 and it hasnt been fixed, I reckon the powers that be obviously think nothing of it.