Jump to content



Issue Information

  • #000506

  • 0 - None Assigned

  • New

  • 2.3.2

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

Problem in installing version 2.3.3

Posted by Eduardo9350 on 13 September 2012 - 11:17

I have installed many times the OSC latest releases. All OK.
The catalog home page of the 2.3.3 release is as in the following image:
osc2.3.3catalog.jpg
I hope to be helpful to solve the problem.

Everything works correctly.
Probably my server has created the problem described above.

After further insights, I have found that there is a installation problem really.

I've attached the phpinfo data of the Italian Server (www.aruba.it) so you can check the settings. Here, the installation creates the problem described in my first topic

Also follow the phpinfo data relating to the Web Server www.000webhost.com, where the installation is successful.

Attached Files



I have the same problem using Aruba .
If I delete the .htaccess in the images folder, images are displayed.
this is .htaccess file:

# $Id$
#
# This is used to restrict access to this folder to anything other
# than images

# Prevents any script files from being accessed from the images folder
<FilesMatch "\.(php([0-9]|s)?|s?p?html|cgi|pl|exe)$">
Order Deny,Allow
Deny from all
</FilesMatch>

Options -Indexes

and for security reason doesn't allow php pages to show iamges .... (I think so)
Someone can help me?

I have the same problem using Aruba .
If I delete the .htaccess in the images folder, images are displayed.
this is .htaccess file:

# $Id$
#
# This is used to restrict access to this folder to anything other
# than images

# Prevents any script files from being accessed from the images folder
<FilesMatch "\.(php([0-9]|s)?|s?p?html|cgi|pl|exe)$">
Order Deny,Allow
Deny from all
</FilesMatch>

Options -Indexes

and for security reason doesn't allow php pages to show images .... (I think so)
Someone can help me?

To solve the problem change into following .htaccess files:

catalog/ext/.htaccess
catalog/images/.htaccess
catalog/pub/.htaccess

the:
Options -Indexes
Options +FollowSymLinks -Indexes

with:
#Options -Indexes
#Options +FollowSymLinks -Indexes

Hi,

Have really no idea why but can confirm Options -Indexes in the .htaccess does give problems with some servers as regards image and jquery have removed twice now on different servers ?
Later just changed server.

Regards
Joli

Later just changed server.


You feel that for this problem it is necessary to change the server?

To solve the problem change into following .htaccess files:

catalog/ext/.htaccess
catalog/images/.htaccess
catalog/pub/.htaccess

the:
Options -Indexes
Options +FollowSymLinks -Indexes

with:
#Options -Indexes
#Options +FollowSymLinks -Indexes

 

 

I have tested the new version 2.3.4. As always, after installing the images are not visible.
To solve the problem I deleted
Options-Indexes
Options + FollowSymLinks-Indexes

within these two files

catalog / ext / .htaccess
catalog / images / .htaccess

I would like to know whether this maneuver or force can cause some problems in the future.



Product Images (and others) not shown after Installing new Version of OSC V2.3.4

 

After several Installations from scratch the Images still were not visible.

(...Grummel...)

 

The explanation above helped me to fix exactly this issue.

Great day. Thanks :-)

 

 

 

 



Do you enable directory listing to your site?



Do you enable directory listing to your site?

So what can happen?