Jump to content



Photo
- - - - -

How to move osCommerce?


This topic has been archived. This means that you cannot reply to this topic.
26 replies to this topic

#1   dchau

dchau
  • Members
  • 5 posts

Posted 05 March 2004 - 23:57

Hi Everyone,

I need help on how to move osCommerce to a new web host. The original webmaster that set everything up in gone. And I have no clue on what to do.

I'm sure there's more to it than moving updating the DNS name for the server, and transfering the files to the new host.

Does anybody have a step-by-step manual or checklist?

Thanks.

DC

#2   241

241
  • Members
  • 6,181 posts

Posted 06 March 2004 - 00:08

backup the database, download all your files, upload all your files to new server, import your backed up database change the paths and information in the two configure.php files admin/includes/configure.php and catalog/includes/configure.php
No longer giving free advice. Please place deposit in meter slot provided. [img]http://forums.oscommerce.com/style_images/1/folder_post_icons/icon1.gif[/img] Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! [img]http://forums.oscommerce.com/style_emoticons/default/tongue.gif[/img]


Support The Project
Documentation/Knowledgebase/Discussions
My Contributions

#3   dchau

dchau
  • Members
  • 5 posts

Posted 09 March 2004 - 07:37

Thanks 241.

I'll give it a try, I hope it works out. Otherwise I'd have to call in the pros, and end up with a huge bill.

#4   dchau

dchau
  • Members
  • 5 posts

Posted 19 March 2004 - 19:45

Hi, I've moved osCommerce to the new site, and the SQL database was imported successfully.

Everything in the catalog seems to be working fine. However, I have a strange problem.

when I type in the address:

www.my-domain.isp/shop/admin

the admin page doesn't allow me to login, it doesn't accept my password. Did I leave something out somewhere?

#5   dchau

dchau
  • Members
  • 5 posts

Posted 19 March 2004 - 20:57

I forgot to add:

Does it have something to do with .htaccess? Which directories do I need to add them in?

Thanks for your help!

#6   pracing

pracing
  • Members
  • 50 posts

Posted 14 January 2007 - 15:21

I am about to do this as well.

Hope it works!

#7   storm

storm
  • Members
  • 147 posts

Posted 08 March 2007 - 16:27

I am about to do this as well.

Hope it works!



Did it work for you - I am in a similiar situation.

#8   pederb

pederb
  • Members
  • 448 posts

Posted 13 March 2007 - 15:58

Hi, I've moved osCommerce to the new site, and the SQL database was imported successfully.

Everything in the catalog seems to be working fine. However, I have a strange problem.

when I type in the address:

www.my-domain.isp/shop/admin

the admin page doesn't allow me to login, it doesn't accept my password. Did I leave something out somewhere?


Excuse a maybe stupid question, but where is the SQL database located?
-Peder Beckman-
Kool Kat Jazz Records

#9   pederb

pederb
  • Members
  • 448 posts

Posted 13 March 2007 - 16:14

Never mind I found it.

Thxs
-Peder Beckman-
Kool Kat Jazz Records

#10   cabachona

cabachona
  • Members
  • 49 posts

Posted 22 January 2009 - 07:58

backup the database, download all your files, upload all your files to new server, import your backed up database change the paths and information in the two configure.php files admin/includes/configure.php and catalog/includes/configure.php

Will this help if I do a fresh install, then simply upload my catalog to the install directory? My idiotic server people have taken it upon themselves to copy and paste my entire catalog to a new folder for a sub-domain so it can be redirected. They did this without warning and I have since been adding items to my new folder. Only trouble is that all my backups are going to the old folder they told me I could safely delete. When I re-named it to old catalog, I got error messages with no images showing. So I renamed it back and now it works. Just two catalogs instead of one!
Why is it so hard to get people who should know what they are doing to listen to you when you've just told them that you've installed the program - not just copied it and uploaded it! (Don't answer, it is rhetorical anyway you look at it)
Any help will do, thanks in advance /rolleyes.gif' class='bbc_emoticon' alt=':rolleyes:' />
Unconditional Love Makes The World Turn.
When we stop and smell the flowers, we can all live instead of merely existing. We spend too much time infront of computers daily and not enough time in wonderment and awe at what we can achieve in life. creating these beasts is both a blessing and a curse!
Believe in yourself as though no one else will and you will find that The World will begin to believe in You Too!

#11   seiki73

seiki73
  • Members
  • 3 posts

Posted 08 January 2010 - 16:08

Hi, I've moved osCommerce to the new site, and the SQL database was imported successfully.

Everything in the catalog seems to be working fine. However, I have a strange problem.

when I type in the address:

www.my-domain.isp/shop/admin

the admin page doesn't allow me to login, it doesn't accept my password. Did I leave something out somewhere?



Did it work for you - I am in a similiar situation.


Sorry to bring this up again. But has anyone of you had any luck with this? I have not been able to login in ever since I moved my files. ( I changed URL and hosting)

I am not being able to log in with any user.

#12   mdtaylorlrim

mdtaylorlrim
  • Members
  • 2,497 posts

Posted 08 January 2010 - 16:40

Does anybody have a step-by-step manual or checklist?

I can try one, not sure if I will get all the steps, but with the resources here there will surely be folks that can add to or correct this.


1. Back up your database in pure sql. No compression. Note the name of it. Note the path to it.
2. Download your entire store using an ftp client that is capable of automatically changing from ascii to binary mode and be sure it is set to transfer php,xml,sql, and css files in ascii. All image files in binary.
3. Have your domain name transferred to the new host.
4. FTP your files to the new host.
5. Get login information for sql server, and absolute path to your file space from new host.
6. Change configure.php files to reflect new login information and paths.
7. Using phpMyAdmin, run the sql file of your last db backup.
8. Log in/start troubleshooting.

Most errors will be in the path values in the configure.php files. Just knowing the URL to your store is not enough. You need to know the exact path from / to your file space, usually something like /var/www/yourname/public_html/ or something.
Avoid the most asked question. See How to Secure My Site and How do I...?

#13   Kjolebutikken

Kjolebutikken
  • Members
  • 491 posts

Posted 10 April 2010 - 18:14

Hi,

I'm also moving my store from one host to another, but also to another domene.
I've tried to use the explanations above in this thread, but I don't understand all of it.

I have updated my database and stored the sql file on my computer.
I have downloaded all files from my old webhotell and uploaded to my new webhotell at my new domain.

Since I have changed domain also, I need to change that in all necessary files.

In the configure.php files, I especially wonder how to change this code:

define('DIR_FS_DOCUMENT_ROOT', '/customers/myoldsite.com/myoldsite.com/httpd.www/catalog/'); // where the pages are located on the server


For my new site I have changed it to:

define('DIR_FS_DOCUMENT_ROOT', '/customers/mynewsite.no/mynewsite.no/httpd.www/public_html/catalog/'); // where the pages are located on the server

When I open my ftp for my new domain, all my files is in a folder called public_html. Therefore all files are at public_html/catalog.

Is the above correct?
Is mynewsite.no supposed to be there twice?
I do not know where the /customers/ come from? Is it from the oscommerce installation?

I have got several info from my new host when creating the new webhotell, but I'm not sure what info to put in the code above, so please help :-)


Thanks!
Best regards
Kjolebutikken

#14   Kjolebutikken

Kjolebutikken
  • Members
  • 491 posts

Posted 10 April 2010 - 19:03

And also wonder, do I have to perform a new install of oscommerce in my new webhotel, and then go through the configuration steps there, like I did the first time? Or is it sufficient to upload database, upload storefiles, and change in configure.php files?


Thanks :-)
Best regards
Kjolebutikken

#15   MarD

MarD
  • Members
  • 15 posts

Posted 31 August 2010 - 17:52

I just uploaded my site to my new server and changed everything that was needed (configuration files, permissions, imported database).
Everything looks to work fine except some images that aren't displayed.
Since I have repair my permissions (644 for files, 755 for folders), I can't figure out what's wrong.

So, anybody can help?
URL: http://www.coolmodels.gr/index.php

Thanks guys...

#16   TolleyM

TolleyM
  • Members
  • 49 posts

Posted 10 March 2011 - 13:35

hi

i am just trying to move a website from one host to another - to complicate matters the domain name is also changing

i have downloaded all files via ftp from old website
uploaded all files on new website
imported last copy of database
changed the 2 config files

but when i type the website in browser all i get is a download box pop up and the browser download the index file

web address is www.poloart.co.uk

this also happens if i put

www.poloart.co.uk/admin

anyone any ideas

#17   TolleyM

TolleyM
  • Members
  • 49 posts

Posted 10 March 2011 - 13:43

an update - managed to get rid of error above but still not quite there

get lots of other errors - i will update if i fix and if anyone had any ideas, can they let me know

mark

#18   TolleyM

TolleyM
  • Members
  • 49 posts

Posted 10 March 2011 - 14:51

sorted it

basically when i downloaded all the files, it skiped all the files in the modules directory

uploaded them and everything works fine so happy to report the the process listed in previous posts is spots on

problem was user error - ie me

thanks

mark

#19   brigantine

brigantine
  • Members
  • 1 posts

Posted 23 March 2011 - 04:53

Hi, I've got a variation on the theme here. The catalog came over to the new location, fine. Working great!

When I try to go to admin, I get a configuration error.

Looking at the server log, the error indicates it cannot find the OLD path to the admin directory

I have queried the configuration table in the database, double checked the three configure.php files (we have chosen to go with a distinctly named admin path, the original admin path still exists, hence 3 configuration.php files.) All three configure.phps have the correct new path.

I've done a text search on every folder I can think of for the old path. All to no avail.

Where is that bugger hiding?

Thanks,

Brig

Edited by brigantine, 23 March 2011 - 04:54.


#20   onliner13

onliner13
  • Members
  • 1 posts

Posted 09 May 2011 - 23:23

I moved my oscommerce website to a new domain name within the same hosting account! I followed the usual steps and updated both config files. I used the same database from the previous domain name so no changes were made there! Everything works perfect except on the new site, all the buttons images are missing! Although the links work as they supposed to!

Please help! Thanks in advance!