Jump to content



Photo
- - - - -

can't reach admin... .htpasswd_oscommerce work around?


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1   jason8285

jason8285
  • Members
  • 3 posts

Posted 05 August 2012 - 15:57

hi all, I've tried installing 2.3.2 on a free hosting site while i work on a webpage but can't seem to reach the admin panel. I've had an older version of oscommerce work before on the same host but that version never needed the .htpasswd_oscommerce file. The host won't allow the file on the server and I think I can't login as admin because of this. Is there a work around for this file? Is it even really needed since the database is already populated with my admin credentials? I've been scouring the forums for more information but haven't found the correct fix. Closest I've come to an answer was to clear the action record, sessions, and admininstrator tables and input new credentials. But when I do that, the usename field always return blank in the database and I have to manually enter my username. Still have invalid login attempt. If anyone has time I would appreciate it.

#2   DunWeb

DunWeb

    The Censored One

  • Members
  • 13,084 posts

Posted 05 August 2012 - 16:21

@jason8285

The admin .htaccess password is NOT required. If you didn't enable it, it won't prevent you from accessing the admin area.

I suggest uploading the two files again and over-write the existing files. This will disable .htaccess protection. Furthermore, with hosting as cheap as $4.00 a month, why would anyone ever choose FREE limited hosting...??????




Chris
:|: Was this post helpful ? Click the LIKE THIS button :|:

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

#3   jason8285

jason8285
  • Members
  • 3 posts

Posted 05 August 2012 - 16:57

touché DunWeb. I really should purchase another host so I can at least have full access to what I need. I went the free route for practice while i decide which CMS to use for future endeavors.

I've replaced the two ht files but with no avail. And again I can't even get the htpasswd file onto the server. Burt suggested yesterday that I might redownload the dist and try a fresh install, but this damn free host makes that a two day filefest with their limited concurrent connections. Sounds like the answer is to just belly up and find a better host.

I still can't help but to want to repair this installation. I really think everything will work as intended once I get into my admin panel. If that file isn't needed then is there by chance some other reason why my only error reads: Error: Invalid administrator login attempt. Does the database have to be in ascii for both username and password? Maybe something with the blank username field in the administrator table when I empty the administrator table to reset the password?

#4 ONLINE   Gergely

Gergely

    Action Hero

  • Community Team
  • 1,123 posts

Posted 05 August 2012 - 18:14

@jason8285

sounds like some problem with password class. Maybe DIR_WS_CLASSES or some server problems there are. Would be helpfull if you can switch on debugs to clarify errors.
Look after server error reports or try to use http://addons.oscommerce.com/info/7705/v,23 in admin site
some rewrites :-)