Jump to content



Photo

Images not showing on homepage


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1   redgemini

redgemini
  • Members
  • 3 posts

Posted 14 June 2012 - 10:59

The images are not showing on my homepage when you type in my URL, but when you click on any of the links to my homepage from the homepage they load, how can I change this?

URL is http://www.creativeallsorts.com

#2   Praful Kamble

Praful Kamble
  • Members
  • 325 posts

Posted 14 June 2012 - 11:08

Found img src="" missing.
Like post..hit LIKE button.

osCommerce | Joomla | WordPress | Magento | SEO | CakePHP | CI

Guaranteed Website Speed Optimization!!

#3   Praful Kamble

Praful Kamble
  • Members
  • 325 posts

Posted 14 June 2012 - 11:18

When you click any of the product link Url becomes: http://creativeallso...oucael2gmangd13

http://creativeallso...com/oscommerce/index.php site appears cool.

Check configuration properly.
Like post..hit LIKE button.

osCommerce | Joomla | WordPress | Magento | SEO | CakePHP | CI

Guaranteed Website Speed Optimization!!

#4   MrPhil

MrPhil
  • Members
  • 5,186 posts

Posted 14 June 2012 - 16:13

On the product page, the image is in /oscommerce/images/. Apparently on the front page, osC (tep_image() call) is looking in the wrong place (perhaps /catalog/images/?) for the image, and finding nothing, is outputting no image tag <img src="/oscommerce/images/XYZ.png" /> in the link. I don't know why osC would be looking in two different places for index.php and product_info.php. Ditto for "What's New" on the front page. Do you have any add-ons installed? Check DIR_WS_IMAGES "define" for correctness (in configure.php), although that should be the same everywhere (i.e., if it works in one place it should work in all). If the database entry (file name) is working in product_info.php, it should be working in index.php too. Did someone modify index.php to handle images differently? You should see code like
... . tep_image(DIR_WS_IMAGES . $name_from_database,...
in index.php, product_info.php, and bm_whats_new.php.

#5   redgemini

redgemini
  • Members
  • 3 posts

Posted 18 June 2012 - 12:31

I have noticed my index.php that my domain (and "Top" link on the nav bar) links to is in the the root directory, but the index.php file my "Catalog" link on the nav bar links to is in the osc directory... how do I get them all to link to the one in the osc folder?

#6   info@iafrate.net

info@iafrate.net
  • Members
  • 1 posts

Posted 12 October 2012 - 03:36

I had the same problem and I fixed it up deleting this line :

Options -Indexes

in the .htaccess file in the images folder. Problem is probably this line was written for security reasons ....

#7   MrPhil

MrPhil
  • Members
  • 5,186 posts

Posted 14 October 2012 - 13:52

Wrong. Options -Indexes prevents an index file from being automatically generated in a directory when a visitor accesses a directory (such as your images directory) that has no index file. The purpose is to block them from seeing the contents of the directory listed. If somehow you were accessing an image with just the file path and no filename, it might show you a list of files in the directory. There's no way that it would cause the symptoms described earlier.

It is good practice to either have Options -Indexes (in the /.htaccess file) or put in a "Move along. Nothing to see here" dummy index.html or index.php in all directories on your site, so that inquisitive explorers can't look around at your files.