Jump to content



Photo

Can't acess localhost/catalog


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1   dlw1146

dlw1146
  • Members
  • 4 posts

Posted 17 March 2012 - 08:34

Changed password setting up security and can not access /localhost/catalog.
How do I solve this?

#2   geoffreywalton

geoffreywalton

    Available for Hire

  • Community Sponsor
  • 8,209 posts

Posted 17 March 2012 - 09:49

How are you prevented from access ing it?

G
Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

Virus Threat Scanner
My Contributions
Basic install answers.
Click here for Contributions / Add Ons.
UK your site.
Site Move.
Basic design info.

For links mentioned in old answers that are no longer here follow this link Useful Threads.

If this post was useful, click the Like This button over there ======>>>>>.

#3   PupStar

PupStar
  • Members
  • 644 posts

Posted 17 March 2012 - 12:55

by 'localhost/catalog' do you mean you are using XAMPP or WAMP etc etc???

If so then the username is 'root' and the password is left blank.

or do you mean you can not get into the admin area, if so then go to your control panel and use phpmyadmin to truncate the administrators table.

Mark

Edited by PupStar, 17 March 2012 - 12:56.


#4   dlw1146

dlw1146
  • Members
  • 4 posts

Posted 18 March 2012 - 22:55

When setting up I left the password blank.
Later, when checking status in xampp, I set up a password.
Where the password is I do not know.

#5   dlw1146

dlw1146
  • Members
  • 4 posts

Posted 18 March 2012 - 23:37

Below is the error message.

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in C:\xampp\htdocs\catalog\includes\functions\database.php on line 19
Unable to connect to database server!

#6   ja1nsa

ja1nsa
  • Members
  • 24 posts

Posted 23 March 2012 - 18:19

HA ha .. someone just as nieve as myself. I did this yesterday ... now how did I fix it ....

Give me 5 mins to look it up and I'll post ... brb.

#7   ja1nsa

ja1nsa
  • Members
  • 24 posts

Posted 23 March 2012 - 19:10

ok, this is what worked for me ...

1 : go to your WAMP icon on your PC desktop screen and LEFT CLICK to open the menu, you will see MYSQL folder, CLICK to see MYSQL CONSOLE, open it.

2: now you have DOS screen ( a black screen ) :

A: if you already set a password, type it
B: if you did not do this step yet, write the following red text
B1: use mysql; and click ENTER on your keyboard
3: now write the following red text and click ENTER :

UPDATE mysql.user
->SET Password=PASSWORD("*******")
->WHERE User="root";

don't worry about this sign ( -> ) , because for example when you write ( UPDATE mysql.user ) and you click ENTER on your keyboard, a new line appear with this sign ( -> ), your command will execute when you write this sign ( ; ) at the end of your text and click ENTER.

NOTE: replace the password ******* by your password.

4: now write the following red text and click ENTER :

FLUSH PRIVILEGES;

5: and to exit the black DOS

Hope you have the same results!

#8   spooks

spooks
  • Members
  • 7,017 posts

Posted 24 March 2012 - 00:45

Thanks for posting your solution, makes a nice change. /thumbsup.gif' class='bbc_emoticon' alt=':thumbsup:' />
Sam

Remember, What you think I ment may not be what I thought I ment when I said it.

Contributions:


Auto Backup your Database, Easy way

Multi Images with Fancy Pop-ups, Easy way

Products in columns with multi buy etc etc

Disable any Category or Product, Easy way

Secure & Improve your account pages et al.

#9   alexboi

alexboi
  • Members
  • 2 posts

Posted 08 May 2012 - 09:33

OsCommerce 3.x is compatible to php5?