Jump to content



Photo
- - - - -

HTML validation


This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1   semper-linux

semper-linux
  • Members
  • 42 posts

Posted 08 August 2011 - 17:19

Using OSC V2.3.1 with Header Tags SEO with Google Analytics code
site :- www.custompc.ch


Hi Forum,

I just thought I'd run index.php through HTML validation and was horrified to find a fistful of errors being reported (30 errors - 36 warnings !!!)

I've included a short sample of the output.........



******** BEGINNING OF OUTPUT ********

# Error Line 4, Column 70: end tag for "meta" omitted, but OMITTAG NO was specified

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" >



You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".
# Info Line 4, Column 2: start tag was here

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" >

# Error Line 6, Column 88: end tag for "meta" omitted, but OMITTAG NO was specified

…ame="Description" content="High performance, custom-built, quality computers" >



You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".
# Info Line 6, Column 2: start tag was here

<meta name="Description" content="High performance, custom-built, quality comp…

# Error Line 7, Column 77: end tag for "meta" omitted, but OMITTAG NO was specified

<meta name="Keywords" content="custom-built, high-performance, computers" >



You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".
# Info Line 7, Column 2: start tag was here

<meta name="Keywords" content="custom-built, high-performance, computers" >

******* END OF OUTPUT ********


The page tested is the "source" of the home page which I guess is interpreted and assembled from index.php, template_top.php and all the other relevant files.

I can see many of the errors - mostly spaces before the closing > tag. Is this OK ?

Is this not going to upset the crawlers and, in the end, page / site ranking ?


Can anyone put this concerned little mind at rest ?!?

Many thanks
semper-linux

Edited by semper-linux, 08 August 2011 - 17:30.


#2   Hotclutch

Hotclutch
  • Members
  • 1,243 posts

Posted 08 August 2011 - 18:14

Osc 2.3.1 validates out of the box for XHTML. Your errors will be due to addons you install. eg

Replace

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" >

with

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

will reduce some errors.

#3   semper-linux

semper-linux
  • Members
  • 42 posts

Posted 11 August 2011 - 16:01

Hi Hotclutch,

Thanks for the reply - my apologies for a late answer - I didn't get the automatic notification of a reply.

I found the following in template_top.php.................

/*** Begin Header Tags SEO ***/
if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
require(DIR_WS_INCLUDES . 'header_tags.php');
} else {
?>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>
<?php
}
/*** End Header Tags SEO ***/


Looks like the Header Tags SEO mod is involved here.

I think I'll contact the HT-SEO developer.

Thanks for the clue.

semper-linux.