Jump to content



Photo
- - - - -

Forgotten Admin Password in OSC 2.3


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1   aftabn10

aftabn10
  • Members
  • 214 posts

Posted 26 July 2011 - 10:15

Hi, unfortunately I have forgotten my admin password for my online shop. I had enabled the .htaccess through admin but now i cant login. I have tried changing the password in the database alongwith the .htpassword file but this still doesnt let me in. Can any1 please help and let me know if there is anything else that i can try.

Thanks in advance.

#2   DunWeb

DunWeb

    The Censored One

  • Members
  • 13,084 posts

Posted 26 July 2011 - 13:47

Aftab,


Using phpmyadmin in your hosting control panel, truncate the administrators table.


Then, log back into your admin area, it will instruct you to create a NEW admin username and password. Do as instructed and log in as normal.


If you have enabled .htaccess protection, you will need to edit the /admin/.htaccess file and remove the protection line.


Chris
:|: Was this post helpful ? Click the LIKE THIS button :|:

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

#3   aftabn10

aftabn10
  • Members
  • 214 posts

Posted 27 July 2011 - 10:26

DunWeb, thanks that seems to have worked, but i am now getting the following error:

Warning: main(C:/xampp/htdocs/oscommercenew/catalog/includes/classes/action_recorder.php) [function.main]: failed to open stream: No such file or directory in /homepages/29/d116169/htdocs/mdz/md/admin/includes/classes/action_recorder.php on line 13
Not sure why, but i am guessing might have something to do with what i have defined in the config file.

Edited by aftabn10, 27 July 2011 - 10:27.


#4   aftabn10

aftabn10
  • Members
  • 214 posts

Posted 28 July 2011 - 08:42

DunWeb, thanks for all your help, i have managed to sort the issue out as it was an error in my config file. Really appreciate it.

#5   Barbara Carrera

Barbara Carrera
  • Members
  • 10 posts

Posted 31 August 2011 - 12:25

Hi,

DunWeb at all

I've followed your instruction but I'm still getting the "A user name and password are being requested by http://www.xxx.com. The site says: "osCommerce Online Merchant Administration Tool" error

I found the right database & trucated the password. Then you say "Then, log back into your admin area, it will instruct you to create a NEW admin username and password. Do as instructed and log in as normal"

Unfortunately, I'm unable to do so because when I try to log into osCommerce (Online Merchant Administration Tool) get the pop up password box. I have previously enabled the extra password security measure from within the Admin dashboard.

I also tried the solution with inserting the line into administrators table from within the phpMyAdmin. While the new details
were successfullyinserted that didn't work either.

Any suggestions how to change the apssword will be much appreciated.

Cheers

Barb

#6   satish

satish
  • Members
  • 5,350 posts

Posted 31 August 2011 - 17:53

http://www.oscommerc...tributions,5857
reset admin password will be of help.

Satish
Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

Check My About US For who am I and what My company does.

#7   Barbara Carrera

Barbara Carrera
  • Members
  • 10 posts

Posted 01 September 2011 - 01:00

Hi Satish,

I've tried the script but unfortunately it did not work. I'm getting the following error message:

Warning: require_once(includes/configure.php) [function.require-once]: failed to open stream: No such file or directory in /home/xxx/public_html/xxx_store/reset.php on line 6

Fatal error: require_once() [function.require]: Failed opening required 'includes/configure.php' (include_path='.:/usr/local/lsphp-5.2.17/lib/php') in /home/xxx/public_html/xxx_store/reset.php on line 6

It looks like it may be having problems with accessing appropriate files and directories under v 2.3.1?

Any suggestions?

Cheers

Barb

#8   Barbara Carrera

Barbara Carrera
  • Members
  • 10 posts

Posted 03 September 2011 - 10:31

Hi All,

Should this http://forums.oscommerce.com/topic/379316-lost-access-to-my-control-panel-cant-log-in/ also work for me? I've tried all that to no avail ... when I try login to my backend Administration Tool it just pops up the login box?

Any help appreciated

Barb