Jump to content



Photo

V3.01 Admin Logon error


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1   Mystefyer

Mystefyer
  • Members
  • 11 posts

Posted 14 April 2011 - 19:28

Hi guys,

Scoured the forums for a solution but found none that worked for me sofar :-(

I've installed a fresh install on my local webserver (Apache 2.2, PHP 5.5.3, MySQL 5.5.11)
All works fine except for the error I recieve when logging into the admin section :

Error: Identification of the store administrator failed. Please try again if you have been authorized to use this system.

Now I checked via PHPMyAdmin the hash of the password. Checked it against HashCalc MD5, got a diffent hash.
So removed the pass altogether in osc_administrators table, nogo, same error. As if it does not even check...

Do I need to setup some special folder permissions on the ftp side, or am I missing something.

Hope others have seen the issue and found a solution :-)

Thanks in advance

#2   Harald Ponce de Leon

Harald Ponce de Leon

    Healthy Giraffe

  • Core Team
  • 4,893 posts

Posted 15 April 2011 - 10:00

Hi Emile..

Did you use any special characters for your password? Can you re-install and try again with a simple password?

Thanks,
Harald Ponce de Leon

#3   Mystefyer

Mystefyer
  • Members
  • 11 posts

Posted 15 April 2011 - 10:52

Hmm Yes I used a "&" in my pass. Will try with more normal pass :-)
Thanks for the tip, keep you updated :-)

#4   Harald Ponce de Leon

Harald Ponce de Leon

    Healthy Giraffe

  • Core Team
  • 4,893 posts

Posted 15 April 2011 - 11:04

Hi Emile..

If it works with a simple password you may have magic_quotes_gpc enabled in php.ini. This is a deprecated setting and should be disabled.

If this is true for your case, please disable it, restart your webserver, and you can continue with a stronger password.

Kind regards,
Harald Ponce de Leon

#5   Mystefyer

Mystefyer
  • Members
  • 11 posts

Posted 15 April 2011 - 11:36

Well it works with a simple password indeed. Ill check the php.ini file.

Thanks!

Update : Just checked my php.ini. It was turned off..

Edited by Mystefyer, 15 April 2011 - 11:43.


#6   Harald Ponce de Leon

Harald Ponce de Leon

    Healthy Giraffe

  • Core Team
  • 4,893 posts

Posted 15 April 2011 - 11:56

Hi Emile..

That's strange! I will check this and confirm back with you.

Thanks,
Harald Ponce de Leon

#7   Harald Ponce de Leon

Harald Ponce de Leon

    Healthy Giraffe

  • Core Team
  • 4,893 posts

Posted 15 April 2011 - 13:59

Hi Emile..

I can confirm this bug. It only happens during the installation procedure. Changing the administrator password using the Admin -> Configuration -> Administrators application performs as normal.

I am looking into the issue now.

Kind regards,
Harald Ponce de Leon

#8   Harald Ponce de Leon

Harald Ponce de Leon

    Healthy Giraffe

  • Core Team
  • 4,893 posts

Posted 15 April 2011 - 14:33

Hi Emile..

This is now fixed for v3.0.2.

Relevant bug report:

http://forums.oscomm...d-during-setup/

Thanks for reporting this!

Kind regards,
Harald Ponce de Leon

#9   Mystefyer

Mystefyer
  • Members
  • 11 posts

Posted 15 April 2011 - 18:33

Hi Emile..

This is now fixed for v3.0.2.

Relevant bug report:

http://forums.oscomm...d-during-setup/

Thanks for reporting this!

Kind regards,



Glad to help :-)